• I’m on r7843 with Fedora 23,

    I have an Optiplex 760 in BIOS mode with one Sata HDD in it, with Ubuntu 16.04 just now imaged onto it (I had the image on hand), and it won’t exit to the HDD properly after network booting.

    The host is registered fully, but when visiting
    All I get is this:

    set fog-ip
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}

    So that’d be why chainloading is failing.

    I’ve looked at that URL with other registered host’s MAC in place, and I get the same thing.

    There doesn’t appear to be any Apache related errors.

    After removing the patch cable when the host reboots, Ubuntu 16.04 boots fine.

    After having updated the target host, and scheduling a capture, the above URL now produces the below, which looks appropriate.

    set fog-ip
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web= consoleblank=0 rootfstype=ext4 rootfstype=ext4 mac=00:23:ae:ab:73:7c ftp= storage= storageip= osid=50 irqpoll hostname=Opti760 chkdsk=0 img=Optiplex760Ubuntu1604 imgType=n imgPartitionType=all imgid=12 imgFormat= PIGZ_COMP=-6 hostearly=1 pct=5 ignorepg=1 type=up
    imgfetch init_32.xz
  • Moderator

    @adukes40 all working well, thanks Tom

  • @Tom-Elliott just updated Main and node. Chainloader seems to be working for registered and unregistered hosts now. Was able to register from remote location. Thanks.

    Hopefully Falko has the same results 🙂

  • Confirmed, found and fixed for unregistered hosts.

  • Moderator


    after confirming it to be working below, we got the call to an IT suite (unregistered in FOG) and this room had the chainloading isse

  • Updated to 7845, chainloading seems to fail if host is not registered.

    I tried from a remote site using the location plugin. the host was manually entered. It worked. I was able to get in the boot menu, I did a host unregister. the host removed itself, then it would not pxe back to the boot menu. Complained about the chainloader. Manually added, worked again. I also tried this at the Main’s site using a VM. I network booted from the VM and being it was not manually registered, it gets the chainloader error. As soon as I manually add the host to FOG, it works perfectly.

  • Moderator

    @Tom-Elliott thanks, all working for me

  • Had the same problem.
    Chainloading works fine r7845 (Ubuntu 14.04).

  • Should be fixed, thanks for reporting.

  • Moderator

    Ok, so I got Wayne wrong I suppose. Sounded like he had upgraded from r7843 to ??? after seeing the problem and fixed it. @falko Thanks for pointing me to read his post again. I am pretty sure @Tom-Elliott will fix this soon.

  • Moderator

    @Sebastian-Roth I am also on r7843 (Debian 8), and recieving "chainloading failed, hit ‘s’ " during the pxe boot. however if I set a download task, it will correctly perform the task

  • Moderator

    @Wayne-Workman So your machines booting/chainloading again properly?