Install fails - Git version May 21 22:55:22 2016 on Debian 8.4



  • Hi there. Trying to install the latest Git version on Debian 8.4:

    commit 75093841964ddb73d917e1408c015d91364c511c
    Merge: 1a598c1 d68efa5
    Author: Tom Elliott tommygunsster@gmail.com
    Date: Sat May 21 22:55:22 2016 -0400

    However at the installer fase:

    * You still need to install/update your database schema.
    * This can be done by opening a web browser and going to:
    http://192.168.0.7/fog/management
    

    My browser “hangs” when trying to reach 192.168.0.7/fog/management
    Tried it with 3 machines and many browsers.
    After 10 minutes Apache2 is still using 90% cpu, “top” tells me even after closing the browser.

    I can connect to http://192.168.0.7/ however so apache is running and working. This is the default homepage now (see under). Clicking op fog/ gives a “cannot reach destination” error in the browser, after 1 min waiting.


    Index of /

    [ICO] Name Last modified Size Description
    [DIR] fog/ 2016-05-22 10:20 -
    [DIR] html/ 2016-05-22 10:10 -
    Apache/2.4.10 (Debian) Server at 192.168.0.7 Port 80


  • Senior Developer

    @coco65 I’ve edited the code and removed the .mo files. They will only be generated if installlang variable is set.

    I can’t really remove the language menu item though. So not having the .mo files will make any language selected automatically defaulted to english.



  • @Tom-Elliott : Yes it works (the installer on Debian)! Thank you.

    A very small and not so important but funny detail: during installation I choose “Internationalization: no” as an option. However in the logon screen the languages are still shown and the default is Chinese, I think. The language list should not be there and/or default to English, I think.

    0_1463972879684_fog1.jpg

    0_1463972888310_fog2.jpg


  • Senior Developer

    Alright so a bit more testing I did find the issue. I have reverted the manager controller file to one that shouldn’t cause the issue you’re seeing anymore.

    Please update and all this should be fixed.


  • Senior Developer

    I’m unable to replicate the issue. Not in any respect.



  • @Developers Found this in the Apache error log, during the install, when trying to surf to http://192.168.0.7/fog/management with web browser. Maybe that can help you?


    PDOStatement::execute(): MySQL server has gone away in /var/www/fog/lib/db/pdodb.class.php on line 169

    PDOStatement::execute(): Error reading result set’s header in /var/www/fog/lib/db/pdodb.class.php on line 169


    see attached log file:

    0_1463923506678_error.log


  • Developer

    @coco65 Anything in the apache error logs? See my signature below this message on where to find the error log.


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.