r7478 Advanced Boot Menu not worked



  • 0_1462367542212_untitled.png

    :MENU2
    menu
    item --gap – ---------------- AntiVirus Diagnostics ----------
    item avg AVG
    item kav Kaspersky
    item panda Panda
    item --gap – ---------------- Memory Diagnostics -------------
    item memtest Memtest86+ 5.01
    item msm Windows Memory Diagnostic
    item --gap – ---------------- HDD Diagnostics ----------------
    item fujitsu Fujitsu HDD Diagnostic
    item ibm IBM / Hitachi (OLD) HDD Diagnostic
    item samsung Samsung HDD Diagnostic
    item seagate Seagate HDD Diagnostic
    item seagateold Seagate Old HDD Diagnostic
    item seagatefirm Seagate HDD Firmware Diagnostic
    item seagatens Seagate HDD Barracuda ES Firmware Diagnostic
    item toshiba Toshiba HDD Diagnostic
    item wd Western Digital HDD Diagnostic
    item wdold Western Digital Old HDD Diagnostic
    item --gap – ---------------- Partition Managment --------------
    item mbrwizd MBR Rewrite
    item fog.fastwipe FastWipe
    item gparted GParted
    item src System Rescue
    item --gap – ---------------- Password Recovery ----------------
    item owpre Offline Windows Password & Registry Editor
    item return return to previous menu
    choose --default return --timeout 15000 target && goto ${target}
    :wd
    initrd http://${fog-ip}/IMG/wd.img
    chain memdisk keeppxe ||
    goto MENU2
    :wdold
    initrd http://${fog-ip}/ISO/wdold.img
    chain memdisk raw keeppxe ||
    goto MENU2
    :ibm
    initrd http://${fog-ip}/IMG/ibm.img
    chain memdisk keeppxe ||
    goto MENU2
    :seagate
    initrd http://${fog-ip}/IMG/seagate.img
    chain memdisk keeppxe ||
    goto MENU2
    :seagateold
    initrd http://${fog-ip}/IMG/seagateold.img
    chain memdisk keeppxe ||
    goto MENU2
    :seagatefirm
    initrd http://${fog-ip}/ISO/SeagateFirmware.iso
    chain memdisk iso raw ||
    goto MENU2
    :seagatens
    initrd http://${fog-ip}/ISO/ST31000340NS.iso
    chain memdisk iso raw ||
    goto MENU2
    :samsung
    initrd http://${fog-ip}/IMG/samsung.img
    chain memdisk keeppxe ||
    goto MENU2
    :fujitsu
    initrd http://${fog-ip}/IMG/fujitsu.img
    chain memdisk keeppxe ||
    goto MENU2
    :toshiba
    initrd http://${fog-ip}/IMG/toshiba.img
    chain memdisk keeppxe ||
    goto MENU2
    :memtest
    initrd http://${fog-ip}/ISO/mt501.iso
    chain memdisk iso raw ||
    goto MENU2
    :msm
    initrd http://${fog-ip}/IMG/msm.img
    chain memdisk keeppxe ||
    goto MENU2
    :fog.fastwipe
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=${fog-ip}/fog consoleblank=0 loglevel=4 capone=1 mode=wipe wipemode=fast mac=00:00:00:00:00:00
    imgfetch init_32.xz
    boot ||
    goto MENU2
    :gparted
    kernel http://${fog-ip}/ISO/Gparted/vmlinuz boot=live username=user config keyboard-layouts=us components quiet noswap nomodeset vga=791 fetch=http://${fog-ip}/ISO/Gparted/filesystem.squashfs
    initrd http://${fog-ip}/ISO/Gparted/initrd.img
    boot ||
    goto MENU2
    :src
    kernel http://${fog-ip}/ISO/SRC/rescue32 setkmap=us dostartx netboot=http://${fog-ip}/ISO/SRC/sysrcd.dat
    initrd http://${fog-ip}/ISO/SRC/initram.igz
    boot ||
    goto MENU2
    :mbrwizd
    initrd http://${fog-ip}/IMG/mbrwizd.img
    chain memdisk keeppxe ||
    goto MENU2
    :kav
    kernel http://${fog-ip}/ISO/KAV/rescue root=live kav_lang=en udev liveimg doscsi nomodeset
    initrd http://${fog-ip}/ISO/KAV/rescue.igz
    boot ||
    goto MENU2
    :avg
    kernel http://${fog-ip}/ISO/AVG/vmlinuz max_loop=255 vga=791 init=linuxrc reboot=bios ramdisk_size=100000
    initrd http://${fog-ip}/ISO/AVG/initrd.lzm
    boot ||
    goto MENU2
    :panda
    kernel http://${fog-ip}/ISO/Panda/vmlinuz boot=live union=aufs noswap fetch=http://${fog-ip}/ISO/Panda/filesystem.squashfs
    initrd http://${fog-ip}/ISO/Panda/initrd.img
    boot ||
    goto MENU2
    :owpre
    initrd http://${fog-ip}/ISO/cd140201.iso
    chain memdisk iso raw ||
    goto MENU2
    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU2
    autoboot



  • Path correct , problem with & in the script and how it stored


  • Developer

    @sgennadi is your path correct? You’re defining {boot-url} but you’re using {fog-ip} in the path to your image files


  • Senior Developer

    @sgennadi What HTML parser?

    Somethings gone wrong with how that information is stored (which is pretty obvious), but FOG has not caused that, at least not directly.


  • Senior Developer

    @sgennadi What @Sebastian-Roth is saying, is your script works perfectly fine. What we need is error logs to helps us at least with a starting point of what is going on.



  • Centos 7 (latest updates ) If I check boot.php
    http://x.x.x.x/fog/service/ipxe/boot.php I see problem with ampersand symbol $
    0_1462438468828_5.JPG
    0_1462438491471_6.JPG


  • Moderator

    Sometimes the code looks fine, but the structure is actually not filled in properly which causes stuff like this. I’m guessing something went wrong here :

    item return return to previous menu
    choose --default return --timeout 15000 target && goto ${target}
    :wd
    

    It’s probably formatted accidentally something like

    item return return to previous menu
    choose
     --default return --timeout 15000 target && goto ${target}
    :wd
    

    So expand the code box and double check all that.



  • I made new menu from faq sample - not worked

    Maybe problem with html parser

    I made new menu Bios with description Bios & Firmware

    0_1462429968654_4.JPG

    But
    0_1462430281581_3.JPG

    Previous fog version now problem with “&” and description



  • I know what is my script worked and must work but no…
    0_1462429584013_1.JPG
    when I choose Diagnostics
    0_1462429620499_2.JPG 0_1462429656458_error_log


  • Developer

    @sgennadi If you don’t know where to find those logs check out the signature below my message…

    I just copy&pasted your script into my advanced menu config and it works like a charm.

    0_1462385470236_Untitled.png


  • Senior Developer

    @sgennadi apache error logs.



  • @Tom-Elliott
    Which log exactly you need?


  • Senior Developer

    @sgennadi Still, error logs? anything we can use to help figure out the issue? My guess, if I had to have one, is your pxe_menu_timeout value is not set currently. Because of this the menu is not setup correctly. Again this is just a guess, but error logs would certainly go a long way, and is there a real need for all this to be in the advanced menu? I ask because trunk allows you to put this all on the main menu screen now. Maybe it will have better luck that way?



  • I have 3 advanced menu item in the boot menu list, after svn update
    First menu with password not worked. Second worked fine. Third
    then i choose menu item i recieve error (see picture)… Menus worked fine for a long time ± 6 six month ( and I don’t do any changes)


  • Senior Developer

    Just because it doesn’t work does not automatically mean it’s a bug. Because of the way adv menu works, there is a high likelihood your code is the culprit for this “bug”. Of course a TON more information will be needed because your menu just shows us the menu structure. What’s causing the issue is totally unknown.


  • Moderator

    Any error messages you could share?

    It’s most likely a formatting issue, though.


Log in to reply
 

414
Online

39210
Users

10856
Topics

103343
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.