Invalid host certificate



  • This started showing up only in the past couple days. I get an invalid host certificate error in the fog.log and thus things like printer installs do not happen. I’ve tired removing and reinstalling the fog service, manually installing the srvpublic.crt, and resetting encryption on that host. Any suggestions?

    4/27/2016 2:53 PM Middleware::Communication Response: Invalid host certificate
    4/27/2016 2:53 PM Middleware::Communication URL: http://fog-server/fog/management/other/ssl/srvpublic.crt
    4/27/2016 2:53 PM Data::RSA FOG Server CA cert found
    4/27/2016 2:53 PM Middleware::Authentication Cert OK
    4/27/2016 2:53 PM Middleware::Communication POST URL: http://fog-server/fog/management/index.php?sub=authorize
    4/27/2016 2:53 PM Middleware::Communication Response: Success
    4/27/2016 2:53 PM Middleware::Authentication Authenticated
    4/27/2016 2:53 PM Middleware::Communication URL: http://fog-server/fog/service/jobs.php?mac=78:AC:C0:98:3A:FA|&newService=1&newService=1&newService=1&newService=1&newService=1&newService=1&newService=1&newService=1&newService=1&n
    

  • Senior Developer

    @Scott-B , v0.10.3 addresses this issue, please update.



  • @plegrand said in Invalid host certificate:

    @Scott-B It seems that with the latest of fog (7410) and the latest client (0.10) everything is OK.
    Can you confirm that ?

    I am no longer seeing the message about object reference set to… The fog.logs looks like it should and looks like its installing the printers, but ends up just making the ports.



  • @Scott-B It seems that with the latest of fog (7410) and the latest client (0.10) everything is OK.
    Can you confirm that ?



  • Updated to SVN 7386 and I’m still getting the…

     4/28/2016 10:26 AM Middleware::Communication Unknown Response: 
     4/28/2016 10:26 AM Service ERROR: Object reference not set to an instance of an object.'
    

    Also, just noticed under FOG settings the checkboxes don’t save. Such as unchecking Green Fog doesn’t stick.



  • This post is deleted!

  • Senior Developer

    @Scott-Adams Please update, it will fix it.



  • I am experiencing this as well, running trunk 7346. Did updating to a newer trunk fix it for you?


  • Senior Developer

    @Tom-Elliott This issue is also plaguing v0.10.0’s new authentication methods as well.



  • @Tom-Elliott said in Invalid host certificate:

    Please update to latest.

    Looking better…

    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     4/27/2016 3:24 PM Client-Info Version: 0.9.12
     4/27/2016 3:24 PM PrinterManager Running...
     4/27/2016 3:24 PM Middleware::Communication URL: http://fog-server/fog/service/servicemodule-active.php?moduleid=printermanager&mac=78:AC:C0:98:3A:FA|&newService=1
     4/27/2016 3:24 PM Middleware::Communication Response: Success
     4/27/2016 3:24 PM Middleware::Communication URL: http://fog-server/fog/service/Printers.php?mac=78:AC:C0:98:3A:FA|&newService=1
     4/27/2016 3:24 PM Middleware::Communication Unknown Response: 
     4/27/2016 3:24 PM Service ERROR: Object reference not set to an instance of an object.
    ------------------------------------------------------------------------------
    

  • Senior Developer

    Please update to latest.


Log in to reply
 

360
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.