Lenovo Yoga ThinkPad S1



  • I have been trying for a week now trying to get this yoga to ipxe boot off of a (lenovo ) usb 3.0 ethernet dongle. So far i am able to see the dongle in the bootable devices and it will ipxe far enough to see the fog server and then it will get stuck at “initializing devices”.

    Things I’ve tried so far based off of other posts regarding this topic and model:

    1.Edited the etc/dhcp/dhcpd.conf to show my fog server as the next-server.
    RESULT: Able to ipxe boot but stops at the screen “initializing devices” still.

    1. Created a bootable usb using this guide Here
      RESULT: Machine tries to boot into the ipx file but doesn’t get dhcp to reach the fog gui.

    Also tried the bootable usb on a desktop to make sure it was working properly and i am able to reach the fog gui and receive tasks properly.

    Any help would be greatly appreciated as i am at a loss now on where to go from here.


  • Developer

    @josh-martin Are you able to load that URL (…/boot.php) with your browser?? What do you get? Please post the full output here in a code box.



  • @Tom-Elliott
    This is where i am getting stuck at.Here


  • Senior Developer

    @josh.martin What do you mean the boot.php file? It shouldn’t be downloading boot.php, rather it downloads init.xz and/or bzImage.



  • @george1421

    I was able to successfully update to the new trunk (release 7188). Once upgraded i was able to ipxe boot the machine and reach the fog menu FINALLY! The quick inventory and registration task also worked properly. I can now see the machine in the Fog web management console. However, when i attempt to ipxe boot the same machine again it is getting stuck on loading the “boot.php” file. It certainly sees the file and stops at 94% of the download. Unable to get it past this point now.


  • Moderator

    @josh.martin If you can tolerate a little instability then it is recommended that you move to the trunk build to support current hardware with uefi firmware. 1.2.0 supported this not very well.

    What it sounds like that iPXE is having an issue over the FOS kernel itself.
    <edit> And the older FOS kernel doesn’t support the usb nic kernel parameter. </edit>




  • Developer

    @josh-martin FOG version??



  • @Sebastian-Roth

    You were correct in recommending the “undionly.kkpxe” file. Once i made that change i was able to reach the fog gui with no issues. However, once i begin the quick inventory it appears to be working like normal until it tries to send the inventory to the server and it just freezes there until i cut it off.

    +1 for progress!


  • Developer

    @josh-martin By the way, which version of FOG are you running (see in the blue cloud on the web interface)? If it is FOG 1.2.0 then you will run into more trouble with that USB NIC after you’ve solved the iPXE issue I reckon. I’d advice to go with FOG trunk!

    [edit]I just added your adapter to our list in the wiki. It has Realtek RTL8153 chipset which is confirmed working with undionly.kkpxe…[/edit]



  • @josh.martin said in Lenovo Yoga ThinkPad S1:

    Is a reboot of the server necessary when making these changes to the dhcpd.conf?

    No sir. If it’s Linux dhcp, just restart the service…
    Debian/Ubuntu:
    service dhcpd stop;sleep 2;service dhcpd start
    Fedora/CentOS/RHEL:
    systemctl restart dhcpd

    If it’s windows, it takes effect immediately.



  • @Sebastian-Roth

    You are correct I am currently using “undionly.kpxe” in the dhcpd.conf. I will give the others a shot in a bit once i get settled in and report back some results. Is a reboot of the server necessary when making these changes to the dhcpd.conf?



  • @Wayne-Workman

    The usb dongle i’m using is the Here once plugged in and i boot to it I see that it is a Realtek RTL8153.


  • Developer

    I am sure Wayne meant lsusb to get the USB NIC information.

    @josh-martin said:

    …initializing devices…

    That’s a good starting point. You already got past one of the biggest hurdles of PXE booting your Yoga via a USB NIC. Well done! But there are a couple more hurdles to pass. The message means that iPXE is trying to find your NIC. How long did you wait when seeing this message. Sometimes it takes a longer time. Just give it a minute or so to see if it is really stuck. As well you can try different iPXE binary. I guess you are using undionly.kpxe right now. Edit your /etc/dhcp/dhcpd.conf and try undionly.kkpxe (note the double ‘k’) or ipxe.pxe/ipxe.kpxe



  • Boot to a recent linux live disk - any will do.

    Open up terminal and switch to root with sudo -i

    Plug in your dongle, and then wait a second, and then issue the command lsusb, give us the output of that. It’ll let us know exactly what hardware is connected to the machine and it’ll give IDs, which we can then use to learn a whole lot more about the chipset the dongle is using (and other stuff).

    It would also help if you gave us the make/model/version of the dongle, and a link to the page where you found it.

    –fixed


 

571
Online

41.9k
Users

12.5k
Topics

117.6k
Posts