Another post for TFTP / NFS authentication issues



  • Hi Fog community,

    I have 2 problems ;

    First (sorry, but again…) i tried for several week to setup a NFS share to store my images on a external server, but i doesn’t work for some reasons…

    i followed this procedure : https://wiki.fogproject.org/wiki/index.php/Windows_Storage_Node but i can’t validate the step to copy the .mntcheck files:

    " mkdir /images2"
    " chmod 777 /images2"
    " mount 10.1.11.64:/Images /images2 “
    ” cd /images2 “
    ” -bash: cd: /images2 : Permission non accordée"

    Another problem is that i can’t use the fog local storage too: i changed the “fog” password on the server “passwd fog”, so i changed it on fog local storage node on webgui too, using FOGCrypt, but look at what it say now…:
    alt text

    Which ID should i use for the local storage node and distant storage node??

    Thank you for your help!!!
    Arnaud


  • Testers

    @Quazz ah, yes you are right. I didn’t think about that, enterprise only. And not installed by default. But the FTP test should work from Windows. I would try connecting to the FTP share from the CentOS that should give you an indication as to if the server with NFS is accessible.


  • Moderator

    @ITSolutions NFS is restricted to certain versions of Windows I believe


  • Testers

    @arnaudrigole Yes, even from a Windows machine you can try mount 10.1.11.64:/Images *
    This will mount to the next available drive letter to test if the NFS is accessible. It should ask for Username/password, make sure to use the FOG username/password as that is what you gave access to.

    You can also try to connect to the FTP share with ftp://10.1.11.64 and see if it gives access.

    Basically we are trying to narrow down where the failure is, it definitely appears the permissions on your NFS share are not correct in some fashion, but just want to see if you can connect to everything independently.


  • Moderator

    @arnaudrigole said in Another post for TFTP / NFS authentication issues:

    How can i test the access the NFS share from other machine? with mount cmd too?

    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_NFS



  • @ITSolutions
    Ok thanks,
    FOG 1.2.0 is running on a Debian 8 server. NFS share is coming from a Windows 2008 R2 server, Filezilla server is running on 0.9.56 beta.

    How can i test the access the NFS share from other machine? with mount cmd too?

    @Wayne-Workman @Tom-Elliott
    I did all the commands as root and it still the same … :/


  • Senior Developer

    @Wayne-Workman Wrong.

    Both types, changing to root is still sudo -i


  • Moderator

    @arnaudrigole If your using Ubuntu/Debian, the correct way to switch to root is sudo -i if your using Red Hat, Fedora, CentOS, the correct way is also sudo -i. Try executing the same commands but as root.

    –Fixed


  • Testers

    @arnaudrigole Let’s see if @Wolfbane8653 can help as he wrote the steps and probably is more versed than I in this method.

    But to help him out can you give us a little more information:
    What OS is FOG on, Debian, Ubuntu, Cent, Red Hat?
    What version of FOG are you using (1.2 or Trunk, if trunk what version does it say in the cloud on the management page)?
    What version of windows is the NFS share coming from Win 7, Win 2008, 2012?
    What version of Filezilla are you using?

    It’ll make it easier to narrow down possible version issues with this information.

    One quick question also is can you access the NFS share from any other machines?



  • @ITSolutions

    Thanks for your reply.

    For the local storage, uncrypt the password solved the problem, thank you :)

    For the NFS , i ran all SSH cmds with under root account… i tried with “fog” also but still the same :
    " cd /images2 “
    ” -bash: cd: /images2: Permission non accordée "


  • Testers

    For your second issue to access your local storage, you don’t need to use FOGCrypt. The password is plain text in the webgui. The only thing to use FOGCrypt for is the legacy client. So try changing the storage node password to the plain text of your new password.

    For the NFS part, did you make sure the password for the share is your new password for the FOG account that you changed? Also are you running the commands over SSH using the FOG account or another account? In the steps on that article the only account getting access is the FOG account, so if you are using best practice and not doing things under the FOG account with SSH that could give you the permissions error. Try running all SSH under the FOG account and see if that works for you.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.