wget failure on client's image



  • Hello guys,

    I’m currently on the latest trunk, and i’m trying to register my hosts/send inventory and I always get stuck on this point

    0_1459437425607_e28dc53b-95f0-4a7b-9687-0c4a55fd8d7a.jpg

    0_1459437429340_ee717447-fe6b-413f-b6ec-36b261552f3b.jpg

    This wget line is the one that causes the trouble, I can ping my fog server, but this line here won’t get through

    Here’s the error message:

    0_1459463383983_IMG_20160331_160551 (1).jpg

    sorry for the potato quality, I’m on a temporary phone right now



  • @Tom-Elliott I’ve used it lately on a low-resolution monitor and an older computer in a debug session, and I’ve noticed I can’t see the bottom line where you normally can see where you type in commands for Vi. It’s like the screen is mis-aligned or something. Of course, paying very close attention to what you type and knowing what your doing and you don’t need to see that line, but still it’s weird. Mind you, that low-res monitor works perfectly fine with showing the bottom line at the shell prompt in a debug session.


  • Senior Developer

    @jdmg94 vi is not buggy. It works perfectly fine. What do you mean “buggy”?



  • @jdmg94 said in wget failure on client's image:

    I just realized I have a typo, my bad it works on both vlans, response is 7013

    Oh ok.

    You might now ensure your Web Server settings are correct. Like the web root.

    Web Interface -> FOG Configuration -> FOG Settings -> Web Server -> FOG_WEB_ROOT
    Also is the original issue still present? Did you have a typo in the wget command or what?



  • @Wayne-Workman BTW, vi is as buggy as it can get on the debugging interface on the clients side, could you guys consider switching to nano instead?



  • @jdmg94 And you have “eth0” set as the interface name inside the node’s storage management area?

    Also - the blank response you said you got, did it result in a blinking-cursor type of thing?

    I’ve had a very, very similar issue twice now with this sort of result. But my issues were getting to the main server which is being run inside of VMWare…

    Is this server virtualized? And does the eth0 link have to go through a router to get to it’s clients or is there just switches between?



  • @Wayne-Workman so here’s my setup

    I have a server with 2 nics, eth0 is on a vlan that has all the test computers on it, this vlan has no internet connection nor has it access anywhere else but its own computers.

    eth1 is on a vlan that has internet and access to my desktop, which is the one I do ssh on.

    when I run the script you sent on a server outside the test vlan I get a “7013” response
    but when I run the same file on a client computer on the test vlan I just get a blank response.

    I can ping the server, but I don’t really know what could be causing the trouble here.

    I just realized I have a typo, my bad it works on both vlans, response is 7013



  • @jdmg94 What happens if you try this from a debug session (maybe try a Linux Live disk too)?

    version=$(wget -qO - http://10.54.0.230/fog/service/getversion.php)
    echo $version
    


  • @Sebastian-Roth my document root is /var/www/html/fog/

    so usually I get

    fogserver/management
    

    instead of

    fogserver/fog/management
    

  • Developer

    Usually we have DocumentRoot set to /var/www

    The wget syntax error is probably because you used ‘0’ (zero) but the command is using ‘O’ (upper case OOOOH) - meaning output to - (stdout)



  • @Tom-Elliott well my virtual host is set to have the fog folder as document root, maybe that’s causing a conflict there?


  • Senior Developer

    just a guess, but you access fog with:
    10.54.0.230/fog/management/index.php



  • I tried running that line from a different server to check on the syntax

    this is what I got

    0_1459438517913_Capturew1.PNG


 

540
Online

41.9k
Users

12.4k
Topics

116.8k
Posts