Strange registration messages


  • Moderator

    @aruhuno That is disappointing the 30 second delay between the first dhcp request and the second chance request did not resolve the issue.

    One last request if you still have this setup (as you have pictured), its probably been several minutes now sitting at the second chance dhcp request. Would you please try one more time for the udhcpc command? If it does not come up after 5 minutes the network link will never come up and we are back to a linux driver issue why this interface is not becoming ready.

    I do have to ask this just to eliminate the obvious. “Can you plug another known good device into the network cable to check to see if the cable or network port is defective?” I doubt this is the case since you are getting into the Fog Operating System.



  • @george1421
    Sorry for the wait. This morning, I’ve updated FOG (now in 6651) and problem persist:
    alt text

    @Wayne-Workman
    I hope so.

    Even if it’s not finished, thanks everybody for the help!



  • @aruhuno said:

    On FOG 1.2.0, yes, but not on 1.3.0 and I need it to deploy Windows 10 with FOG Client.

    What I meant was if it worked before, we can get it working again. :-)


  • Moderator

    @aruhuno The devs worked on the init scripts over the weekend. Since you just upgraded to the current trunk release, does the network interface come up when you try to register this Lenovo today?

    If the updates inits do not work. Could you repeat the same steps from earlier with this modification?

    Use this udhcpc command
    udhcpc -i eth0 --now

    Then when the command times out (or better picks up an up address)
    cat /sys/class/net/eth0/carrier

    If the carrier value is still 0 wait 30 seconds and issue the udhcpc command again. What they were looking at is to find a way to detect if the network adapter has a slow startup. They are working hard to find a way to get these network adapters to init right.



  • @Sebastian-Roth
    I’ve updated FOG this morning:
    alt text

    @Sebastian-Roth said:

    Edit: Found an interesting parameter for the udhcpc. Tom added it to the inits. You might want to upgrade and run the installer again to get the latest inits. This might possibly fix things for you…

    So, I’m making init with updated script :)

    @Wayne-Workman said:

    @aruhuno Just an FYI, the E73 is in our working hardware list: https://wiki.fogproject.org/wiki/index.php?title=WorkingDevices

    On FOG 1.2.0, yes, but not on 1.3.0 and I need it to deploy Windows 10 with FOG Client.


  • Developer

    @george1421 said:

    I’ve done quite a bit of research on this in the last few days and it seams these realtek NICs are generally a problem for linix. I have found references that this particular nic 8169 driver is trouble, where the recommendation is to black list this linux driver and to use the 8168 driver instead. If this is the case then it is a kernel builder issue.

    You are right, there are a lot of posts and discussions on this r8169 driver included in the kernel and a lot of people say that using the official r8168 driver from realtek fixed things for them. But in those cases the people mostly couldn’t get a proper connection at all. In our case it seams to be just an issue of waiting till the interface is fully up. As well most of those posts date back to 2008-2011. A lot has changed in the kernel since then! For example see this.

    @aruhuno Again I may ask you to boot into debug upload mode and check cat /sys/class/net/eth0/carrier. As well, please run ethtool eth0 | grep "Link detected" - both before and after running ip link set eth0 up by hand.

    Edit: Found an interesting parameter for the udhcpc. Tom added it to the inits. You might want to upgrade and run the installer again to get the latest inits. This might possibly fix things for you…



  • @aruhuno Just an FYI, the E73 is in our working hardware list: https://wiki.fogproject.org/wiki/index.php?title=WorkingDevices


  • Developer

    @aruhuno said:

    Hum, just a question in your script: line 18, it’s written if not wait up to 10 seconds but where is the sleep command ? It’s possible to edit this file directly in my FOG installation?

    Unfortunately not. The script is packed into the init.xz file and cannot be modified as is. But you can extract the init.xz and modify it! About your question on the wait. Take a look at line 33 (sleep for 1 second) and line 26 (loop ten times or till the NIC reports to be up). Possibly your NIC reports UP status although it is actually down. Please PXE boot in debug mode and check cat /sys/class/net/eth0/carrier (1 means connected, 0 means disconnected). This check works for most NICs I suppose as users don’t report having issues. But possibly your NIC is behaving differently.

    Please let us know about your findings so we can add this to improve the network startup script…



  • @george1421
    Hum, just a question in your script: line 18, it’s written if not wait up to 10 seconds but where is the sleep command ? It’s possible to edit this file directly in my FOG installation?

    @Tom-Elliott:
    It’s not blank for me :)


  • Senior Developer

    @aruhuno I ran into a similar problem last night. For some reason, the FOG_WEB_HOST setting under: FOG Configuration Page->FOG Settings->Web Server was blank when it should have been /fog. Please check this setting and make sure it’s set to /fog. It should work then (hopefully).


  • Moderator

    @aruhuno If you have time, I would like to see if you can create a FOS-L (FOG OS Live boot flash drive). https://forums.fogproject.org/topic/6532/usb-boot-target-device-into-fog-os-live-fosl-for-debugging

    Actually I want you to follow the Option #4 process:
    https://forums.fogproject.org/topic/6532/usb-boot-target-device-into-fog-os-live-fosl-for-debugging/19

    While I don’t think this will give us different results than PXE booting, I would like you to create this boot flash drive to see if we eliminate the PXE and iPXE parts out of the booting process, does anything change. Booting with this flash drive will send you directly to the debug console. I’m interested in when the link light comes on. Does it repeat the pattern of pxe booting or do you get an IP address right away.

    I’ve done quite a bit of research on this in the last few days and it seams these realtek NICs are generally a problem for linix. I have found references that this particular nic 8169 driver is trouble, where the recommendation is to black list this linux driver and to use the 8168 driver instead. If this is the case then it is a kernel builder issue.



  • @Quazz said:

    @aruhuno The last time I had this issue I switched ethernet cables and it worked fine. Your mileage may vary of course.

    I already tried:

    • another cable
    • another switch
    • another cable on another switch

    As many say it’s certainly the card.


  • Moderator

    @aruhuno The last time I had this issue I switched ethernet cables and it worked fine. Your mileage may vary of course.



  • @Sebastian-Roth
    Ok, but, see my cold boot:

    • Power On: no LED (link down)
    • PXE found: LED (link up)
    • PXE boot: LED (link up)
    • Starting eth0 message: no LED (link down)
    • Computer will reboot in 1 minute message: no LED (link down)
    • few seconds after: LED (link up)

    But when link is up, script wait for reboot computer… too quickly boot or?

    In the script, comment line 18, it’s written wait 10 seconds but where is the wait / sleep?


  • Developer

    @aruhuno Please have a look at what the network script actually does. On line 25 the network interface is brought up, then link state is detected (in a loop ten times!) and when the link is ready we start udhcpc to get an IP. What else could we possibly do??

    One thing you could also try is adding has_usb_nic=1 in the field “Host Kernel Arguments” in that host’s configuration on the web interface. This way you will be prompted to un/re-plug the USB NIC. Ignore that. But you will have some sleep time on bootup just before the network configuration.


  • Moderator

    @aruhuno Do you have an old unmanaged switch you can insert between this computer and your building network switch? If Tom is right, inserting a really dumb unmanaged switch should disable the 802.11az port protocol.

    @Wayne-Workman you may want to follow this thread.



  • @Tom-Elliott
    I don’t know if my switch supports 802.11az but I do not think.
    I change option in firmware from Windows but has no impact :(


  • Senior Developer

    @aruhuno Put in another switch (one that doesn’t use 802.11az would be helpful too) or edit the firmware to always enable the LAN from within windows.

    Unfortunately there’s no straightforward method to doing this.



  • @Tom-Elliott
    What can I do at once ?


  • Senior Developer

    @aruhuno This leads me to believe it is indeed due to power saving features on the NIC.


 

413
Online

5.3k
Users

12.5k
Topics

117.8k
Posts