"FOGFTP: Failed to connect" but FTP appears to be working



  • In the logs for the replicator, I’m seeing this:

    FOGFTP: Failed to connect. Host: 192.168.2.66, Error: Undefined variable: whereArrayAnd
    

    However, replication is working. Problem is I can’t see any other information for that node from the master (logs, hardware info, FOG version, etc):

    alt text

    alt text

    alt text

    I tested FTP on that IP with Filezilla, and was able to log in and browse without any issues.

    192.168.2.66 is a Storage Node.


  • Moderator

    @xmotion Sounds about right. :-)



  • I also figured out my issue. What caused the issue was I tried to upgrade my virtual fog server and it didn’t work. So I created a new server and attached the iscsi volume from the old server to the new server. I then imported the fog backup config. Well I didn’t save any of the passwords it created on the new server. I tried to change them but didn’t know enough to fix it. So I started over and copied all settings before I imported the fog backup config.

    My issues were the passwords for fogstorage MySQL password and TFTP/FTP password.

    You also have to change this on your storage node under storage management.


  • Moderator

    @moses It’s entirely possible that the FTP commands just timed out due to network saturation. If that is the case, you have bufferbloat issues on your link. Might want to look into it further - Dave Taht has a lot of information on it - and there are a few great tools to test for it, and there are lectures on YouTube about it.



  • @Wayne-Workman This is weird, but after leaving it over the weekend, with no intervention, the issue resolved itself. Perhaps it was due to bandwidth? I was saturating the link between the master/node with the replication task. I’ll keep an eye on it and post back here if I see the issue again.


  • Moderator

    I just had the same error. I reset my password in the Storage Management area for each storage node, and also deleted/re-added the fog user and set it’s proper password on the OS of each storage node and this fixed my issue.

    I’m going to re-run the installer and see if that breaks it again…

    — EDIT —

    I ran the installer on all my nodes a few times and the problem didn’t re-appear. I’m chalking the error up to me messing around with the fog user on both systems earlier today - and I’d recommend everyone experiencing similar issues to re-check all their FTP related credentials -as seen in our wiki in the Troubleshoot_FTP article.



  • 0_1456532307419_Kernel.JPG

    I’m also getting that error. I get this error when trying to download any Kernel file. Running latest 6476.


  • Developer

    @Tom-Elliott I am not absolutely sure if this is related. But to me it pretty much looks like it. Yesterday trying to debug the mysql access denied errors I enabled PHP error reporting. I guess it’s not a bad thing to do from time to time. I got several pages full of notices:

    Notice: Undefined variable: whereArray in /var/www/fog/lib/fog/fogmanagercontroller.class.php on line 115
    
    Notice: Undefined variable: join in /var/www/fog/lib/fog/fogcontroller.class.php on line 244
    
    Notice: Undefined variable: whereArrayAnd in /var/www/fog/lib/fog/fogcontroller.class.php on line 244
    

    As well I got (but that’s another story):

    Notice: Undefined index: HTTP_X_REQUESTED_WITH in /var/www/fog/lib/fog/fogbase.class.php on line 54
    
    Notice: Undefined index: node in /var/www/fog/lib/fog/page.class.php on line 35
    
    Notice: Undefined index: name in /var/www/fog/lib/fog/fogcontroller.class.php on line 47
    
    Notice: Undefined index: name in /var/www/fog/lib/fog/fogcontroller.class.php on line 49
    
    Notice: Undefined index: name in /var/www/fog/lib/fog/fogcontroller.class.php on line 52
    
    Notice: Undefined index: name in /var/www/fog/lib/fog/fogcontroller.class.php on line 54
    
    Notice: Undefined index: password in /var/www/fog/lib/fog/fogcontroller.class.php on line 47
    
    Notice: Undefined index: password in /var/www/fog/lib/fog/fogcontroller.class.php on line 49
    
    ...
    

Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.