Fatal Error: Unknown mode :: onlydebug 6303 (kernel 4.4.1)


  • Testers

    Creating a Debug task causes this error in the client.


  • Testers

    @Tom-Elliott Thanks! Works as expected. And I see the confusion regarding this bug. I didn’t report it very clearly, and you took it mean the the result of the “fog” script within the debug session vs the actual start of the task. I’ll take care to report more completely in the future. Thanks again for all your efforts here!


  • Senior Developer

    @jkozee I see and understand. I took the …kill task button, but not actually perform… To mean killing tasks was not operating. Sorry I misread/misunderstood.


  • Testers

    @Tom-Elliott I’m not sure what you mean about replicating the “task cancel”, as it cancels fine for me. Unless it was from my quoting the Debug task: [Debug mode will load the boot image and load a prompt so you can run any commands you wish. When you are done, you must remember to remove the PXE file, by clicking on “Active Tasks” and clicking on the “Kill Task” button]. I’ll pull and confirm…


  • Senior Developer

    This should be fixed now too.

    The task cancel i’m unable to replicate at all. Are the checkbox’s checked when you cancel the tasking?


  • Testers

    @Tom-Elliott Sorry for my confusion. And I’m not trying to be dense, just confirming this is intended behavior, as it still seems counter-intuitive to me.

    In version 5315, when I do a “Host->Basic Tasks->Advanced->Debug”, the client boots to linux shell. In the latest version the client reports the error, and sits idle as it waits to reboot in 60 seconds. So, I never get to the linux shell.

    The “Debug” task still reports the same intended behavior “Debug mode will load the boot image and load a prompt so you can run any commands you wish. When you are done, you must remember to remove the PXE file, by clicking on “Active Tasks” and clicking on the “Kill Task” button.”, but doesn’t actually perform this task.

    So, what should the debug task do, or is it being deprecated in favor of the new “Deploy-Debug”, “Capture-Debug”, or “Schedule task as a debug task” option for any other task? I assumed it was a separate option, when the intention is to poke around a bit and not to perform any other available task.

    Thanks again and sorry if I’m being a PITA…


  • Senior Developer

    @jkozee this is actually the expected result. Onlydebug mode is not meant for imaging. Running the fog script will fail.


  • Testers

    @Tom-Elliott I think a variant of this bug may still exist in 6363. The error is now “Fatal Error: Unknown request type :: Null”

    I get this error when booting the client after creating a “Debug” task for a it. So, “Host->Basic Tasks->Advanced->Debug”, then start the client.

    I don’t think “Capture-Debug” or “Deploy-Debug” has this problem (even in 6303), as I was able to get to a debug console by using those options.


  • Senior Developer

    @jkozee I believe I fixed the onlydebug issue.

    I’m solving this thread because i’m 99.99999% sure this is now working properly without completely erroring out.


  • Testers

    Thanks. I had not seen that post. I was able to get into debug mode using the “Capture-Debug” task. This bug report can be removed or marked as a duplicate if it already exits.


  • Moderator

    Just saw a same exact error in another post. https://forums.fogproject.org/topic/6515/surface-pro-4-won-t-get-to-registration-menu/145

    While I think this is a bug in the current inits, Tom did explain how to get into debug mode just above the post of the link.


Log in to reply
 

461
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.