Manually import image files on newly installed Fog server

  • I have a fog server 1.2.0 running on Ubuntu desktop 14.04. I was able to upload a coupple of images previously. After a few days, I got an update, don’t know which, wherein when I tried to login to Fog web console, I got the Database schema update. I tried to update it but I kept getting failures so I decided to create a different Fog server, same versions with same OS. I manually copied the /images folder to an external HDD. I then copied back the contents of the /images from my USB hard drive to the new one. I don’t have a backup of my MySQL database. I was able to login to Fog web console and tried to recreate the same image name from Images. It shows the Image sizes on server which are correct but my Image sizes on client are all zero. I tried to download the image to a new device but it just kept on restarting saying task completed.

    Have I missed any steps here or done something wrong? Is there a way for me to import my old images manually?

  • @greenfog The image is not a resizable image type. If it was taken from a computer with a HDD capacity larger than 128GB (which it likely was), then that’s why the image download is failing.

  • Moderator

    Are you sure you chose the correct image type when adding the images to the database?

    I believe “size on client” is something generated when capturing the image, by the way.

  • @Wayne-Workman

    Notebook is an HP Elitebook Folio 1040 G2 with 128GB SSD. It is in UEFI mode. The image size is around 17GB. Notebook is laid out as MBR.

  • @greenfog Ok, good information. You tried imaging a notebook. What is it’s model? What sort of HDD/SSD does it have in it? Is it in UEFI mode? Is the disk currently laid out as GPT or MBR? and… what is the drive’s capacity? Also, what is the capacity of the drive you uploaded this image from?

  • @Wayne-Workman

    below is the screenshot Wayne. I was trying to download the image from my fog to a new notebook so there is definitely an HDD drive on that which is not blank as well.


  • @greenfog Thanks for the screen shots. Can you post the output of
    ls -lahRt /images/Win7PreSysprepv20;echo ----------------------------;ls -lahRt /images/dev

    Also - normally this error is seen when the destination HDD is blank. Have you tried on another system yet?

  • Hi,

    I actually did try some of the tips suggested on the Fog troubleshooting site but none of them worked for me. Below are some screenshots from my setup and the bootup where it loops on reboot process. The last screenshot just shows database updated then it reboots and the task is automatically removed from Fog without actually downloading the image to the device





  • Most likely permissions is the issue.

    sudo chown -R fog:root /images
    sudo chmod -R 777 /images

    If it still fails after that, please post pictures of what happens from when the ASCII art “FOG” appears until it’s finished, or take a short video and upload to YouTube and then post here - that way we can see what you’re seeing.

    also - instead of rebuilding your server next time this happens, maybe follow the fixes in the wiki for it: There is a section in there just for your issue.