Could Not Mount Image



  • I am unable to get an image to upload. I’ve tried this from two machines and I get the same results.

    I’m running on CentOS 7
    Version: 6132
    bzImage Version: 4.4.0
    bzImage32 Version: 4.4.0

    All it says is:

    An error has been detected!
    Could not mount images folder (/bin/fog.upload)
    Computer will reboot in 1 minute.

    The host register just fine. I’ve attached a screenshot of the error and the task that is running

    0_1454023603518_Capture.PNG

    ![1_1454023576157_image1.JPG](Uploading 100%) ![0_1454023576157_Capture.PNG](Uploading 100%)
    0_1454023650122_image1.JPG


  • Moderator



  • @Wayne-Workman HI Wayne know this is an old call but stumbled upon it when I had the same issue.

    You were after a decent photo of the error for the wiki which I’ve not been able to get and adding in a codebox below just screws up but hopefully this workaround of text on a black background in notepad++ will do the trick :)

    0_1464795138739_upload-b4b7ee3f-135f-4616-a29e-c0374be5411f

    Also in my case for anyone else finding this later on I had moved the images directory to /home/fog/images and updated fog everywhere except for the /etc/exports file.

    Amending that to read as

    /home/fog/images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /home/fog/images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    

    And then running

    exportfs -a
    

    bypassed the error for me,.

    cheers kiweegie.


  • Moderator

    @bberrelez Can you take a better photo of the error for wiki purposes? Please? Otherwise I’ll need to wait for someone else to post a picture of the same error.

    wiki


  • Moderator

    I just experienced this exact issue - problem was NFS and RPC was starting up before network is even ready. I fixed it by delaying their start by 30 seconds.

    Here are instructions for that for Fedora, should be awful similar (if not exactly the same) for CentOS7 - https://wiki.fogproject.org/wiki/index.php?title=Fedora_21_Server#Set_the_FOG_services_to_start_30_seconds_after_boot

    My old fog server didn’t have this issue because it was slower and sort of handicapped (hence the rebuild), my new fog server is viciously fast, and can reboot in under 10 seconds…


  • Senior Developer

    @bberrelez Can you ensure the .mntcheck files are in the /home/fog/images and /home/fog/images/dev files? Also, does the /home/fog/images/dev folder exist?

    From the sounds of it, you switched to /home/fog/images after /images was already created.

    Based on all of this, I’m also just guessing that this was a fresh install, and there were no images in /images.

    Basically, if I can follow the issue at all:

    You ran:

    mkdir /home/fog/images
    mkdir /home/fog/images/dev
    

    If you don’t have the dev folder in /home/fog/images, you’ll also fail as the mount literally fails (no such directory).

    If you do have the dev folder, then run this on your fog server as root:

    mkdir -p /home/fog/images/dev
    touch /home/fog/images/.mntcheck
    touch /home/fog/images/dev/.mntcheck
    

  • Moderator

    @bberrelez said:

    @jgurka

    I tried this and still nothing. I did find that I had an incorrect path list on the the image path under Storage management. I created a directory here: /home/fog/Images, applied the appropriate permissions and corrected the path under the storage management.

    Still have the same message appearing.
    Could not mount images folder (/bin/fog.upload)

    Need to know information! Lol
    You need to modify /etc/exports to reflect the correct path. Then reboot.



  • @jgurka

    I tried this and still nothing. I did find that I had an incorrect path list on the the image path under Storage management. I created a directory here: /home/fog/Images, applied the appropriate permissions and corrected the path under the storage management.

    Still have the same message appearing.
    Could not mount images folder (/bin/fog.upload)



  • @plegrand

    The images directory needs to have full r/w/x permissions in order for FOG to use it – did you make sure to change the permissions when you created the new directory and copied the contents of the old /images?

    To check the directory permissions, run the following:

    cd /home
    ls -la
    #You want permissions on the new images directory to be drwxrwxrwx and also on sub-directories
    

    To enable full r/w/x permissions on the folder, run the following:

    chmod -R 777 /home/images
    #-R will run it recursively to apply the permission changes to sub-directories as well as the top directory
    


  • Hello, i think i’ve got the same problem except i made modification on the web interface :
    i didnt want the “images” directory be at the root (/images)
    then i copy the images directory into /home/images.

    Then i modify the image path on the web interface, i thought it would modify the export file also but it seems not.

    then i had to modify manualy the export file. Now it works fine.
    Could it be the problem ?


  • Moderator

    @jgurka People like @george1421 suggest to put the images in /opt/fog/images, which is why I suggested searching for /dev/.mntcheck ;-)



  • @Wayne-Workman

    I definitely get where you’re coming from. :)

    @Vasahond

    You can try running this to see whether or not /images actually exists:

    [ -d /images ] && echo 'Directory Found' || echo 'Directory /images not found'
    

    You should see "Directory Found’ if it does in fact exist.


  • Moderator

    @jgurka Yeah I saw that, but the directory could still be missing. I’m most concerned with him not seeing a /images directory on his server.

    As a test, I just created a directory called /image and exported it in /etc/exports, and restarted rpcbind and nfs-server and saw that NFS was running fine, I then deleted the /image directory and then again checked NFS… still running fine. :-\ You’ll also hopefully understand that I have been bitten many times by making assumptions about things. No telling what the guy has copy/pasted into his server trying to get it to work.



  • @Wayne-Workman

    Vasahond’s running services output seems to show it as existing and being mounted via NFS:

    Configured NFS mountpoints:
    /images
    /images/dev
    Active NFS mountpoints:
    /images
    /images/dev
    

  • Moderator

    @Vasahond said:

    I am in the root directory – there seems to be no /images path.

    Really? If that’s the case, that’s almost surely the problem. Can you please post the output of find / | grep /dev/.mntcheck

    Also, what output/errors do you get when you re-run the installer? You’ve also not specifically stated what version of FOG you’re using, we need this information as well.



  • @Vasahond

    It looks like you’re on CentOS 6 – I was assuming you were on 7 earlier. Is this the latest trunk build of FOG, btw?

    I don’t think the stopped FOG services are crucial for what your problem is, but I’d start them back up anyway:

    service FOGPingHosts start
    service FOGSnapinReplicator start
    

    It looks like you have the IPv6 firewall still enabled…this might potentially be causing the problem? I’d go ahead and disable it:

    service ip6tables stop
    chkconfig ip6tables off
    

    Try it again and see if it made any difference.



  • @jgurka, here is a list of my running services. A few are stopped; do you suppose these are crucial processes?
    0_1454444404023_Capture3.PNG



  • @Vasahond

    Also ensure that all of the FOG services are running by entering:

    systemctl list-units --type=service
    

    You should see see all five Fog services in my screenshot as loaded, active, and running:

    alt text

    Another issue I’ve seen is the nfs-server service will show that it is running, but will be inactive and exited. Also double check that isn’t the case, because it will at a glance look as though it is loaded when you check status.

    To verify the Images directory exists, try the following:

    cd
    cd /images
    ls
    

    You should be within the directory and able to see at least a directory called dev and postdownloadscripts.



  • Hello – I’m having a similar issue. I don’t want to hijack the thread, but I have checked to make sure the NFS server service has been started, and it has. If I boot into debug mode and check the current working directory, I am in the root directory – there seems to be no /images path. Again, not sure if it’s related, but I’m having the same problem.



  • I ran into this before too. Check that nfs-server is running by running:

    systemctl status nfs-server
    

    If it’s not, you can manually start it with:

    systemctl start nfs-server
    

    This enables the service to start automatically on next boot, but it should already be enabled…

    systemctl enable nfs-server
    

    Which brings me to telling you to follow this guide on delaying the FOG services to fix the problem:
    https://wiki.fogproject.org/wiki/index.php/Fedora_21_Server#Set_the_FOG_services_to_start_30_seconds_after_boot

    I needed to also add “systemctl start FOGPingHosts” to the rc.local on my CentOS 7 installation.

    Two commands you can use to easily see what is/isn’t running on your CentOS 7 installation are:

    pstree
    

    &

    systemctl list-units --type=service
    

Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.