Snapin isseus ...



  • Hello,
    my config:
    fedora 22 64bit
    fog Version: 6120
    I have problems with installing snapins.
    I have created snapin for msi package:
    0_1453893005344_fog1.png
    Task is finished with windows error 1603 (net helpmsg 1603 “Fatal error during installation”)
    But when I run this task
    0_1453893384416_fog2.png
    from cmd with elevated priviliges (Run cmd as administrator) task is done with success.
    Client runs win7 pro.
    FOGService in services.msc in column “Log ON as” is local system.
    My question:
    why I can’t use fog service to install msi package.
    Regards


  • Developer

    @robza No problem.

    If you need any help just let me know, I will see what I can whip up.



  • @Jaymes-Driver thanks for suggestion, I’ll try and let you know.
    Regards


  • Developer

    Why not code in a script to disable the UAC (or disable it by default in the image) and use a script to re-enable after your snap in is complete.

    This way, yes it’s still half hearted, but it seems the issue is on the windows side of things rather than FOG, but you won’t be leaving your systems UAC disabled.



  • I have found solution but in my opinion is half-hearted success. After disabling UAC scripts installed with code 0.
    Regards



  • @Thiago no difference after removing /qn - 1603 error generated in fog log.
    I have folder with few files and there is setup.exe, but after starting there is installation wizard, where is necessary to define few variables. If installing msi there is xml file used.
    Tomorrow I’ll try with exe.
    Regards



  • @robza
    if i could see properly, the error begins here:

    MSI (s) (7C:E0) [12:20:19:742]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI756D.tmp, Entrypoint: CheckRequirements
    Pocz\Ufffffffftek akcji 12:20:19: CheckRequirements.
    CustomAction CheckRequirements returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    

    Sorry, but i can’t help with this specifically.
    Do you have this agent in a exe version? Exe has hability for silent install too.
    Last time that this occurred to me, i removed the options for silent install and send snapin task to host, at the computer client i saw that it asked for elevated privileges (that was my issue).



  • @Thiago below log
    0_1453980384596_ccc.txt
    This script works fine when I start cmd as administrator (cmd with elevated priviliges).
    Kaspersky service answered that is connected with UAC (User Account Control) or “operating system permissions” - what ever thats mean.
    Regards



  • @robza
    Try to use log verbosity option of msi. Maybe something appears in log file.

    C:\Windows\System32\msiexec.exe /i Kaspersky_Network_Agent.msi /l*v C:\msi.log SSINSTALL="172..." /qn
    


  • @Thiago no change, still 1603 error occured.



  • @Thiago said:
    Try put \\ before server ip in SSInstall settings… \172…
    sorry for the typo… the forum “eat” other \ :smile:



  • @Thiago still the same 1603 error after your advice:
    0_1453974571532_fog.png
    Regards



  • @robza
    Try put \ before server ip in SSInstall settings… \172…



  • @ITSolutions from cmd with elevated priviliges (Run cmd as administrator) task is done with success.
    Spaces in msi package are removed
    0_1453962544513_fog.png
    and /quiet command used but still got 1603 error.
    Regards


  • Testers

    @robza In your original screenshot I just noticed that the MSI file has spaces in it, can you remove the spaces? This would cause msiexec to error finding the file. 1603 is a common catch all error on MSI files, so this could be the issue also.


  • Testers

    @robza Have you tried removing the “/qn” from the msi as the /quiet should be the same thing and /quiet is the normal msi style?

    Also can you install the file using that command manually on the machine?



  • @Jbob 0_1453904200712_fog.png
    still the same error 1603


  • Senior Developer

    Change Snapin Run With Args to

    /quiet /i
    


  • @Tom-Elliott this msi package is provided by Kaspersky Lab. GPO not available.
    Hmm I’m going to contact with Kaspersky support.
    Any other ideas?
    Regards


  • Senior Developer

    @robza That I’d say is then the snapin itself. You created the MSI? See I see the same type of problem with Java, but that’s just java’s own msi files being problematic. You may have better luck, with this particular msi, using an Active directory GPO.


Log in to reply
 

367
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.