Dell Optiplex 3020 Micro with new Samsung SSD 850 EVO



  • Hello,

    I am trying to FOG a new Dell Optiplex 3020 Micro with a brand new Samsung SSD 850 EVO. I am able to get to the menu prompt and choose Perform Full Host Registration. Once I select that option, it hangs up and shows a cursor in the top left corner.

    The only other message I’ve seen is “Reopening Network Connections.” Are there any know issues with the hardware and FOG? Any thoughts?


  • Developer

    @Aaron-Kearns said:

    However, that SOMETIMES works and other times does not.

    What exactly does that mean? Can you please take a picture when things go wrong andupload it to the forums. There is no chance we can help you if we don’t know exactly what goes on.

    So SSD does not want to play with FOG from what I get. Please try booting any kind of live linux DVD (e.g. ubuntu) on the 3020 with SSD installed. If this comes up please run commands lsblk and cat /proc/partitions - take a picture for us.

    Upgrading to trunk might fix this for you but I can’t tell for sure.



  • @Sebastian-Roth Sorry this response has taken so long! When imaging the PC with the SSD, the process definitely hangs when trying to register. Using the HDD is the only way to actually get an image on the PC. However, that SOMETIMES works and other times does not.

    After some waiting, the computer with the HDD was able to boot into the debug session. This is the output for each of the commands you asked me to run.

    fogpartinfo --listdevices
    /dev/sda

    cat /proc/partitions
    major minor #blocks name
    8 0 488386584 sda
    8 1 102400 sda1
    8 2 488283160 sda2

    lsblk
    name maj:mn Rm size Ro type mountpoint
    sda 8:0 0 465.86 0 disk
    |-sda1 8:1 0 100M 0 port
    |-sda2 8:2 0 465.76 0 port

    Any thoughts?


  • Moderator

    @Sebastian-Roth Just a question for you. (I have no basis to suspect this is true other than my intuition) Is there anything in the registration code that would blow up if the hard drive was “new out of box” with no partition table at all? This past week there was one or two posts about new lenovos with that build in 16GB M.2 SSD drive in addition to the main SSD hard drive. One poster put a partition on the drive and was able to proceed, and another removed it, where it was found under the battery and the registration proceeded. Understand the registration process was the fist step with both of these devices. I’m not sure (remember) if the device crashed when any FOG PXE action menu was selected or not. I’m not sure if there is a common thread here or not.


  • Developer

    @Aaron-Kearns said:

    I tried using the original hdd, and I was able to begin registration of the host. I stopped and swapped in the ssd to see if I could get to the same spot, but I didn’t get that far.

    That’s really interesting! Are you sure this is the case? Can you please try and confirm that it hangs if using the SSD when trying to register!? One of the first things that happen in the registration script is checking the hard disk. So this might actually be an issue. Can you then please register/add this host by hand (web GUI) and run a debug task for it. Does it boot up into the debug session? If so, please see what you get from those commands: fogpartinfo --list-devices, cat /proc/partitions and lsblk



  • @george1421 The PC boots up in Legacy mode. I can look into using the trunk build to see if this helps.

    I tried using the original hdd, and I was able to begin registration of the host. I stopped and swapped in the ssd to see if I could get to the same spot, but I didn’t get that far.

    Thanks for taking the time to chime in on this subject.


  • Moderator

    @Aaron-Kearns Based on what you’ve posted so far I feel the issue is with/between the fog kernel and the 3020. I’m pretty sure the ssd is not relevant to this issue.

    The one thing I forgot to ask, is this 3020 booting in uefi or bios mode. If it is uefi mode do you have secure boot disabled? I can say I’ve successfully images the same list as you, including the 9020 with FOG 1.2.0 (stable) without issue. All of these systems were in bios mode though.

    There are a few other posts currently in the community that are reporting similar events with FOG and new hardware. FOG 1.2.0 is somewhat old, the newer kernels/inits from the trunk build may help.

    If you are booting this 3020 in bios mode and have time to test out/follow a tutorial I’m working on, I’d like to give that test a shot. FWIW: This test will not touch anything on your fog server.



  • @george1421

    The FOG version is 1.2.0, and we are not running a trunk version.
    This FOG server has been used successfully for quite a while. It has been used to image older Dell Optiplexes including the 755, 760, 780, 790, and the 7010. More recently I imaged a 9020 Micro that came prebuilt with an SSD.



  • This post is deleted!

  • Moderator

    Lets start with the basics.

    What version of FOG are you using? (I’ll assume 1.2.0)

    Are you running a trunk version? (if you look at the management page, there is a cloud in the upper left corner. There are numbers on the cloud, what are they?)

    Is this a new FOG install or have you been using this successfully for a while?

    Do you have any other client computers (older than the 3020) that do register correctly?

    BTW: There is another thread in this forum with almost the same exact issue. But lets start with the basics first.


Log in to reply
 

411
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.