SOLVED Upload Image from HP Probook 450 G3

  • Hello,

    i have some problem with a HP Probook 450 G3 on PXE Boot
    I try to upload this new model on my fog server but on the boot PXE I have an error message after the ipxe Reimage menu :

    IPXE initialising devices… WARNING Using legacy NIC wrapper on 00:00:00:00:00:00

    iPXE 1.0.0+ (53653) – Open Source Network Boot Firmware –
    Features NFS FTP etc…
    configuring (net0 00:00:00:00:00:00)…error 0x04ee119 (
    configuring (net1 #MAC ADRESSE of the HP Probook#

    Then FOG PXE Menu appeared and indicate that my Host is NOT registered (but of course it is in my fog interface)
    I tried register my computer directly with the fog pxe menu but nothing change
    If i register again this computer the system tells me that this computer is already registered

    I don’t have any pb with another model of computers (Probook 450 G2 for example)
    Do you have any idea ?

  • Tom,

    Yes pb mean problem 🙂 no misunderstanding for me with your answer 😛

    You can solve this post, all is ok now, thanks to Sebastian who told me how update / change my boot pxe

  • Senior Developer

    @Seydoo No problem. I probably screwed something up with the build at whatever point in time that was. However, your English is perfectly fine. I just notice what I’m guessing to be an abbreviation of letters to indicate “problem”.

    pb = problem?

    I see this occasionally, and the abbreviations are all that confuses me, which is why I ask. I say abbreviations, but maybe you don’t know what to actually put? And I mean this with no ill-intentions.

  • Tom,

    some months ago the pxe file was changed from the originally file to another file (in dhcpd file ?) because of some which lenovo don’t want to boot correctly.
    With the help of Sebastian booting from PXE does not generate any error. Perhaps some files (undionly.kpxe or else) were corrupted or not up to date.

    Thanks to all of you my problem is solve

    P.S sorry for my english wich is not as good as i wish 🙂

    Edit : another problem but perhaps with Windows 10 and fog client : once my host registered on my Fog server and the client install on the computer i can’t have an IP with the fog dhcp (no boot pxe, and no IP on windows (169.254 etc…)
    If I delete the host, on fog server, reboot on PXE, register the host, create the task to upload the image and reboot without restarting windows PXE is ok and create my image. After image is created, at the restart of windows, again, no IP which consequences no download of the snapins

  • Senior Developer

    @Seydoo What do you mean?

    “Perhaps when the boot pxe was changed something wrong was done and it’s why you see some pb with the binary.” What is pb?

    What was changed?

  • Hi Sebastian,
    My fog server is my DHCP server, and my version of Fog is really 1.2.0. Perhaps when the boot pxe was changed something wrong was done and it’s why you see some pb with the binary.

    I’ll try update it.

    Thanks for your help

  • Senior Developer

    @Seydoo Are you sure you are using the FOG DHCP server? I am asking because the config you posted shows “undionly.kpxe”. At some point you said something about changing to ipxe.pxe because of some Lenovo device. And from my understanding of iPXE we should not see this legacy NIC wrapper warning if you really use undionly.kpxe (maybe I am wrong here!!).

    And there is something else I am wondering about. In your first post it says: “iPXE 1.0.0+ (53653)”. This is not the number of the official FOG 1.2.0 released iPXE binary (should be 3a02). Please check which version you see in the blue cloud in the web GUI. If it really is 1.2.0 then at some point someone has changed the iPXE binary.

    Maybe you can try updating just that iPXE binary again to the very latest version and see if that helps. iPXE binaries are usually in /tftpboot on your FOG server. So maybe try this as root (hope I am getting this right, please pay attention when doing this!):

    service xinetd stop
    mv /tftpboot /tftpboot.BACKUP
    svn export /tftpboot
    chmod 755 /tftpboot
    chmod 644 /tftpboot/*
    service xinetd start

    Then try again booting your device and see what you get.

    Edit: Thanks for the PCI IDs. Those Realtek 8168 seam to cause quite some trouble here and there. Some revisions of this adapter behave well but others are a nightmare. Here you have two emamples: and

  • Hi Sebastian,
    in the network part in device manager I can see 4 cards (NIC and Blootooth):

    • Realtek PCIe GBI family Controller (4 IDs : PCI\VEN_8168&SUBSYS_8101103C&REV_15, PCI\VEN_8168&SUBSYS_8101103C, PCI\VEN_8168&CC_020000 and PCI\VEN_8168&CC_0200)
    • Intel Dual Band Wireless AC3165 (4 IDs : PCI\VEN_8086&DEV_3165&SUBSYS_40108086&REV_81, PCI\VEN_8086&DEV_3165&SUBSYS_40108086, PCI\VEN_8086&DEV_3165&CC_028000 and PCI\VEN_8086&DEV_3165&CC_0280
    • Bluetooth Device (Personal Area Network) ID : BTH\MS_BTHPAN
    • Bluetooth Device (RFCOMM Protocol TDI) ID : BTH\MS_RFCOMM


    here is the content of my dhcpd file :

    option space PXE;
    option PXE.mtftp-ip    code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16; # RFC4578
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    subnet netmask {
            option subnet-mask    ;
            range dynamic-bootp;
            default-lease-time 21600;
            max-lease-time 43200;
                    option routers;
            filename "undionly.kpxe";

  • @Seydoo Please fill Sebastian’s request below, and you can get the contents of your DHCP config by using cat /etc/dhcp/dhcpd.conf

  • Senior Developer

    @Seydoo said:

    IPXE initialising devices… WARNING Using legacy NIC wrapper on 00:00:00:00:00:00

    I’ve played with iPXE quite a bit in the last months. But I have never seen this warning. Can you please try to find out which NIC exactly you have in this machine. Device manager in windows or using lspci if you have linux installed on it. PCI IDs would be really great.

    Edit: Looking through the ipxe source code and trying to trace where this is coming from it seams like this is happening when ipxe tries to probe for 3c509 (3Com) cards on the bus. I kind of doubt that you have such a card in your probook… Hope this is not causing any further confusion.

  • The OS is Red Hat Enterprise 6.6 (Santiago)
    My kernel is update to 4.1.2 (x86_64)

  • @Seydoo said:

    i know Fog has problem with UEFI so i always deactivate it on my computers before imaging them

    That statement is not really true anymore. There’s been great progress made in FOG Trunk, which is the bleeding edge development version.

    We can take a look at the dhcp file, what OS is fog running on?

  • I know the boot file for pxe boot was change some months ago (used ipxe instead of original file because of a lenovo computers who doesn’t want to boot on pxe) Is that you’re talking about ?
    My fog server is my dhcp server
    Do you know how can i reinstall / change to the original file ?
    And the computer is running in legacy mode, i know Fog has problem with UEFI so i always deactivate it on my computers before imaging them

    One more thing, i can’t update my fog with the client update menu on the webpage : I have these messages at the log on screen :
    Estimated FOG sites: Error contacting server
    Latest Version: Error contacting server
    When i installed Fog i used wgetrc to configure the proxy in order to download the files on sourceforge, perhaps there is another way to connect my fog server on the internet ?
    I’m a real noob with Linux so sorry if i don’t explain well the problem

  • @Seydoo Do you know what boot file you’re using for DHCP option 067 ? Also, do you know if this computer is running in Legacy mode or in UEFI mode?

  • I forgot the version, it’s FOG 1.2.0
    I don’t understand why my NIC is on net1 instead of net0 after ipxe Reimage menu
    It looks like a virtual card (?) wants to start before my integrated NIC

  • @Seydoo What version of FOG are you using? In the web interface, look at the cloud in the top left corner. it has a number in it.