Realtek 8168 NIC issue with PXE bootmenu

  • I am currently busy to set up a fog server in a classroom at a school as a final study project. After testing with different machines the conclusion is that it works on every client, except for the Dell optiplex 3010. After a little search we concluded that the NIC is unsupportive.
    EDIT1: It gets the 0x040ee119 error which i believe it is the timeout because the network card could not be found. I have posted the image.

    After 3 weeks of trial and error I am at my limit of possibilities and asking now for help.

    The following systems has been used:

    • Server is a dell optiplex 3010 with ubuntu Desktop.
      – Fogserver 1.2.0
    • clients are Dell optiplex 3010 with realtek r8168.
    • Test DHCP server: Cisco 3750 with DHCP enabled and configured rules 66/67

    followed instruction sets.

    • Tried to add the r8168 driver into a linux kernel by adding into the /usr/src 3.13.0 kernel and changed the Kconfig and makefile. (well, it is the first try)
    • Tried to add it into the new 3.17.3 kernel and make an image. I got the driver into the xconfig list, but the bzImage build was corrupted/didn’t work. I was close.
    • Build a whole new server on the CentOS platform. Issue isn’t a distro, but a kernel, so that was useless)
    • (problem is the network driver isn’t listed)
    • Tried again to make an bzImage with the latest LTS driver 3.14.25. (still working on this one)
    • (errr, this isn’t gonna work, server crash, won’t come back up)

    Not yet done. Think this is not the issu.

    I am just starting with linux and I am out of options. Does someone have any options left?


  • It took a while to get everything straight.
    The server is up and running with the 1312 revision of undionly.kpxe
    Each dell has to enable Wake on LAN /w PXE and [B]disable deep sleep mode.[/B]
    With this settings the setup works for me with the standard configuration.

    My project is tested and approved today, so thanks again for the help.

    Jeroen v. W.

  • Developer

    @Wallioo, post: 39419, member: 27278 said:

    wake on lan does not work on the Dell 3010…
    I have checked the bios setup, and wake on lan is enabled with PXE.

    you may have to check your power management settings
    from dell:

    Wake from hard shutdown (S5) and hibernate (S4) does not work any more. This is by-design Windows behavior.
    This change is due to Microsoft design changes in Windows 7 & Windows 8
    For optimal Wake-On-LAN operation, power management setting should not go below Sleep (S3)

  • We have tried the 1312 version of undionly.kpxe again and it seems to be working.
    We will update the latest news monday.

    Thank you, Tom and Wolfbane for the help.

  • We have succes with :
    wget -O /tftpboot/undionly.kpxe
    We can register the client to Fog. Deploy and upload works fine, but the wake on lan does not work on the Dell 3010…
    I have checked the bios setup, and wake on lan is enabled with PXE.

    Edit: Wrong link!

    WOL works on the HP machine, but not on the Dell 3010 .

  • Developer

    At time index 1:20 you get the wonderful error code!

    Error 0x040ee119

    Read thru the last few pages. This is most likely due to something not right in your environment.

    Also check your network switches.

  • I have a public link of the video now.
    It is 120MB. forgot to change the settings in a hurry

    Here is the link
    Here is a Wetransfer link

  • Senior Developer

    On the system that’s giving you the problem, can you take a video of the issue and post it?

  • I have done the option you gave me, but to no avail.
    I still get the same error.

    what I have done is:

    • downloaded tftpboot dir from svn
    • copied the svn dir to the tftpboot.
    • try to reboot Dell and HP clients. (HP works, Dell doesn’t)
    • Restart service tftpd-hpa
    • try to reboot Dell and HP clients. Same result.

  • I have got a link from 2012 that has a similar problem:

    EDIT: I will try the option

  • Senior Developer

    Do me a favor and try the ipxe files from trunk.

    To do so open a terminal and become root (whether directly or through sudo.)


    svn co svntftpboot
    cp -Rf svntftpboot/* /tftpboot/

    Maybe this will help?

  • I am failing to get to the FOG menu. The image I attached is the step I get when it tries to get the menu.

  • Senior Developer

    All of the kernels I’ve been building have support for the Realtek 816* series drivers.

    I believe the default is labeled as 8169 usually. But they are supported.

    What are the specifics that is giving issues? You’ve attempting running as a Debug task?

    Or you’re never actually getting that far and failing to get to the FOG Menu at all?

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.