SOLVED New Fog Server Build Cannot Deploy


  • Hello all,
    I just built a new Fog Server, Ubuntu 14.04 LTS 64bit
    I am on Fog version 6020 using bzImage 4.3.2

    When I try to deploy my image to a Lenovo T440s or T450s I get a write cache error. I am using Bios in Legacy mode and DHCP is set as undionly.kkpxe.

    Thanks,
    Chris


  • WOOT, Sorry to have caused the problem in the first place, but I am glad it is now working properly.


  • It is working now. Thanks!


  • Please update. Some fixes have been done.


  • Sorry for my late response. Please see the attached picture.
    0_1453322678990_Screenshot from 2016-01-20 20-25-51.png

  • Moderator

    To borrow a quote again from Sebastian:

    “Could you please run a debug session on this device (WebGUI -> Host -> Basic tasks -> Debug) and run lsblk from the command line of the target computer? What do you get?”

    The order reported by lsblk may give us an idea which drive is /dev/sda as well as what this drive thinks it is. If you could take a screen shot of the output and post it here, that would be helpful for the devs.


  • @Chris-Sodey Just a guess, but is this “problematic ssd” displaying on the system as the First disk?


  • Ok, I did the following in GParted.

    Wiped the partition table and created a new msdos based table.
    Formated the drive to NTFS

    Same error persists. Do you have a suggestion on formatting to try?

  • Moderator

    @Chris-Sodey Excellent feed back

    I know the @Developers where working just recently on kernel enhancements for M.2 ssd drives. [Edit] looking at your OP you are using a mostly current build already so you should have the fixes for the m.2 ssd drive already. so it may be the blank drive that is causing the issue [/Edit]

    It would be interesting to know from a dev standpoint is it the fact of having this M.2 ssd installed or not having any partitions and format on this device that is causing the issue (as outlined in the link I provided below). With your assistance I’m sure the devs can work this out. This shadow hard drive seems to be embedded in more hardware than originally through.


  • I have some more info regarding this post.

    Apparently, the 16GB SSD is not soldered on. I found it under the battery in the T440s. The drive is a M.2 SSD and once removed the laptop imaged correctly. I would still like to get this to work without removing the drive. I will test formating the 16GB SSD with gparted to see if FOG will enumerate it properly.

  • Moderator

    @Chris-Sodey said:

    The computer has 2 SSDs. 500GB samsung 850 EVO and a soldered on 16GB SSD.

    There was just another recent post where th OP was trying to deploy to a Lenovo (I think) and this built in drive was causing a problem with fog because it wasn’t formatted, it was just a blank drive. I think the OP was able to put a partition on that drive and then fog was happy enumerating it. If this is a systemic issue I do think the developers need to be aware of this built in drive.

    [Edit] just for reference here is the thread I was thinking about: https://forums.fogproject.org/topic/6461/cannot-get-capture-to-work-new-server/37 There was no mention of what hardware, or any real answer on a resolution[/Edit]


  • @Chris-Sodey I’m going to defer this one to the @Developers , sounds like a good usage case to figure out.

    Here recently, the upload and download scripts were totally re-written and are using better and more standard methods of disk detection. So fog is going through some teething at the moment in this area.

    What sort of settings do you have set on the image? Single disk? Resizable or not? Multiple disk?

    On the host you uploaded from, do you only have one drive specified, or none?


  • The computer has 2 SSDs. 500GB samsung 850 EVO and a soldered on 16GB SSD.


  • Check to make sure there aren’t any inserted SD cards, flash drives, or connected external storage devices.

    How many HDDs does this computer have?


  • 0_1453221388305_IMG_5054.JPG


  • @Chris-Sodey Can you take a photo of the error and post it here? A video works too.

324
Online

9.1k
Users

15.7k
Topics

145.9k
Posts