[5874] Multicast service and list all images


  • Moderator

    Hi,

    I updated my installation today with that error :

     * Press [Enter] key when database is updated/installed.
    
     * Setting up storage..........................................OK
     * Setting up and starting DHCP Server.........................Skipped
     * Setting up and starting TFTP and PXE Servers................OK
     * Setting up and starting VSFTP Server........................OK
     * Setting up FOG Snapins......................................OK
     * Setting up UDPCast..........................................OK
     * Configuring UDPCast.........................................OK
     * Building UDPCast............................................OK
     * Installing UDPCast..........................................OK
     * Installing FOG System Scripts...............................OK
    
    
                            Configuring FOG System Services
    
    
     * Setting FOGMulticastManager.service script executable.......OK
     * Enabling FOGMulticastManager.service Service................Failed!
    root@SRV-FOG-01:~/svn/trunk/bin#
    

    I’ve updated my FOG because I’ve these bugs :

    • Search image
      0_1452167863008_upload-4ce39040-fb6f-4eef-91c2-17cce6f9af03

    • List all image
      0_1452167934574_upload-44897428-3882-489e-97f6-a5cb97e7eca0

    [Thu Jan 07 13:01:41.168735 2016] [:error] [pid 3042] [client 192.168.101.252:59494] PHP Fatal error:  Uncaught exception 'Exception' with message 'No Storage nodes enabled for this group' in /var/www/html/fog/lib/fog/storagegroup.class.php:29\nStack trace:\n#0 /var/www/html/fog/lib/pages/imagemanagementpage.class.php(99): StorageGroup->getMasterStorageNode()\n#1 [internal function]: ImageManagementPage->search_post()\n#2 /var/www/html/fog/lib/fog/fogpagemanager.class.php(67): call_user_func(Array)\n#3 /var/www/html/fog/management/index.php(20): FOGPageManager->render()\n#4 {main}\n  thrown in /var/www/html/fog/lib/fog/storagegroup.class.php on line 29, referer: http://fog.eseo.fr/fog/management/index.php?node=image
    

    Not solved with the latest installation.


  • Moderator

    @Tom-Elliott said:

    This should also fix the start/stop not being able to be found. I’m going to mark this post as solved.

    Ok, thank’s a lot


  • Senior Developer

    This should also fix the start/stop not being able to be found. I’m going to mark this post as solved.


  • Moderator

    @Tom-Elliott said:

    @ch3i as there is an error is there anything in the Apache error logs?

    Hi Tom, I’ve updated from the latest SVN and the Search/List All Images are OK !


  • Moderator

    @Wayne-Workman said:

    @ch3i also, look at this: cat /var/log/fog_error_5874.log

    Executing /usr/sbin/update-rc.d FOGMulticastManager enable
    update-rc.d: error: FOGMulticastManager Default-Start contains no runlevels, aborting.
    

  • Moderator

    @Tom-Elliott said:

    @ch3i as there is an error is there anything in the Apache error logs?

    I’ve edited my first post, line break missing after the three ` !!!



  • @ch3i also, look at this: cat /var/log/fog_error_5874.log


  • Senior Developer

    @ch3i as there is an error is there anything in the Apache error logs?


 

341
Online

41.4k
Users

11.8k
Topics

112.2k
Posts