iPXE timeout after upgrade to trunk



  • Today I updated to latest trunk (from 1.2) with great help from the dev team.
    When I attempt to PXE boot a client PC, the client PC gets a valid IP and starts the iPXE process but fails with a timeout.

    iPXE 1.0.0+ Open source Network boot firmware – http://ixpe.org
    Features: DNS FTP HTTP HTTPS iSCSI NFS…
    PXEXT
    Configurign (net0 20:24:47:cb:75:e8)…ok
    received DHCP answer on interface net0
    tftp://192.168.1.1/default.ipxe… ok
    http://192.168.1.207/fog/service/ipxe/boot/php…connection timed out (http://ipxe.org/4c0a6035)
    could not boot: Connection timed out

    My FOG box is a laptop with eth1 192.168.1.1 (static) and wlan 192.168.1.207 (DHCP). I have the wlan turned off but it seems something is still pointing to that IP…
    help?


  • Senior Developer

    I’ve solved the thread.

    The timeout was because this system is on an isolated network.

    The isolated network IP is 192.168.1.1, but the wifi lan is set to 192.168.1.207 (which gives the device internet for upgraded/updating).

    To enable the installation to operate, I changed the IP address to 192.168.1.207 as the DB settings were already set.

    This ipaddress was used to generate the default.ipxe file which was what was causing the problem and I over looked it.

    Sorry :(



  • @Tom-Elliott lol Tom.


  • Senior Developer

    That was my bad sorry im an idiot sometimes.


  • Moderator

    @george1421 said:

    But I though there was a variable in that file and not hard coded

    I think that’s the only place it’s hard coded. The installer builds the file.


  • Developer

    default.ipxe is hard coded because the file is retrieved over tftp and cannot be easily generated on request. it’s value is based on answers given during install, or retrieved from the file .fogsettings in /opt/fog/ that is used for upgrade installs. it is here that you should edit ipaddress= setting to prevent the default.ipxe file from being incorrect after future installs.


  • Moderator

    @templink This may be a place to start: https://forums.fogproject.org/topic/6348/wrong-ip-on-pxe-boot/9

    But I though there was a variable in that file and not hard coded, so I may be a bit confused on this. I’ll have to power on my dev box and see if there is a static value in there.



  • @george1421

    thx i’ll look there.
    My FOG server is a laptop with 2 IPs: (eth1 192.168.1.1 static) and (wlan 192.168.1.207 dhcp)

    I checked the settings in FOG web GUI, they appear correct for TFTP server IP. = 192.168.1.1


  • Moderator

    @templink said:

    OK self-resolved.
    I modified /tftpboot/default.ipxe and restarted tftpd-hpa service
    it’s working now

    While its working I wonder how many pains it will give you the next time you upgrade your FOG server. There is a setting inside the FOG management console you need to update. Its in the FOG settings section that has the wrong IP address.


  • Moderator

    I’m a bit confused on your current setup. Your FOG server IS 192.168.1.1? Where does 192.168.1.207 come into play? It looks like your target computer thinks the fog server is there.



  • OK self-resolved.
    I modified /tftpboot/default.ipxe and restarted tftpd-hpa service
    it’s working now


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.