problem updating to trunk. Stopping web service......failed!



  • I am attempting to upgrade a previously working FOG install from 1.2 to latest trunk.
    I used git and successfully pulled down latest version.
    When I run the install script, I answered all the questions, and it begins.
    However, in the configuring services section, I get 7 OKs and then this:

    • Stopping web service…Failed!
      and it dumps me back to the command line.

    More info regarding my setup:
    During install, I use WiFi to connect to internet to ensure “active internet connection” requirement is met.
    Post install, this box will be on a private lan (no internet).



  • @Arrowhead-IT

    “What version of Ubuntu are you running?”

    Ubuntu 14.04 LTS



  • @Tom-Elliott Yeah i got through that. it was a firewall issue. i did the steps above but now getting:

    • Installing package: php5…Failed!

    so I ran:

    sudo -E add-apt-repository ppa:ondrej/php5-5.6

    and got:

    This branch follows latest PHP 5.6 packages as maintained by me & rest of the Debian pkg-php team.

    You can get more information about the packages at https://sury.org

    For PHP 5.5 use: ppa:ondrej/php5
    For PHP 5.4 use: ppa:ondrej/php5-oldstable

    BUGS&FEATURES: This PPA now has a issue tracker: https://deb.sury.org/pages/bugreporting.html

    PLEASE READ: If you like my work and want to give me a little motivation, please consider donating: https://deb.sury.org/pages/donate.html

    WARNING: add-apt-repository is broken with non-UTF-8 locales, see https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:

    apt-get install -y language-pack-en-base

    LC_ALL=en_US.UTF-8 add-apt-repository ppa:ondrej/php5-5.6

    More info: https://launchpad.net/~ondrej/+archive/ubuntu/php5-5.6
    Press [ENTER] to continue or ctrl-c to cancel adding it

    gpg: keyring /tmp/tmpshpbmela/secring.gpg' created gpg: keyring/tmp/tmpshpbmela/pubring.gpg’ created
    gpg: requesting key E5267A6C from hkp server keyserver.ubuntu.com
    gpg: /tmp/tmpshpbmela/trustdb.gpg: trustdb created
    gpg: key E5267A6C: public key “Launchpad PPA for Ondřej Surý” imported
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)

    I also ran the updater


  • Moderator

    @Arrowhead-IT said:

    even if it does get taken out later

    It’s fine if it gets taken out later. But having something that works is better than nothing at all. The @Developers can fix it the proper way when they have time.


  • Testers

    @Wayne-Workman That would work, but I feel like it’s kind of a bandaid to the issue rather than a real fix. We didn’t have to reinstall php for every fog update before, why do we suddenly need to do it now? Granted I do like the idea of contributing something to the official fog code, even if it does get taken out later… =)


  • Moderator

    @Arrowhead-IT Why not just add them to the installer for Ubuntu ?


  • Testers

    @Tom-Elliott @ManofValor
    I’ve had this problem on a few of the trunks in the last week. So I’ve just put those commands into a bandaid fix type script and it works everytime it happens, like this morning for example. Said script is just the same commands with some echo’s and -y for automation, looks like this…

    #!/bin/bash
    echo "running autoremove to clean up apt..."
    sudo apt-get autoremove --purge -y
    echo "removing php files..."
    sudo rm -rf /etc/php5
    echo "removing ondrej sources from apt..."
    sudo rm -rf /etc/apt-get/sources.d/*ondrej*
    echo "uninstalling php5..."
    sudo apt-get purge php5* -y
    echo "cleaning up apt..."
    sudo apt-get autoremove --purge -y
    exit
    

    Do we have any idea what is causing this or should I just add those commands to my update script reinstall php over and over and just not worry about it? Granted it doesn’t happen with every trunk, maybe 3 of them in the last week.

    I wonder if it’s specific to a linux distro? I am running Ubuntu Server 14.04
    @templink What version of Ubuntu are you running?
    @ManofValor Assuming you’re having this problem too, what linux distro are you running?


  • Senior Developer

    @Arrowhead-IT said:

    Maybe try the commands Tom suggested again? I did them out of order on accident since I was having the same problem and it worked for me.

    sudo apt-get autoremove --purge
    sudo rm -rf /etc/php5
    sudo rm -rf /etc/apt-get/sources.d/*ondrej*
    sudo apt-get purge php5*
    sudo apt-get autoremove --purge
    

    Then I reran the installer and all was well with the world. Maybe trying it again is worth a shot

    @ManofValor,

    More or less, the steps above are what the fix was. There was some minor variance but this was what got it to operate.

    If I recall, your particular issue was the server was unable to add another repository.



  • @templink Sure would be nice to know what the solution was?



  • @Tom-Elliott

    yes solved


  • Senior Developer

    I’m assuming it’s safe to solve this now?



  • @Wayne-Workman
    awesome thanks


  • Moderator

    @templink When you’re posting large chunks of code to the forums, please use the code box feature. It looks like in the pic below, it’s located just above the editing window. Highlight your code and then click the code box feature and it will wrap your code for you.
    0_1452121584358_upload-6d55b62f-69dd-42b8-88d5-829ed2f2240b


  • Senior Developer

    @templink Can you check your chat, are you able to tv?



  • @Arrowhead-IT

    thanks I just tried several rounds of apt-get with autoremove, autoclean, purge, etc. Apt-get seems to be OK now.
    I don’t know what is up… Fog install keeps failing at libapache2-mod-php5.


  • Testers

    Maybe try the commands Tom suggested again? I did them out of order on accident since I was having the same problem and it worked for me.

    sudo apt-get autoremove --purge
    sudo rm -rf /etc/php5
    sudo rm -rf /etc/apt-get/sources.d/*ondrej*
    sudo apt-get purge php5*
    sudo apt-get autoremove --purge
    

    Then I reran the installer and all was well with the world. Maybe trying it again is worth a shot



  • @Tom-Elliott
    so as it told me, I did ‘apt-get -f install’ and it updated some stuff
    then i reran the FOG installer. Now it fails at libapache-mod-php5:

     Here are the settings FOG will use:
                                   Base Linux: Debian
                          Detected Linux Distribution: Ubuntu
                             Server IP Address: 192.168.1.1
                                    Interface: eth1
                            Installation Type: Normal Server
                                       Donate: 0
                                Internationalization: 0
                            Image Storage Location: /images
                                  Using FOG DHCP: Yes
                                 DHCP router Address: 
                                   DHCP DNS Address: 
    
    
     * Are you sure you wish to continue (Y/N) y
    
                                  Installation Started
    
                      Installing required packages, if this fails
                   make sure you have an active internet connection.
    
     * Adding needed repository....................................OK
     * Preparing Package Manager...................................OK
     * Packages to be installed:
    
    	apache2 php5 php5-json php5-gd php5-cli php5-curl mysql-server mysql-client isc-dhcp-server tftpd-hpa tftp-hpa nfs-kernel-server vsftpd net-tools wget xinetd  sysv-rc-conf tar gzip build-essential cpp gcc g++ m4 htmldoc lftp openssh-server php-gettext php5-mcrypt php5-mysqlnd curl libc6 libcurl3 zlib1g php5-fpm libapache2-mod-php5
    
    
     * Skipping package: apache2...................................(Already Installed)
     * Installing package: php5....................................OK
     * Skipping package: php5-json.................................(Already Installed)
     * Installing package: php5-gd.................................OK
     * Skipping package: php5-cli..................................(Already Installed)
     * Installing package: php5-curl...............................OK
     * Skipping package: mysql-server..............................(Already Installed)
     * Skipping package: mysql-client..............................(Already Installed)
     * Skipping package: isc-dhcp-server...........................(Already Installed)
     * Skipping package: tftpd-hpa.................................(Already Installed)
     * Skipping package: tftp-hpa..................................(Already Installed)
     * Skipping package: nfs-kernel-server.........................(Already Installed)
     * Skipping package: vsftpd....................................(Already Installed)
     * Skipping package: net-tools.................................(Already Installed)
     * Skipping package: wget......................................(Already Installed)
     * Skipping package: xinetd....................................(Already Installed)
     * Skipping package: sysv-rc-conf..............................(Already Installed)
     * Skipping package: tar.......................................(Already Installed)
     * Skipping package: gzip......................................(Already Installed)
     * Skipping package: build-essential...........................(Already Installed)
     * Skipping package: cpp.......................................(Already Installed)
     * Skipping package: gcc.......................................(Already Installed)
     * Skipping package: g++.......................................(Already Installed)
     * Skipping package: m4........................................(Already Installed)
     * Skipping package: htmldoc...................................(Already Installed)
     * Skipping package: lftp......................................(Already Installed)
     * Skipping package: openssh-server............................(Already Installed)
     * Installing package: php-gettext.............................OK
     * Installing package: php5-mcrypt.............................OK
     * Installing package: php5-mysqlnd............................OK
     * Skipping package: curl......................................(Already Installed)
     * Skipping package: libc6.....................................(Already Installed)
     * Skipping package: libcurl3..................................(Already Installed)
     * Skipping package: zlib1g....................................(Already Installed)
     * Installing package: php5-fpm................................OK
     * Installing package: libapache2-mod-php5.....................OK
     * Updating packages as needed.................................OK
    
                            Confirming package installation.
    
     * Checking package: apache2...................................OK
     * Checking package: php5......................................OK
     * Checking package: php5-json.................................OK
     * Checking package: php5-gd...................................OK
     * Checking package: php5-cli..................................OK
     * Checking package: php5-curl.................................OK
     * Checking package: mysql-server..............................OK
     * Checking package: mysql-client..............................OK
     * Checking package: isc-dhcp-server...........................OK
     * Checking package: tftpd-hpa.................................OK
     * Checking package: tftp-hpa..................................OK
     * Checking package: nfs-kernel-server.........................OK
     * Checking package: vsftpd....................................OK
     * Checking package: net-tools.................................OK
     * Checking package: wget......................................OK
     * Checking package: xinetd....................................OK
     * Checking package: sysv-rc-conf..............................OK
     * Checking package: tar.......................................OK
     * Checking package: gzip......................................OK
     * Checking package: build-essential...........................OK
     * Checking package: cpp.......................................OK
     * Checking package: gcc.......................................OK
     * Checking package: g++.......................................OK
     * Checking package: m4........................................OK
     * Checking package: htmldoc...................................OK
     * Checking package: lftp......................................OK
     * Checking package: openssh-server............................OK
     * Checking package: php-gettext...............................OK
     * Checking package: php5-mcrypt...............................OK
     * Checking package: php5-mysqlnd..............................OK
     * Checking package: curl......................................OK
     * Checking package: libc6.....................................OK
     * Checking package: libcurl3..................................OK
     * Checking package: zlib1g....................................OK
     * Checking package: php5-fpm..................................OK
     * Checking package: libapache2-mod-php5.......................Failed!
    ubuntu@CSN-06:~/downloads/fog/trunk/bin$
    

    Mod edited to use code box.



  • I appreciate the quick response. I really want to get this back running today.
    the autoremove command somewhat failed (see output below).
    I was able to remvove the /etc/php5 folder.
    When i tried to reinstall FOG, it failed at installing php5 again.

    ubuntu@CSN-06:~/downloads/fog/trunk/bin$ sudo apt-get autoremove --purge
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     libapache2-mod-php5 : Depends: php5-common (= 5.6.16+dfsg-4+deb.sury.org~trusty+1) but it is not installed
                           Depends: php5-cli but it is not installed
                           Depends: php5-json but it is not installed
    E: Unmet dependencies. Try using -f.
    

    Mod edited to use code box.


  • Senior Developer

    @templink

    The error doesn’t mean much, but you can ensure things are a-ok with running:

    sudo apt-get autoremove --purge

    Then run:

    sudo rm -rf /etc/php5

    Then rerun the installer.



  • @Tom-Elliott

    The first command succeeded.
    The second ended with an error code 1, and Ubuntu crash reporter popped up.

    When I tried to re-run the installer, it fails at instaling php5.

    some of the output from the purge:

    Package 'php-horde-imap-client' is not installed, so not removed
    Package 'php-horde-imp' is not installed, so not removed
    Package 'php-horde-imsp' is not installed, so not removed
    Package 'php-horde-ingo' is not installed, so not removed
    Package 'php-horde-injector' is not installed, so not removed
    Package 'php-horde-itip' is not installed, so not removed
    Package 'php-horde-kolab-format' is not installed, so not removed
    Package 'php-horde-kolab-server' is not installed, so not removed
    Package 'php-horde-kolab-session' is not installed, so not removed
    Package 'php-horde-kolab-storage' is not installed, so not removed
    Package 'php-horde-kronolith' is not installed, so not removed
    Package 'php-horde-ldap' is not installed, so not removed
    Package 'php-horde-listheaders' is not installed, so not removed
    Package 'php-horde-lock' is not installed, so not removed
    Package 'php-horde-log' is not installed, so not removed
    Package 'php-horde-logintasks' is not installed, so not removed
    Package 'php-horde-lz4' is not installed, so not removed
    Package 'php-horde-mail' is not installed, so not removed
    Package 'php-horde-mapi' is not installed, so not removed
    Package 'php-horde-memcache' is not installed, so not removed
    Package 'php-horde-mime' is not installed, so not removed
    Package 'php-horde-mime-viewer' is not installed, so not removed
    Package 'php-horde-mnemo' is not installed, so not removed
    Package 'php-horde-mongo' is not installed, so not removed
    Package 'php-horde-nag' is not installed, so not removed
    Package 'php-horde-nls' is not installed, so not removed
    Package 'php-horde-notification' is not installed, so not removed
    Package 'php-horde-oauth' is not installed, so not removed
    Package 'php-horde-passwd' is not installed, so not removed
    Package 'php-horde-pdf' is not installed, so not removed
    Package 'php-horde-perms' is not installed, so not removed
    Package 'php-horde-prefs' is not installed, so not removed
    Package 'php-horde-queue' is not installed, so not removed
    Package 'php-horde-rdo' is not installed, so not removed
    Package 'php-horde-role' is not installed, so not removed
    Package 'php-horde-routes' is not installed, so not removed
    Package 'php-horde-rpc' is not installed, so not removed
    Package 'php-horde-scheduler' is not installed, so not removed
    Package 'php-horde-scribe' is not installed, so not removed
    Package 'php-horde-secret' is not installed, so not removed
    Package 'php-horde-serialize' is not installed, so not removed
    Package 'php-horde-service-facebook' is not installed, so not removed
    Package 'php-horde-service-twitter' is not installed, so not removed
    Package 'php-horde-service-urlshortener' is not installed, so not removed
    Package 'php-horde-service-weather' is not installed, so not removed
    Package 'php-horde-sesha' is not installed, so not removed
    Package 'php-horde-sessionhandler' is not installed, so not removed
    Package 'php-horde-share' is not installed, so not removed
    Package 'php-horde-smtp' is not installed, so not removed
    Package 'php-horde-socket-client' is not installed, so not removed
    Package 'php-horde-spellchecker' is not installed, so not removed
    Package 'php-horde-stream' is not installed, so not removed
    Package 'php-horde-stream-filter' is not installed, so not removed
    Package 'php-horde-stream-wrapper' is not installed, so not removed
    Package 'php-horde-support' is not installed, so not removed
    Package 'php-horde-syncml' is not installed, so not removed
    Package 'php-horde-template' is not installed, so not removed
    Package 'php-horde-test' is not installed, so not removed
    Package 'php-horde-text-diff' is not installed, so not removed
    Package 'php-horde-text-filter' is not installed, so not removed
    Package 'php-horde-text-filter-csstidy' is not installed, so not removed
    Package 'php-horde-text-flowed' is not installed, so not removed
    Package 'php-horde-thrift' is not installed, so not removed
    Package 'php-horde-timeobjects' is not installed, so not removed
    Package 'php-horde-timezone' is not installed, so not removed
    Package 'php-horde-token' is not installed, so not removed
    Package 'php-horde-translation' is not installed, so not removed
    Package 'php-horde-trean' is not installed, so not removed
    Package 'php-horde-tree' is not installed, so not removed
    Package 'php-horde-turba' is not installed, so not removed
    Package 'php-horde-url' is not installed, so not removed
    Package 'php-horde-util' is not installed, so not removed
    Package 'php-horde-vfs' is not installed, so not removed
    Package 'php-horde-view' is not installed, so not removed
    Package 'php-horde-webmail' is not installed, so not removed
    Package 'php-horde-whups' is not installed, so not removed
    Package 'php-horde-wicked' is not installed, so not removed
    Package 'php-horde-xml-element' is not installed, so not removed
    Package 'php-horde-xml-wbxml' is not installed, so not removed
    Package 'php-html-common' is not installed, so not removed
    Package 'php-html-safe' is not installed, so not removed
    Package 'php-html-table' is not installed, so not removed
    Package 'php-html-template-it' is not installed, so not removed
    Package 'php-htmlpurifier' is not installed, so not removed
    Package 'php-http' is not installed, so not removed
    Package 'php-http-request' is not installed, so not removed
    Package 'php-http-request2' is not installed, so not removed
    Package 'php-http-upload' is not installed, so not removed
    Package 'php-http-webdav-server' is not installed, so not removed
    Package 'php-image-text' is not installed, so not removed
    Package 'php-imlib' is not installed, so not removed
    Package 'php-invoker' is not installed, so not removed
    Package 'php-irods-prods' is not installed, so not removed
    Package 'php-jama' is not installed, so not removed
    Package 'php-kolabformat' is not installed, so not removed
    Package 'php-letodms-core' is not installed, so not removed
    Package 'php-letodms-lucene' is not installed, so not removed
    Package 'php-log' is not installed, so not removed
    Package 'php-mail' is not installed, so not removed
    Package 'php-mail-mbox' is not installed, so not removed
    Package 'php-mail-mime' is not installed, so not removed
    Package 'php-mail-mimedecode' is not installed, so not removed
    Package 'php-mdb2' is not installed, so not removed
    Package 'php-mdb2-driver-mysql' is not installed, so not removed
    Package 'php-mdb2-driver-pgsql' is not installed, so not removed
    Package 'php-mdb2-schema' is not installed, so not removed
    Package 'php-mime-type' is not installed, so not removed
    Package 'php-net-checkip' is not installed, so not removed
    Package 'php-net-dime' is not installed, so not removed
    Package 'php-net-dnsbl' is not installed, so not removed
    Package 'php-net-ftp' is not installed, so not removed
    Package 'php-net-imap' is not installed, so not removed
    Package 'php-net-ipv4' is not installed, so not removed
    Package 'php-net-ipv6' is not installed, so not removed
    Package 'php-net-ldap' is not installed, so not removed
    Package 'php-net-ldap2' is not installed, so not removed
    Package 'php-net-nntp' is not installed, so not removed
    Package 'php-net-portscan' is not installed, so not removed
    Package 'php-net-publicsuffix' is not installed, so not removed
    Package 'php-net-sieve' is not installed, so not removed
    Package 'php-net-smartirc' is not installed, so not removed
    Package 'php-net-smtp' is not installed, so not removed
    Package 'php-net-socket' is not installed, so not removed
    Package 'php-net-url' is not installed, so not removed
    Package 'php-net-url2' is not installed, so not removed
    Package 'php-net-whois' is not installed, so not removed
    Package 'php-nette' is not installed, so not removed
    Package 'php-numbers-words' is not installed, so not removed
    Package 'php-opencloud' is not installed, so not removed
    Package 'php-openid' is not installed, so not removed
    Package 'php-pager' is not installed, so not removed
    Package 'php-patchwork-utf8' is not installed, so not removed
    Package 'php-phpdocx' is not installed, so not removed
    Package 'php-sabre-dav' is not installed, so not removed
    Package 'php-sabre-event' is not installed, so not removed
    Package 'php-sabre-http' is not installed, so not removed
    Package 'php-sabre-vobject' is not installed, so not removed
    Package 'php-sabredav' is not installed, so not removed
    Package 'php-seclib' is not installed, so not removed
    Package 'php-sepa-direct-debit' is not installed, so not removed
    Package 'php-services-json' is not installed, so not removed
    Package 'php-services-weather' is not installed, so not removed
    Package 'php-soap' is not installed, so not removed
    Package 'php-structures-datagrid' is not installed, so not removed
    Package 'php-structures-datagrid-datasource-array' is not installed, so not removed
    Package 'php-structures-datagrid-renderer-htmltable' is not installed, so not removed
    Package 'php-structures-datagrid-renderer-pager' is not installed, so not removed
    Package 'php-symfony-classloader' is not installed, so not removed
    Package 'php-symfony-console' is not installed, so not removed
    Package 'php-symfony-eventdispatcher' is not installed, so not removed
    Package 'php-symfony-finder' is not installed, so not removed
    Package 'php-symfony-process' is not installed, so not removed
    Package 'php-symfony-routing' is not installed, so not removed
    Package 'php-symfony-yaml' is not installed, so not removed
    Package 'php-symfony2-yaml' is not installed, so not removed
    Package 'php-tcpdf' is not installed, so not removed
    Package 'php-text-captcha' is not installed, so not removed
    Package 'php-text-figlet' is not installed, so not removed
    Package 'php-text-password' is not installed, so not removed
    Package 'php-text-template' is not installed, so not removed
    Package 'php-text-wiki' is not installed, so not removed
    Package 'php-texy' is not installed, so not removed
    Package 'php-timer' is not installed, so not removed
    Package 'php-token-stream' is not installed, so not removed
    Package 'php-tokenreflection' is not installed, so not removed
    Package 'php-validate' is not installed, so not removed
    Package 'php-wikidiff2' is not installed, so not removed
    Package 'php-xajax' is not installed, so not removed
    Package 'php-xml-dtd' is not installed, so not removed
    Package 'php-xml-htmlsax3' is not installed, so not removed
    Package 'php-xml-parser' is not installed, so not removed
    Package 'php-xml-rpc' is not installed, so not removed
    Package 'php-xml-rpc2' is not installed, so not removed
    Package 'php-xml-rss' is not installed, so not removed
    Package 'php-xml-serializer' is not installed, so not removed
    Package 'php-zeroc-ice' is not installed, so not removed
    Package 'php5-adodb' is not installed, so not removed
    Package 'php5-exactimage' is not installed, so not removed
    Package 'php5-gdcm' is not installed, so not removed
    Package 'php5-gnupg' is not installed, so not removed
    Package 'php5-lasso' is not installed, so not removed
    Package 'php5-librdf' is not installed, so not removed
    Package 'php5-mapscript' is not installed, so not removed
    Package 'php5-midgard2' is not installed, so not removed
    Package 'php5-ming' is not installed, so not removed
    Package 'php5-pinba' is not installed, so not removed
    Package 'php5-remctl' is not installed, so not removed
    Package 'php5-rrd' is not installed, so not removed
    Package 'php5-sasl' is not installed, so not removed
    Package 'php5-stomp' is not installed, so not removed
    Package 'php5-svn' is not installed, so not removed
    Package 'php5-tokyo-tyrant' is not installed, so not removed
    Package 'php5-vtkgdcm' is not installed, so not removed
    Package 'php5-xhprof' is not installed, so not removed
    Package 'phpbb3' is not installed, so not removed
    Package 'phpbb3-l10n' is not installed, so not removed
    Package 'phpgacl' is not installed, so not removed
    Package 'phpmyadmin' is not installed, so not removed
    Package 'phppgadmin' is not installed, so not removed
    Package 'phpqrcode' is not installed, so not removed
    Package 'phpreports' is not installed, so not removed
    Package 'phpsysinfo' is not installed, so not removed
    Package 'phpunit' is not installed, so not removed
    Package 'phpunit-mock-object' is not installed, so not removed
    Package 'phpunit-selenium' is not installed, so not removed
    Package 'phpunit-story' is not installed, so not removed
    Package 'phpwebcounter' is not installed, so not removed
    Package 'phpwebcounter-extra' is not installed, so not removed
    Package 'python-sphinxcontrib.phpdomain' is not installed, so not removed
    Package 'sbnc-php-dev' is not installed, so not removed
    Package 'simplesamlphp' is not installed, so not removed
    Package 'slbackup-php' is not installed, so not removed
    Package 'suphp-common' is not installed, so not removed
    Package 'uphpmvault' is not installed, so not removed
    Package 'uwsgi-plugin-php' is not installed, so not removed
    Package 'zabbix-frontend-php' is not installed, so not removed
    Package 'php-horde-text-filter-jsmin' is not installed, so not removed
    Package 'libgv-php5' is not installed, so not removed
    Package 'libphp-phpmailer' is not installed, so not removed
    Package 'phpldapadmin' is not installed, so not removed
    Package 'php-mythtv' is not installed, so not removed
    Package 'php5-cgi' is not installed, so not removed
    Package 'php-pear' is not installed, so not removed
    Package 'php5-dev' is not installed, so not removed
    Package 'php5-imap' is not installed, so not removed
    Package 'php5-ldap' is not installed, so not removed
    Package 'php5-odbc' is not installed, so not removed
    Package 'php5-pgsql' is not installed, so not removed
    Package 'php5-recode' is not installed, so not removed
    Package 'php5-snmp' is not installed, so not removed
    Package 'php5-sqlite' is not installed, so not removed
    Package 'php5-sybase' is not installed, so not removed
    Package 'php5-xmlrpc' is not installed, so not removed
    Package 'php5-xsl' is not installed, so not removed
    Package 'php5-pspell' is not installed, so not removed
    Package 'php5-interbase' is not installed, so not removed
    Package 'php5-imagick' is not installed, so not removed
    Package 'php5-memcache' is not installed, so not removed
    Package 'php5-ps' is not installed, so not removed
    Package 'php5-xcache' is not installed, so not removed
    Package 'php5-tidy' is not installed, so not removed
    Package 'php5-xdebug' is not installed, so not removed
    Package 'php5-gmp' is not installed, so not removed
    Package 'php5-radius' is not installed, so not removed
    Package 'php-radius-legacy' is not installed, so not removed
    Package 'php-apc' is not installed, so not removed
    Package 'libapache2-mod-php5filter' is not installed, so not removed
    Package 'php5-dbg' is not installed, so not removed
    Package 'php5-geoip' is not installed, so not removed
    Package 'libssh2-php' is not installed, so not removed
    Package 'php5-enchant' is not installed, so not removed
    Package 'php5-memcached' is not installed, so not removed
    Package 'php5-intl' is not installed, so not removed
    Package 'php5-mongo' is not installed, so not removed
    Package 'php5-gearman' is not installed, so not removed
    Package 'pkg-php-tools' is not installed, so not removed
    Package 'libphp5-embed' is not installed, so not removed
    Package 'php5-ssh2' is not installed, so not removed
    Package 'php5-redis' is not installed, so not removed
    Package 'php5-oauth' is not installed, so not removed
    Package 'php5-mysqlnd-ms' is not installed, so not removed
    Package 'php5-apcu' is not installed, so not removed
    Package 'php5-msgpack' is not installed, so not removed
    Package 'dh-php5' is not installed, so not removed
    Package 'php5-phpdbg' is not installed, so not removed
    Package 'php5-libvirt-php' is not installed, so not removed
    Package 'php5-uprofiler' is not installed, so not removed
    The following packages were automatically installed and are no longer required:
      libmcrypt4 libonig2 libqdbm14
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
      libapache2-mod-php5* php-gettext* php5* php5-cli* php5-common* php5-curl*
      php5-fpm* php5-gd* php5-json* php5-mcrypt* php5-mysql* php5-mysqlnd*
      php5-readline*
    0 upgraded, 0 newly installed, 13 to remove and 3 not upgraded.
    After this operation, 30.3 MB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 201919 files and directories currently installed.)
    Removing php-gettext (1.0.11-1) ...
    Removing php5 (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing libapache2-mod-php5 (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module mysqli for apache2 SAPI
    php5_invoke prerm: Disable module mcrypt for apache2 SAPI
    php5_invoke prerm: Disable module json for apache2 SAPI
    php5_invoke prerm: Disable module pdo_mysql for apache2 SAPI
    php5_invoke prerm: Disable module curl for apache2 SAPI
    php5_invoke prerm: Disable module opcache for apache2 SAPI
    php5_invoke prerm: Disable module readline for apache2 SAPI
    php5_invoke prerm: Disable module mysqlnd for apache2 SAPI
    php5_invoke prerm: Disable module gd for apache2 SAPI
    php5_invoke prerm: Disable module mysql for apache2 SAPI
    php5_invoke prerm: Disable module pdo for apache2 SAPI
    ERROR: Module php5 does not exist!
    dpkg: error processing package libapache2-mod-php5 (--purge):
     subprocess installed pre-removal script returned error exit status 1
    Removing php5-readline (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module readline for cli SAPI
    php5_invoke prerm: Disable module readline for fpm SAPI
    Purging configuration files for php5-readline (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-fpm (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module mysqli for fpm SAPI
    php5_invoke prerm: Disable module mcrypt for fpm SAPI
    php5_invoke prerm: Disable module json for fpm SAPI
    php5_invoke prerm: Disable module pdo_mysql for fpm SAPI
    php5_invoke prerm: Disable module curl for fpm SAPI
    php5_invoke prerm: Disable module opcache for fpm SAPI
    php5_invoke prerm: Disable module mysqlnd for fpm SAPI
    php5_invoke prerm: Disable module gd for fpm SAPI
    php5_invoke prerm: Disable module mysql for fpm SAPI
    php5_invoke prerm: Disable module pdo for fpm SAPI
    php5-fpm stop/waiting
    Purging configuration files for php5-fpm (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-mysqlnd (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module mysqlnd for cli SAPI
    php5_invoke prerm: Disable module mysql for cli SAPI
    php5_invoke prerm: Disable module mysqli for cli SAPI
    php5_invoke prerm: Disable module pdo_mysql for cli SAPI
    Purging configuration files for php5-mysqlnd (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-mcrypt (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module mcrypt for cli SAPI
    Purging configuration files for php5-mcrypt (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-curl (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module curl for cli SAPI
    Purging configuration files for php5-curl (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-gd (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module gd for cli SAPI
    Purging configuration files for php5-gd (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Removing php5-mysql (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Purging configuration files for php5-mysql (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    dpkg: php5-json: dependency problems, but removing anyway as you requested:
     libapache2-mod-php5 depends on php5-json; however:
      Package php5-json is to be removed.
     php5-cli depends on php5-json.
    
    Removing php5-json (1.3.9-1+deb.sury.org~trusty+3) ...
    php5_invoke prerm: Disable module json for cli SAPI
    Purging configuration files for php5-json (1.3.9-1+deb.sury.org~trusty+3) ...
    dpkg: php5-common: dependency problems, but removing anyway as you requested:
     libapache2-mod-php5 depends on php5-common (= 5.6.16+dfsg-4+deb.sury.org~trusty+1); however:
      Package php5-common is to be removed.
     php5-cli depends on php5-common (= 5.6.16+dfsg-4+deb.sury.org~trusty+1).
    
    Removing php5-common (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    php5_invoke prerm: Disable module pdo for cli SAPI
    php5_invoke prerm: Disable module opcache for cli SAPI
    Purging configuration files for php5-common (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    dpkg: php5-cli: dependency problems, but removing anyway as you requested:
     libapache2-mod-php5 depends on php5-cli; however:
      Package php5-cli is to be removed.
    
    Removing php5-cli (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Purging configuration files for php5-cli (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Processing triggers for libapache2-mod-php5 (5.6.16+dfsg-4+deb.sury.org~trusty+1) ...
    Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
    Errors were encountered while processing:
     libapache2-mod-php5
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    

    Mod edited to use code box.


Log in to reply
 

440
Online

38948
Users

10699
Topics

101513
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.