Cannot Image HP Stream 11 Netbook



  • Hi

    I have been trying to image a HP Stream 11 using a SMSC LAN7500 USB to Ethernet adapter however I cannot get the Netbook to PXE boot and therefore image the device.

    What happens is when I create a Capture task in FOG, the netbook reboots and the adapters lights start flashing. Unfortunately it doesn’t PXE boot and instead boots into Windows 10. FOG is working as we can image older Toshiba and Acer netbooks fine.

    I’ve looked at this thread - https://forums.fogproject.org/topic/5431/ipxe-initialising-devices-sticking/19?page=2 and added has_usb_nic=1 to fog.reginput boot option as well as the netbooks Kernel Arguments and still no luck.

    BIOS is set to
    Secure Boot <Disabled>
    Legacy Support <Enabled>
    Network Boot Protocol <IPv4 (Legacy)>

    I have tried changing the bootfile in DHCP (windows 2008r2 server) to undionly.kkpxe and ipxe.efi and still no pxe boot. Do I need to make any changes to FOG or the FOG Server when I change bootfile in DCHP?

    Does anyone have any advice so I can get these devices imaging with FOG?

    FOG OS is Ubuntu 14.04
    FOG version is trunk 5852

    It also seems that FOG only lets you add new devices which has a unique MAC address. This means that we cannot image multiple Netbooks with the same USB to Ethernet adapter as the Netbooks will share the same MAC address. Is this something that can be fixed?

    My knowledge of linux / Ubuntu isn’t the best so go easy on my please.

    Cheers!

    Matt



  • @EAHarvey Several programs have found no issues with the drive.

    @Wayne-Workman Cannot do this right now as I only have 1 netbook in my Office but will give it ago when I can.

    Anyone else have an idea why I get this error when trying to deploy an image? https://forums.fogproject.org/uploads/files/1452520756237-error.jpg

    Thanks again.


  • Moderator

    @mwbutler said:

    Only issue now is how to deal with 100+ netbooks with the same mac address. Anyone know how I can get around this?

    I was talking to @Tom-Elliott about this issue a week or so ago - we have ideas about how to better handle it.

    But for now, manually create your hosts with their WiFi MAC address and give them a name as you desire. Inside of FOG Configuration -> FOG Settings -> something… -> early hostname change Turn that off. You’ll need to rely on the client to change names, and don’t worry, it does it fine.

    After creating the hosts manually, there’s a little “+” button by the MAC address. Use that to enter in the Mac Address of your USB NICs. Then there’s some checkboxes in that area also. Check the “Ignore mac for client” checkbox. Then throw your laptops into a group, assign your image, and tell them all to Unicast. Then image them one by one.

    Note that when you go to image them a 2nd time, it’ll be a lot easier because they will already be in the DB.





  • Just tried to deploy the image to the same netbook and got this <Error>. Anyone know what is causing it? See my post below for more info.



  • The ASIX AX88772B chipset adapter turned up today and after a bit of fiddling I managed to capture an image of a netbook ! Here are the host settings <Click me>, using bootfile called ipxe.efi and BIOS settings are Secure Boot <Disabled>, Legacy Support <Enabled>, Network Boot Protocol <IPv4 (Legacy)>. FOG version is trunk 5927.

    Only issue now is how to deal with 100+ netbooks with the same mac address. Anyone know how I can get around this?

    Thanks again for all your help, much appreciated!



  • @Hanz multiple part image, single disk (2)



  • @drc0nc ok I see the part about changing the host disk, but which format are you using ? (Multi part, single part-resize…etc)



  • @Hanz I was having the same problems, if you see my thread https://forums.fogproject.org/topic/6036/hp-stream-11-pro
    I had to change the host disk to /dev/mmcblk0 and that pointed fog to see the HDDs.



  • @mwbutler I’m currently working with this same machine… I did get it to pxe boot after changing option 67 to ipxe.efi. I think I left the legacy support disabled and it took off. Unfortunately my normal images won’t work due to there not being MBR apparently and it doesn’t find the hard drive, so I’m still in testing, but I will let you know.



  • @d4rk3 I tried that and that and it wouldn’t pxe boot.

    @drc0nc Thanks for the info. I’ve ordered a few adapters which have the ASIX AX88772B chipset so hopefully they will work.

    @Sebastian-Roth There are no PXE boot messages when the netbook is booting up. I pressed F12 (network boot) and after a few seconds the laptop boots to W10.

    The adapter I have doesn’t seem to work so I’m goign to give up on it for now and will try the new adapters next week.

    Thanks all.


  • Developer

    @mwbutler Do you see any PXE related messages on the screen while booting up? Tried hitting F12 on bootup? Do you see the USB NIC as a startup option to choose from? Might work in legacy or UEFI only or both. Depends on the system you have - not sure about the Stream 11 as I don’t have one to test.

    Pretty good comment on USB NIC PXE booting: http://www.msfn.org/board/topic/162015-usb-to-ethernet-adapters-and-pxe/?p=1072858



  • @mwbutler I use these for the time being Here
    but anything with the ASIX AX88772B chip ive seen work now.
    If you want to read through my long going post have at it.
    also, I have updated one of my streams to windows 10 and i can pxe into the menu but cant pull an image yet. haven’t done much testing yet on it though. I’m mainly using win 8.1 for now.



  • Turn legacy booting off. Then set the bootfile to any .efi file and try again.



  • @Tom-Elliott Yep the NIC is PXE bootable, it’s a StarTech USB21000S2 and this article here is why I bought it http://www.johnwillis.com/2014/03/pxe-booting-using-usb-to-ethernet-dongle.html.

    @Wayne-Workman Will do.

    @drc0nc I have network listed first in the bios and I’ve tried pressing F12 and no luck PXE booting. If I cannot get this adapter working then I will look into other adapters. Which ones did you get working? The Netbooks are HP Stream 11 11-R050SA.



  • I use ipxe.efi on these streams. Also when you first turn these puppies on you need to be hitting F12 or make sure you have network boot first. If it just skips everything I believe it’s the adapter. I have a couple of adapters I have tried and some just wont pxe boot. I have a usb 3 to gig ethernet adapter i’m trying out but it wont load the inits. I can boot to fog just fine though.

    I guess just try some adapters if you have the availability.
    Also, you said windows 10. are these the HP Stream 11 pro G2?


  • Moderator

    @mwbutler if you do get the SMSC LAN7500 USB to Ethernet adapter working, do let us know so we can add it to our working hardware list.


  • Senior Developer

    @mwbutler First,

    Is the USB Nic that you have PXE capable?

    has_usb_nic is only used in the init’s in the case that the USB nic isn’t working properly in the init, and you will only get this far IF the system has indeed PXE booted.

    You are correct, hosts can only be added with unique MACs. However, there are ways to correct for this already in the FOG system, of which, until you get PXE booting working, I will hold off on trying to define for you.

    You can change all the boot files and information you want, but if PXE boot isn’t even running, none of those changes are going to get you anywhere.

    Once the USB NIC is plugged in, you may have to go into the bios and make sure PXE Boot is turned on, though I’m not sure how to do that as I don’t have a system with a PXE Capable USB NIC to see and further help.


Log in to reply
 

407
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.