install from trunk - cofig errors (build 5790)



  • Hi all,
    yesterday I installed a new fog instance directly from last svn. Script quitted before ending (i tought it was for connectivity issues), so I needed to restart the install script.

    I got some troubles that I was able to solve, but I want to share as bugs (that probably is, but maybe are already solved in git, or it’s caused by the fog installation quitting on the first run. if it’s the case, sorry for bothering).

    • during install/reinstall, “fog” local user password is changed, but the changes has not been reflected on every config (I got one in tftp config file, one different in web-fog config-tftpboot and images management). I didn’t make a deep troubleshooting on this, but seems that if:
      • I change the password from web interface (tftpboot/storage rep) to reflect the correct one,
      • re-run ./installfog.sh
        then:
      • fog local user password changes
      • password in /opt/fog/.fogsettings changes
      • password in web interface (tftboot and storage rep) dont

    Another trouble:
    in storage management, “FTP Path” was empty, so I repeatedly had the error linked to that wiki:
    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#You_must_first_upload_an_image_to_create_a_download_task
    I know that the feature “ftp path” is relatively new, but maybe the wiki could be updated to reflect it.
    Note: AFAIR, the first time i run the ./installfog.sh it quitted with an error setting images folder, so probably it’s not a common issue.
    Note2: I kept the standard /images config on local disk of fog server and just confirmed what install script proposes.


  • Moderator

    From my experience, the installer doesn’t update users/passwords for the web interface for a re-installation. It just does it for the first installation.

    The FTP Path issue is more concerning to me. @Developers

    I also updated that part of the WiKi with this info:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP#You_must_first_upload_an_image_to_create_a_download_task


Log in to reply
 

360
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.