Installation woes: dhcp...Failed!



  • Hey All,

    I’m setting up FOG for the first time and I’m having some problems with the install. Following the installation guide I end up getting all of the packages installed except dhcp. I figured I could just install the dhcp package with yum but that’s failing as well. I’m trying to get to http://xxx.xxx.xxx.xxx/fog /fog/client and /fog/management but it won’t connect.

    Here is the error at the end of installation:

    Error Downloading Packages:
    [Errno 256] No more mirrors to try
    
    OS: CentOS 6.5
    DNS: working
    Internet: accessible
    LAN: accessible via SSH
    Firewall: disabled
    
    Followed all of the steps below:
    Type 1 and press Enter for Fedora/CentOS installation.
    Type N and press Enter for Normal installation.
    Supply IP Address, it should be the static IP address we setup earlier.
    Type Y and press Enter to setup DHCP Server address.
    Enter the DHCP Server address. If it's going to be the FOG Server, set it to the same IP Address as the FOG Server.
    Type Y and press Enter to set up DNS.
    Enter the DNS Server address.
    Type N and press Enter to leave the default network interface.
    Type N and press Enter to disable the FOG Server to act as the DHCP Server. Type Y to enable it.
    Type N and press Enter to not install additional languages, unless you want them.
    Type Y and press Enter to actually begin the installation.
    

    Any suggestions?



  • @Tom-Elliott Looks like there was something wrong with yum. I did a basic yum clean all and that seemed to solve my issues with connecting to the mirrors. I’m progressing through the installation now. Thanks again for all of your help everyone!


  • Senior Developer

    @kbramhall just going on a limb but I don’t think it’s directly related to dns but rather, based on the network structure, maybe limiting outgoing/incoming requests? Maybe firewall on the incoming side of things? The fact that it fails during mirror lookups makes me think transfer requests aren’t being allowed?



  • @Arrowhead-IT That’s a good idea. I’ll see if there is another test box I can try using. I did try those DNS servers and still having problems (also my mistake 4.2.2.2 is Level 3 not Google). I’ll speak with our networking team and one of our Sr Sys Admins and see if they have a second to look over the system. Thanks for all of your help and speedy responses @Tom-Elliott, @Arrowhead-IT , @george1421 and @Wayne-Workman


  • Testers

    @kbramhall said:

    @Arrowhead-IT As we’re troubleshooting I’m thinking it is definitely something with our internal networking configuration. The DNS servers we are using include google’s 4.2.2.2 and an internal DNS server.

    Isn’t google dns server 8.8.8.8 and 8.8.4.4 ?
    And if you’re using public dns’s maybe try opendns and see if that makes a difference
    208.67.220.220 and 208.67.222.222

    When you say internal network config, do you mean at the network infrastructure level or with the FOG server OS?
    If you think its the local network, do you have any other cent OS boxes, and if so are they able to install the packages?

    @kbramhall said:

    @Tom-Elliott Hey Tom, we are not dead set to use 1.2.0 we just figured we’d download the latest from the FOG project website :)

    Welcome to Fog, where if Tom were to release every stable release of the development branch it would be worse than Ccleaner updates.
    1.2.0 was the last time something was labeled stable. I use the trunk in production and rarely have any issues, and you get new features all the time! And if there ever is a problem it’s fixed in a snap. Only issue with your configuration and the trunk is that you wouldn’t have internet, so you wouldn’t be able to install and updates. Which overall would be fine, I’m one of the crazies on the bit torrent sync to the source files because I can’t wait the 20 seconds it takes Tom to hit the commit button.

    Anyway to install the trunk you’ll need git, svn, or btsync. Git is probably the easiest, svn is on sourceforge.net and they’ve gone down like 5 times in the last 3 months. There’s instructions on the wiki here https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk



  • @Tom-Elliott Hey Tom, we are not dead set to use 1.2.0 we just figured we’d download the latest from the FOG project website :)



  • @Arrowhead-IT As we’re troubleshooting I’m thinking it is definitely something with our internal networking configuration. The DNS servers we are using include google’s 4.2.2.2 and an internal DNS server.



  • @george1421 Yep, I can ping friendly names like mirrors.gigenet.com and google.com :)


  • Testers

    @kbramhall said:

    @Tom-Elliott I attempted to go through the installer and saying no to DHCP and DNS but if failed to install tftp-server this time. Attached is the foginstall.log file.0_1450298881023_foginstall.log

    I took a look at the install log and noticed this bit

    ../lib/redhat/functions.sh: line 1: n#: command not found
    

    I’ve seen that before. You need to both make sure that you’re running as the root user and make sure you’re running the install script from the bin folder.
    i.e. cd into where you downloaded/untarred the fog installer and then

    cd bin
    ./installfog.sh
    

    I figured out when making the automated update scripts that you can’t run it with the full path like
    /home/fog/installFoder/bin/installfog.sh
    because it use the trailing … to get to some included scripts. So you have to start the script from its happy home.

    Also, what happens when you try to install the packages that failed manually?
    I would try them one at a time. It looks like these ones…

    yum install tftp-server
    yum install xinetd
    yum install vsftpd
    yum install gcc
    yum install gcc-c++
    yum install lftp
    

    And I just had another thought, are you sure the firewall is completely disabled? I just remembered a recent experience where a fresh install cent OS wouldn’t do internet things until I flushed the iptables.
    Which if memory serves is

    iptables -F
    or
    iptables -f
    

    Hopefully something there helps


  • Senior Developer

    @Arrowhead-IT, @Wayne-Workman, @kbramhall, @george1421 I notice a few issues in the log. First is a typo (Staring Redhat install) that has no impact. But further down line 1: …/lib/redhat/functions.sh n#: or something very similar. @kbramhall how set are you to using 1.2.0? Would you be willing to try trunk? I think it may help out tremendously in the install process. Of course please verify /etc/resolv.conf has the proper dns info.


  • Testers

    @Wayne-Workman said:

    @Arrowhead-IT said:

    Just so you know. The reason I chose not to use DHCP with FOG is because I had the mistaken assumption that FOG would automatically manage it in some way, or that the gui would have some control over it. It does not, you’ll be doing a bunch of manual configuration.

    I guess now is as good a time as ever to say I’m working on an add-on that does just this.

    @Wayne-Workman ooooh! I like that idea!


  • Moderator

    @george1421 @Arrowhead-IT Good point. Right now I think we’ve got it narrowed down to either a DNS issue or a proxy issue.


  • Testers

    @kbramhall Considering that you only just set this up, maybe it’s worth trying a different distro. I’ve had better experiences with ubuntu server and fog then cent OS. But I am more familiar with debian so I might be biased.
    But maybe it’s an issue with the OS install.
    What happens when you run

    yum update
    

    ?
    If that doesn’t seem to connect to anything, then
    What does your resolv.conf say?

    cat /etc/resolv.conf
    

    Might be a dns server thing. That’s sometimes the issue when you can’t seem to install a package


  • Moderator

    To not add too much more noise to this thread. It looks like yum isn’t able to resolve the external repositories dns names.

    On this fog server, you set a static IP address, did you remember to update /etc/resolv.conf with the DNS servers the FOG server will use to query for internet names?

    Since you have direct internet access can you ping www.google.com? Or one of the repositories mirrors.gigenet.com?



  • @Tom-Elliott I attempted to go through the installer and saying no to DHCP and DNS but if failed to install tftp-server this time. Attached is the foginstall.log file.0_1450298881023_foginstall.log



  • @Tom-Elliott Sorry about that. Yes, the CentOS server is the what we’re running FOG on. I’ll just say FOG server moving forward to avoid any confusion. Yes it is successfully downloading other packages (httpd, php, php-cli, php-common, etc) but is not downloading the dhcp package. It has internet connectivity and will for the remainder of the setup. Once everything is up and running we’ll remove the internet connection and put it on an isolated subnet physically connected to the devices it needs to connect to.


  • Senior Developer

    Basically,

    Does the internet work? Is it installing other packages, but failing to install dhcp?

    I need clear concise answers.

    Forgive my methods, but understand:

    The CentOS machine has internet, it’s how I downloaded the installer, vs. The FOG Server is on Net with the clients, is not concise.

    I’m assuming, at this point, the CentOS machine you are referring to is the same as your FOG Server?


  • Senior Developer

    I’m confused.

    Are you downloading the installer, then disconnecting internet?



  • @Tom-Elliott The CentOS machine currently has internet access that’s how I downloaded the installer.


  • Senior Developer

    @kbramhall YEs, but not during the installation process.

    The installer needs to download the files to do the install to begin with.


Log in to reply
 

383
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.