Issue with Image Size: On Client



  • I am having a problem when I am attempting to image computers. I was imaging 64 Dell OptiPlex 990 desktop computers and all of them except 4 worked correctly. The 4 that didn’t work are causing an issue when I try to image them.

    I will register them with the fog server and everything works fine until after I have sent the download task to the host. When the host starts to download the image, the task completes in less than a minute and then shuts down the computer. The computer will not have imaged at all and when I check the image on the fog server the image size: on client changes to 0.0 with the image size: on server stays at 4.01. Once the Image Size: On Client has changed to 0.0 I can no longer use the image on other computers. I have to upload the image back to the fog server again to use it anymore.

    1. Is there a setting somewhere that is not allowing the host to image correctly and setting the image size: on client to 0.0?
    2. When the image size: on client is changed to 0.0 is there a way to fix the image so that when it happens I do not have to upload a new image again?

  • Moderator

    @jonathanh Excellent. Glad to help!

    Marking this issue resolved (or not, no option to…)



  • @george1421
    You were correct about the hard drive being bad. I replaced the hard drives and they have been imaging perfectly. Thanks for all your help!


  • Moderator

    Just be aware that because the hard drive has data on it today, doesn’t imply it doesn’t have a broken (soft) sector. Since all but for systems imaged OK, it probably safe to say that your image is in good shape. Then you have to ask what is different with these 4 systems. It is either bios version, bios settings or something physical. Since the systems are 4 years old, I’m suspecting the hard drive, but that is only a guess.

    Since you are using bios and not uefi the 1.2.0 stable version will and does work fine. If you were using uefi, I would have recommended that you upgrade to a pre1.3.0 release. But you should be good with 1.2.0.


  • Moderator

    It sounds like the image you’re trying to push to the client is too big for it.

    keep in mind - even a few sectors larger or a few KB larger and a non-resizable imaging task will fail.

    just because this Seagate says 250 and that Western Digital says 250 - that doesn’t mean they are absolutely equal. There are small variations that will bite you in the butt.

    Have you tried to upload the image as resizable and deploying it that way? This is what the resizable feature is for. And if you can successfully upload as resizable, there’s no valid reason not to upload as resizable.



  • @george1421

    Version 1.2.0
    bios system
    The hard drive is a known good hard drive. It has an image on it currently that I am trying to replace with a new image



  • Version 1.2.0
    bios system
    The hard drive is a known good hard drive. It has an image on it currently that I am trying to replace with a new image.


  • Moderator

    @jonathanh Lets start with the basics.

    What version of fog are you using? (1.2.0 or a SVN trunk pre 1.3.0 release)
    Are you trying to restore to a UEFI system or is this a bios system?
    The 990s are 4 years old (guess) have you tried replacing the hard drive with a known good drive? (I have seen a hard drive with a bad sector stop the download early)



450
Online

38927
Users

10692
Topics

101463
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.