Installation Problem



  • I’m trying to install FOG on Fedora 23 following this guide:
    https://wiki.fogproject.org/wiki/index.php/Fedora_21_Server

    Everything goes well until i get to this:

    • Downloading inits, kernels, and the fog client…Failed!

    I’m trying to install current trunk on Fedora 23 Server 64bit.

    What am i doing wrong?


  • Moderator

    @george1421 In fact, this one part of the installer has had a lot of issues in the past.

    instead of trying once and just giving up if it doesn’t work the first time - I think it should try again… at least 3 tries, just for problems like below where someone is trying to download the file over a crappy connection half the world away… @Tom-Elliott



  • @george1421 Please do marke it as solved. Thanks again.


  • Moderator

    Just for accuracy we can mark this solved?

    I hope your issue will not reoccur. If its something related to FOG or the installer again, please post back to a new thread. Cheers.



  • @Wayne-Workman said:

    You’re probably doing nothing wrong.

    Wayne was right. I was doing nothing wrong. When i tried to download the client manually, the download died shortly after i copied wget out to paste it here. A few moments ago i was able to succesfully download the client manually, and decided to run the installer again. This time, no issues, everything went just fine. The network guys say it’s a route issue, probably regional.

    Thank you guys for your time and effort, special thanks to Wayne who offered to remote in! You guys rock.


  • Moderator

    @guille_elia I do see some timeout command line switches that may be useful, but the wget response is a bit confusing to me. It looks like it tries the 192.30… address then it transfers to the 54.231… address and then finally download the file. From start to finish it looks like it took 52 seconds to actually get the file once it was located.

    Here are the timeout options with wget. Its not clear in my mind which one is at fault, since I don’t know what the default settings are. But I’m suspecting it was near the 302 redirect message.

    -T,  --timeout=SECONDS         set all timeout values to SECONDS.
          --dns-timeout=SECS        set the DNS lookup timeout to SECS.
          --connect-timeout=SECS    set the connect timeout to SECS.
          --read-timeout=SECS       set the read timeout to SECS.
     -w,  --wait=SECONDS            wait SECONDS between retrievals.
          --waitretry=SECONDS       wait 1..SECONDS between retries of a retrieval.
          --random-wait             wait from 0.5*WAIT...1.5*WAIT secs between retrievals.
    
    


  • @george1421 I do see veeeery slow speeds when connecting with AWS services from here (southern Brazil on a shitty connection) Could there be any timeouts?



  • @george1421 well i also thought it could be DNS, but isn’t:

    [xxxx@fogserver src]# wget https://github.com/FOGProject/fog-client/releases/download/0.9.7/FOGService.msi
    --2015-12-01 15:22:30--  https://github.com/FOGProject/fog-client/releases/download/0.9.7/FOGService.msi
    Resolving github.com (github.com)... 192.30.252.131
    Connecting to github.com (github.com)|192.30.252.131|:443... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: https://github-cloud.s3.amazonaws.com/releases/38578870/75535acc-89ef-11e5-9f7c-3abbb43dfc44.msi?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAISTNZFOVBIJMK3TQ%2F20151201%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20151201T172714Z&X-Amz-Expires=300&X-Amz-Signature=1f04a70e90648a37d791bd415fa28a53e0a76349c5b11228091575b74b503fd0&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3DFOGService.msi&response-content-type=application%2Foctet-stream [following]
    --2015-12-01 15:22:31--  https://github-cloud.s3.amazonaws.com/releases/38578870/75535acc-89ef-11e5-9f7c-3abbb43dfc44.msi?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAISTNZFOVBIJMK3TQ%2F20151201%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20151201T172714Z&X-Amz-Expires=300&X-Amz-Signature=1f04a70e90648a37d791bd415fa28a53e0a76349c5b11228091575b74b503fd0&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3DFOGService.msi&response-content-type=application%2Foctet-stream
    Resolving github-cloud.s3.amazonaws.com (github-cloud.s3.amazonaws.com)... 54.231.32.1
    Connecting to github-cloud.s3.amazonaws.com (github-cloud.s3.amazonaws.com)|54.231.32.1|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1933312 (1.8M) [application/octet-stream]
    Saving to: ‘FOGService.msi’
    
    FOGService.msi                          23%[================>                                                           ] 441.96K  41.5KB/s   eta 52s
    

  • Moderator

    @Wayne-Workman Just looking at drawing a connection here. All three files (kernel, inits, client) are downloaded via wget. If wget is in place then DNS resolution may be another issue. But starting with manually downloading the client agent will give us a better idea of the error.


  • Moderator

    @george1421 I noticed recently that the installer now ensures that wget is installed.


  • Moderator

    Is wget installed? The installer uses wget to pick up the files from the sourceforge servers. I might also expect the database backup to fail too if wget wasn’t installed.

    If wget is installed then see if you can use wget to download the client image. There should be a warning message during the installer script. Copy that out and run it manually from the command line. That may give you a better understanding of the error.

    I have seen proxy servers give issues if things are not setup correctly (I have one in my current environment). But you stated that there is no proxy server, so we won’t go down that rabbit hole.



  • SELinux is disabled as per the guide:

    [xxxx@fogserver ~]# getenforce
    Disabled

    No Proxy, SVN got the files just fine. I’ve updated several other packages with no problems.

    Are there any logs beeing generated when running the install script?


  • Moderator

    You’re probably doing nothing wrong.

    That guide works just fine.

    Is SELinux set to permissive?

    getenforce

    Are you behind a proxy?


Log in to reply
 

469
Online

38916
Users

10688
Topics

101381
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.