Can't load fast registering uc from pxe



  • Hi,

    first i need to say some things on the FOG installation. The installation process is not made form cd/dvd installation process. In fact you need to use Web package to complet install wihtout pb. I had do it anyway, but with pb. in fact it is possible, but screen information needed to switch dvd on device is droped into null so you dont know witch dvd or cd is needed to install package.

    My Fog installation is made on Debian 8 / Jessie x64, with kernel 3.16.0-4amd64 on a Virtualbox machine. there is two network devices configured (one to access internet and forward masquerading as router for other VM via the other network device).
    so ( internet->192.168.0.0/24 <-(.50) VM FOG/Gateway (0.1.1) ->10.0.0.0/8(vm network).<- VM UC )

    fog website is working, and pxeboot too. but i have some trouble with options automatic registering UC. the loading is stoped at 95% of second file and do not continue. i tryed to run pxe tests-> get ip, and it show a bad ip who cannot communicate with FOG server (ex:169.48.16.82). i don’t understand why client is malfunctionning.
    .
    i have somme difficulty to know if my parameters are exacts, could you expertise them:

    DHCPD.CONF:------------------------------------------------------------------------------------------------------------------------
    use-host-decl-names on;
    ddns-update-style interim;
    ignore Client-updates;
    next-server 10.0.1.1; # (local fog server gateway network port adress)

    subnet 10.0.0.0 netmask 255.0.0.0 {
    default-lease-time 21600;
    max-lease-time 21600;
    range dynamic-bootp 10.0.1.2 10.0.2.250;
    option broadcast-adress 10.255255.255;
    option subnet-mask 255.0.0.0;
    option domain-name-servers 192.168.0.254 ; #(internet gateway router dns via local server forward)
    option routers 10.0.1.1; #( local server interface for gateway service)
    filename “undionly.kpxe”;
    }
    subnet 192.168.0.0 netmask 255.255.255.0 {
    }
    END DHCPD.CONF:------------------------------------------------------------------------------------------------------------------------

    and then network config:
    INTERFACES ---------------------------------------------------------------------------------------------------------------------------------
    Auto lo
    iface li inet loopback

    Auto eth0
    Allow-hotplug eth0
    iface eth0 inet static
    address 192.168.0.50
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.254
    dns-nameservers 192.168.0.254
    post-up /sbin/iptables -t nat -A POSTROUTING -s 10.0.0.0/8 -o eth0 -j MASQUERADE

    auto eth1
    allow-hotplug eth1
    iface eth1 inet static
    address 10.0.1.1
    netmask 255.0.0.0
    network 10.0.0.0
    broadcast 10.255.255.255
    END INTERFACES -------------------------------------------------------------------------------------------------------------------

    so
    PXEBOOT OK, i have the PXE menu,

    PERFORMING “client system information (compatibility)”
    /bzimage32… 16% ( 53%…block and dont go ahead on random percentage.)
    /init_32.xz… 71% ( …block and dont go ahead on random percentage.)
    finaly after 4 try to load boot files.:
    -> fog compatibility test ( net [pass], and Disk [pass] )
    -> show dmi information ->ok
    -> partition information -> ok
    -> Ip information:
    Mac: ok : net 192.168.56.102 Mask /24
    SO DHCP DOES NOT WORK ???

    PERFORMING QUICK REGISTRATION AND INVENTORY
    /bzimage32… 100% (…block and dont go ahead on random percentage.)
    /init_32.xz… 26% ( …block and dont go ahead on random percentage.)
    after 6 try…
    using disk device /dev/hda
    attempting to register host … ( cant do it, never end research)
    -> restarting host
    -> adding manually the host in fog database
    -> reloading pxe
    -> Host registered as: TEST_XP, so communication is working between database and client
    -> quick image-> bad password
    -> product jey -> bad password

    What the ??? which password is it? BDD ? or FOG PWD ?
    how can i fixe pxe loading errors ?


  • Moderator

    @Tom-Elliott +1

    I have no idea what is going on in this thread.

    @megs In the future, please stop using acronyms in this manner. They are really confusing when not everyone is familiar and they are not defined early on in the OP.


  • Senior Developer

    @megs What are the letters?

    pb, uc, This is very confusing to read and try to follow.



  • @Sebastian-Roth so. it was not a fog client pb. all is working fine now.
    i had to reboot uc to restart vbox without dhcp. loading process work now perfectly.
    i had corected some parameters in host config too (bad manual entries).
    So no problems with multi-networkdevices on fog server. just user PB.

    Thanks for your time.
    -resolved-


  • Developer

    @megs Please keep us posted on this. I think you are on the right track!



  • it is probably, because there is more than one interfaces. there is a bad configuration in pxe client or fog client somewhere.
    ip information continue to be 192.168.x.x as client does not have dhcp adress.



  • @Sebastian-Roth
    yearhhh… dhcp battle… virtual box default dhcp désactivated now.
    But loading/init_32.xz… stoping at random precent loading anyway.
    It sems to be another pb.


  • Senior Developer

    @megs the login user and pass for any of the pxe menu stuff in 1.x.x is the GUI login user/pass. This could be anybody but for examples sake, if you’ve left the fog username and password as defaults, you would login through the menu using fog:password. Hopefully that helps.


  • Developer

    @megs said:

    My first pb is : the TFTP seems to be unstable and do not charge correctly needed files to run registering and imaging process. it stop loading them at random percent of loading. Fortunately reloading pxe and restarting operation grow up loading percentage each time. and it finaly work . i think it is a parameter somewhere who limit upload or download, or a time limit maybe…

    bzImage(32) and init(_32).xz are not loaded via TFTP but HTTP! To me this sounds more like a VM network issue but I can only guess. Are you keen to run wireshark (enable capturing on your FOG or client VM NIC) when a client boots up and upload the PCAP file so we can have a look??

    Mac: ok : net 192.168.56.102 Mask /24

    Virtualbox comes with a virtual internal DHCP server as well. Maybe that’s one of those IPs. Please read through this: https://www.virtualbox.org/manual/ch06.html



  • @Tom-Elliott
    sure i have install FOG onto a debian preinstalled , copnfigured, and tested, i said only: when you install FOG without internet install mode (so only with debian dvd), we have some problem to know witch dvd is needed to install needed packet because all disturbing messages are pushed to vaccuum ;). ( >null ).

    My first pb is : the TFTP seems to be unstable and do not charge correctly needed files to run registering and imaging process. it stop loading them at random percent of loading. Fortunately reloading pxe and restarting operation grow up loading percentage each time. and it finaly work . i think it is a parameter somewhere who limit upload or download, or a time limit maybe…

    @Quazz
    hmm, i do not use another user than fog user i have configured, but it is not working. he refuse to run operation with it. Entering web page is working perfectly. is the fog passord must be the same as mysql password ?

    It is a test system so no drop rules in iptables firewall.

    I’ll try another user.


  • Senior Developer

    I’m not understanding what the issue is. Fogs installer is not made to operate without the OS first being installed and configured. I will NOT code an installer in this way ever. Having multiple nics is fine but you need to ensure the right interface is configured for your environment. I think we need to know what the actual problem is that is directly related to the operation of fog. Pxe booting appears to be working but the file isn’t downloading the init and kernel fully? What else isn’t working?


  • Moderator

    @Quazz I use the fog user to do that. I never create another user, because there is no access control at this time ;)


  • Moderator

    @ch3i Really? I was never able to login with that.


  • Moderator

    @Quazz The default default FOG user is sufficient to use quick image, it have all rights.


  • Moderator

    For quick image you need to create a new user for it at the FOG WebGUI management page in order to use it.

    Not sure about the rest, does your network have a firewall? Does it have an existing DHCP?



468
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.