Cannot Image Host SVN 5455 USB NIC Inspiron 7348



  • I have upgraded my fog machine to SVN 5455 and I am trying to image multiple Inspiron 7348’s. when I connect it to the network using the usb nic it only sees one machine no matter which one I plug the usb adapter into not as different machines. That is not so much the problem because it is reading the mac from the adapter and after it images the machine I can rename and finish setting it up how I would like. In an earlier version of fog I was able to create and distribute images to these machines, but now it is hanging after it loads bzimage ok and init.xz ok. I am using bzimage 4.3.0, undionly.kkpxe, and in the fog web interface it shows the host in the task management list as “queued” I have turned on debug mode and set it to 7 and when I reboot it flashes information to quick to read but it hangs at

    "[firmware bug]: ACPI: BIOS _OSI(Linux) query ignored
    ACPI: Dynamic OEM Table Load:
    ACPI: SSDT 0xFFFF880255813800 0003D3 (v2 PmRef Cpu0Cst 00003001 INTL 20130117)
    ACPI: SSDT 0xFFFF8802558EF000 0005AA (v2 PmRef ApIst 00003000 INTL 20130117)
    ACPI: SSDT 0xFFFF880255AA2A00 000119 (v2 PmRef ApCst 00003000 INTL 20130117)

    Aslo I have secure boot turned off and boot set to legacy boot.

    any help would be Greatly Appreciated.



  • SUCCESS! I have successfully created and deployed the images for these machines in efi mode. Thank you for all the help!



  • this morning I updated to 5572 and after I fixed the memory problem that was not allowing the host page to load I was able to start the capture of the image. I will update again after it has finished about deploying the image to another machine but so far it looks like it may work.


  • Senior Developer

    @Sebastian-Roth I’m pretty sure I got the real escape string error now. I’m also fairly sure that while the error is annoying, this was not the cause of the inability to image. Of course a test and report would still be nice to have.


  • Developer

    At first sight I thought this might be a DB issue on jeffj’s system. But we have another report on this: https://forums.fogproject.org/topic/6228/unable-to-upload-image-svn-5495



  • @Sebastian-Roth

    yes sigh i did update i knew better but still did it anyway…the apache log has this:

    [Tue Nov 24 16:52:39.958421 2015] [:error] [pid 1359] [client xxx.xxx.xxx.xxx:58640] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/html/fog/lib/db/MySQL.class.php on line 165, referer: http://10.3.1.100/fog/management/index.php


  • Developer

    When a page from the web interface comes up blank you better check your apache error log (http://www.codeasite.com/index.php/linux-a-apache/94-how-do-i-find-apache-http-server-log-files) and post the last few lines. Did you update to the latest version? I wonder why this is happening just now.



  • well i have updated and configured the machine I wanted to image and when I click on the host link to select the host to start the upload I am unable to view the screen the host page is just blank…I checked the /var/www/fog/lib/pages folder and the hostmanagementpage.class.php has the node name as host and i dont know enough programming to find the information in the index.php that would point to the host page i am at a loss.


  • Developer

    @jeffj said:

    did that and changed my boot back to efi and when it boots it now gets to part clone interface

    Sounds great. Wouldn’t have thought that you can make it work using UEFI. Please keep us posted on this. Very interesting indeed! Would be great if you could post all the settings you used to make it work, e.g. BIOS/UEFI, undionly.kpxe/ipxe.efi, kernel parameters, kernel version, exact USB NIC model (PCI ID), … thanks!



  • some updates about this, I downloaded the init.xz and bzimage the way it is shown in the link, but when I tried to boot it failed at bzimage so I then went to kernel update in the fog gui and downloaded the 4.3.0 bzimage I noticed in my tftp folder I could change the undionly.kkpxe to ipxe.efi. did that and changed my boot back to efi and when it boots it now gets to part clone interface but fails. I think that part is because the image was made differently. I am going to remake the image and see what happens. as to weather or not I can boot to a live linux, I tried cent os and it hung and didnt boot and I dont have another os handy at this moment.


  • Developer

    @jeffj said:

    ACPI FADT declares the system doesn’t support PCIe ASPM, so disable it

    Yes, this is why I asked you to try pcie_aspm. Are you able to boot any sort of live linux on this machine?

    Edit: I really doubt that your kernel or init files are corrupt as you’d probably see crc or ext2 filesystem errors then. But you could still try downloading the latest kernel and init files by hand. Just to make sure… Take a look at my first post here: https://forums.fogproject.org/topic/6147/boot-menu-and-kernel-panic/2 (this is only the init files but I am sure you can do this for the kernels as well)



  • @Sebastian-Roth also I played the video myself and watched it step by step there is a part that says:

    Simple Boot Flag value 0x81 read from CMOS RAM was invalid
    Simple boot Flag at 0x44 set to 0x1
    ACPI FADT declares the system doesn’t support PCIe ASPM, so disable it

    not sure if you saw that.



  • I left it on over the weekend so hours and with the acpi_osi=Linux i left for over an hour. with the pcie_aspm=force longer than 10 min still no change.


  • Developer

    How long have you waited after seeing those messages? Seconds, minutes or maybe hours?
    Please remove the acpi_osi=Linux option and add this one pcie_aspm=force. See if this makes any difference and please wait a couple of minutes…




  • Developer

    Those files differ in size from version to version. But those sizes look pretty ok to me (definitely not just a halfway downloaded one!).
    One “simple” way to get the full output is taking a video. Most smartphones take pretty reasonable videos these days. Upload it somewhere and post a link.



  • So just got in the office this morning and checked the bzImage and init.xz files they are 6837408 and 16329408 respectivly those number do differentiate from the numbers you listed. Im not exactly sure how to re-download just those two files. I am not the best in linux so if there is a way to get the whole list of debug information from the boot sequence I don’t know how there may be better information to give you but it is flying by too quickly to read. when adding the acpi_osi=Linux it then gives the firmware bug BIOS _osi(Linux) query honored via cmdline but still hangs.


  • Developer

    @jeffj Those messages shouldn’t be a show stopper. See here for more information about it: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1275985

    You can try adding acpi_osi=Linux as a kernel parameter (FOG web gui -> Host -> settings) but this might cause other issues as I understand.

    I wonder if your bzImage and init.xz files were fully downloaded while installing. ls -al /var/www/fog/service/ipxe/{bzImage,init.xz} (or /var/www/html/fog…). bzImage ~ 6799776, init.xz ~ 16361748…


 

354
Online

41.8k
Users

12.3k
Topics

116.0k
Posts