Unable to upload image...SVN 5495



  • Cannot upload image from VM which I used just a few days ago…Now it hangs around 92-96% and never finishes, all the while the rate continues to drop like it loses connection, but that’s not the case. It is not creating the image folder correctly as it’s not listed under /images, but GUI shows the image exists (with size and all), but there is an entry under /images/dev that (time wise) reflects attempted upload.

    Apache error log shows the following repeatedly

    [Tue Nov 24 18:04:26.796910 2015] [:error] [pid 10013] [client 10.72.146.117:58493] PHP Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in /var/www/html/fog/lib/db/MySQL.class.php on line 165, referer: http://10.72.3.50/fog/management/index.php?node=home
    [Tue Nov 24 18:04:27.071830 2015] [:error] [pid 5087] [client 10.72.146.117:58494] PHP Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in /var/www/html/fog/lib/db/MySQL.class.php on line 165, referer: http://10.72.3.50/fog/management/index.php?node=home
    [Tue Nov 24 18:04:27.071898 2015] [:error] [pid 5087] [client 10.72.146.117:58494] PHP Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in /var/www/html/fog/lib/db/MySQL.class.php on line 165, referer: http://10.72.3.50/fog/management/index.php?node=home
    [Tue Nov 24 18:04:27.071943 2015] [:error] [pid 5087] [client 10.72.146.117:58494] PHP Warning: mysqli::real_escape_string(): Couldn't fetch mysqli in /var/www/html/fog/lib/db/MySQL.class.php on line 165, referer: http://10.72.3.50/fog/management/index.php?node=home
    

    all 1000 lines, and it’s not the ip of VM host.


  • Senior Developer

    It appears this was Hanz’s fault. He had snapshots and what not and it broke the upload process.


  • Moderator

    @Hanz said:
    Two of us were using it as we went through the building registering hosts.

    Off topic - but I just wanted to say that if you deploy the new client via Group Policy or scripting, it will auto-register any client that isn’t registered. On the Web UI, you simply have to approve these registrations for them to become regular hosts in the DB.

    #NewClient



  • This post is deleted!


  • @Sebastian-Roth That’s very possible, as we were at this school thursday doing some stuff and I didn’t have my computer with me. Two of us were using it as we went through the building registering hosts. Shouldn’t this log out after some time though ?

    Always logged in is unchecked per FOG Settings > login settings



  • @Tom-Elliott log issue still exists, but I’m currently trying to capture image from VM to test…they always take waaay longer from VM.

    UPDATE
    problem is still present near the end of upload. No image under /images,and /images/dev has new item with corresponding time.

    [bcs@fog-server images]$ ls -la
    total 140
    drwxrwxrwx  35 fog  fog  4096 Nov 24 11:48 .
    dr-xr-xr-x. 22 root root 4096 Nov 24 18:34 ..
    drwxrwxrwx   2 fog  fog  4096 Oct 22 13:36 11e_ADI_10-15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 09:31 6510bFeb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 09:42 6530bFeb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 09:54 6550b
    drwxrwxrwx   2 fog  fog  4096 Oct 16 10:03 6560bFeb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 10:16 6570bApril
    drwxrwxrwx   2 fog  fog  4096 Oct 16 10:30 6730bFeb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 15:08 dc5700Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 10:52 DC5800April
    drwxrwxrwx   2 fog  fog  4096 Oct 16 11:05 DC7800April
    drwxrwxrwx   3 fog  fog  4096 Nov 24 14:41 dev
    drwxrwxrwx   2 fog  fog  4096 Oct 16 11:45 HoneycombMarch15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 11:22 HP6300ADI
    drwxrwxrwx   2 fog  fog  4096 Oct 16 11:33 HPSmallFF
    drwxrwxrwx   2 fog  fog  4096 Oct 16 12:06 L512ADI827
    drwxrwxrwx   2 fog  fog  4096 Oct 16 12:18 L512Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 12:27 LenovoE540
    drwxrwxrwx   2 fog  fog  4096 Oct 16 12:40 M82ADI610
    -rwxrwxrwx   1 fog  fog     0 Oct 16 08:49 .mntcheck
    drwxrwxrwx   2 fog  fog  4096 Oct 16 09:25 postdownloadscripts
    drwxrwxrwx   2 fog  fog  4096 Oct 30 11:26 Secretary1030ADI
    drwxrwxrwx   2 fog  fog  4096 Oct 16 12:56 SL400Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 13:09 SL500Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 13:21 SlantLenovo
    drwxrwxrwx   2 fog  fog  4096 Nov 20 09:15 SolidLenovo
    drwxrwxrwx   2 fog  fog  4096 Oct 16 13:42 SysprepImagex64
    drwxrwxrwx   2 fog  fog  4096 Oct 16 13:54 SysprepImagex86
    drwxrwxrwx   2 fog  fog  4096 Nov 24 11:48 SysprepX86-11-1
    drwxrwxrwx   4 fog  fog  4096 Oct 16 14:03 System Volume Information
    drwxrwxrwx   2 fog  fog  4096 Oct 16 14:03 T420Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 14:15 T530Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 14:27 T540Teachers
    drwxrwxrwx   2 fog  fog  4096 Oct 16 14:44 T60Feb15
    drwxrwxrwx   2 fog  fog  4096 Oct 16 14:56 X131Feb15
    

    and this is /images/dev

    [bcs@fog-server images]$ cd dev
    [bcs@fog-server dev]$ ls -la
    total 12
    drwxrwxrwx  3 fog  fog  4096 Nov 24 14:41 .
    drwxrwxrwx 35 fog  fog  4096 Nov 24 11:48 ..
    drwxrwxrwx  2 root root 4096 Nov 24 18:48 080027ffa39e
    -rwxrwxrwx  1 fog  fog     0 Oct 16 08:49 .mntcheck
    

    Sysprep-Test is new image I’m trying to upload.


  • Senior Developer

    @Hanz Is this actually after updating?


  • Developer

    Possibly your own client having the web interface open??? Please see which client belongs to this IP.



  • @Sebastian-Roth any idea what is going on with the log ? This is just one machine, I’m not sure if it’s stuck in a boot loop or what.


  • Developer

    Should be fixed in the very latest thanks to Tom. Please update and let us know!


Log in to reply
 

421
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.