SOLVED (r5207) Host Management bugs


  • -Deleting a host removes it from the host list but manually browsing to its old URL (http://xxxx/fog/management/index.php?node=host&sub=edit&id=152) and the host remains with blank information. Browsing to its old URL for deletion does not remove it either.

    -Unable to set BIOS/EFI exit types on new hosts. Any options set for either do not stick after updating the host with the desired options.

    -Random hosts do not have button to reset encryption data anymore.

    -When deploying two snapins to a host only one deployed successfully.

    -Hosts join AD before hostname changes instead of after the hostname changes like they normally do.


  • @Tom-Elliott I am aware. This is fixed too, btw 🙂


  • Random encryption display/ or not is the intended behavior. You will only be presented the button if the host actually has a key and/or security token established for it.


  • I have made it so invalid hosts such as what you explained of Hitting back after deleting will redirect to the index and inform you that that object is no longer valid.


  • @Sebastian-Roth The AD issue is fixed. The snapin issue is fixed. I’ll report back soon about the rest.

  • Senior Developer

    @d4rk3 Are you still seeing any of the issues after updating to the latest trunk?

  • Senior Developer

    @d4rk3 Could you please update to the latest trunk and see if you still find issues. Tom fixed a lot of things lately!


  • I think that this issue is related to this issue, the bits about host deletion match up exactly.
    https://forums.fogproject.org/topic/6051/virus-history-is-empty-after-clamav-scan

    @x9rok said:

    @Tom Elliott

    So i have done an upgrade via wget like you said.
    Now the FOG-Server installation has the version 5209.

    Kernel Versions are:

    • bzImage Version: 3.15.6
    • bzImage32 Version: 3.15.6

    To be sure i removed the testclient from the hostlist and tried to add it again via “Perform full Host registration and inventory”. This procedure fails with following message: “Unable to register for the following reasons: and then --> BLANK…”.

    I tried to use an existing host from the Hostlist and create a task (Clamav Virusscan). The task doesn’t run.
    I started the testclient and you could see the FOG-Boot-Menu (Boot from local hard disk, Memtest and so on…)

    When i try to delete a task, nothing happens and the task is still in the list.

    So Tom do you have another idea ?
    Is there a newer Version than 5209 ? If yes, how can i check this ?
    Maybe there some other updates available ?

    Thanks.

    Richi

321
Online

8.7k
Users

15.4k
Topics

144.0k
Posts