• fog.download has been rewritten.

    I’ve made quite a few adjustments and calculations for this and have tested the resizable download capability.

    With this, i believe i fixed upload and download with multipart types (non resize) as well.

    This should be the most non-assumptive init yet.

    While I’m sure I could post this to the masses, I’d rather those of you with these “weird” hard drives test this and verify if the findings are correct and things are working correctly.

    I have performed some decent testing, but I’d rather rely on information straight from those of you who have this issue.

  • Moderator

    @Tom-Elliott said:

    I can add in the checks if you want.

    That said, I’m kind of scared to enforce write access to this partitions.

    While you are at it… See if you can add this as well. I felt kind of the same when first reading about the read only boot partitions. But on the other hand this is kind of like writing the MBR or partition layout. If we do something wrong there things can really go wrong. But we still do because we need to. Same with those boot partitions on mmcblk devices I reckon. We just won’t get around writing to those if we want to properly deploy to those kind of devices.

  • @Tom-Elliott @Sebastian-Roth I thank both of you guys! I can wait, no problem. Also, you need me to test any of it, I’m more than willing.

  • @Sebastian-Roth said:

    al thing about mmcblk0bootX devices being readonly by default. I’ll have a look on how to check and automaticly enable write access in fog.download.

    I’m re-refactoring the fog.download to follow similar methodology as the fog.upload script does.

    I can add in the checks if you want.

    That said, I’m kind of scared to enforce write access to this partitions.


  • Moderator

    @drc0nc That’s great news. Thanks! Tom has worked on the init files/fog scripts lately. Refactoring and improving the code a lot. Please be patient for a few more days. The newly released init files will have all the changes included. Would be great if you could test those then as well. I will let you know.

    @Tom-Elliott see this special thing about mmcblk0bootX devices being readonly by default. I’ll have a look on how to check and automaticly enable write access in fog.download.

  • @Sebastian-Roth Ok, sorry I was out of office for a few days.
    I got the image to pull just fine using your test files. Ran into the read only problem on the boot0 and boot1

    I just used the

    echo 0 > /sys/block/mmcblk0boot0/force_ro
    echo 0 > /sys/block/mmcblk0boot1/force_ro

    and it let me push an image on it. I’m just pretty happy the partitions weren’t locked permanently. What are the next steps moving forward on this?

    Also, I appreciate the help and hope that other people with these MMC devices can start imaging.

  • Moderator

    @drc0nc Here we go. I found some time to look into this more closely!
    Download init.xz/init_32.xz test files from https://drive.google.com/folderview?id=0B-bOeHjoUmyMazJLZDhGaEl5VTQ&usp=sharing and put into place in /var/www/fog/service/ipxe/ or /var/www/html/fog/service/ipxe/ (probably a good idea to rename the original files instead of just overwriting them!)

    Please test and report back if capturing/deploy is working (Image type: Multiple Partition - Single Disk, Host Primary Disk: /dev/mmcblk0).

    We might still run into issues if mmcblk0boot0 is read only by default. So please check my last post as well and let us know.

  • Moderator

    @drc0nc Thanks a lot for all the testing and the information you gave. We are working on this. Although it’s not easy when we don’t have the devices handy to test. mmcblk0 devices are not as easy to handle as other block devices are. And I just stumbled upon another thing that might cause issues when deploying an image to a new client. Could you please run another debug session on one of your devices and check if writing to the MMC boot partitions is disabled by default (as described here: https://www.kernel.org/doc/Documentation/mmc/mmc-dev-parts.txt)

    cat /sys/block/mmcblk0boot0/force_ro
    cat /sys/block/mmcblk0boot1/force_ro

  • @Wayne-Workman @Sebastian-Roth @Tom-Elliott So today I figured I would update the trunk (5686) and the bzImage. Today’s 4.3.0 was still forcing me to pull an image using the RAW format. The other options will give me the oversize error. Also, the ipxe boot is asking me to manually input the fog server IP while using ipxe.efi after updating. All in all I can still image, just only doing it RAW (pun intended)

  • @Sebastian-Roth I guess, sorry. I know my bzImage and bzImage32 file versions are 4.2.3 (that’s what allowed me to get these babies going.)

  • Moderator

    @drc0nc Hey man, sorry again. I am getting a little confused here. Clearly you are using a newer kernel (bzImage/init.xz) than rev5293 as fogpartinfo is not included anymore. This is not a problem! Just means that the output of lsblk is relavant.

    @Tom-Elliott Changing from fogpartinfo to lsblk - have you tried special things like mmcblk yet? Fram what I can see in the code the major ID 179 is not being taken care of. Could you update the script?

  • @Wayne-Workman lol no sorry. I meant update the revision. I know that 5293 was a working release with the streams so I only installed that one again

  • @drc0nc said:

    BTW I want to upgrade trunk but i’m afraid that I’ll lose functionality for the HP’s.

    Oh. I interpreted that line as if you were on 1.2.0.

  • @Wayne-Workman I’m running version 5293 currently

  • @drc0nc Well if you’re using 1.2.0 stable - it’s not changed. Something else must have changed.

  • @Wayne-Workman I’ll be heading over to one of the other schools today. I’ll bring a couple HP’s and try it from there and see if an updated trunk will let me boot. I’m just curious as to why I can’t image using anything other than RAW when it was letting me before. (on the HP’s)

  • @drc0nc I was going to suggest creating a DHCP Reservation for one of the adapters, and point it’s option 066 (for the reservation only) to the FOG server in the other building that is running FOG Trunk.

    See what luck you have…

    That’ll cause it to use that fog server.

  • @Sebastian-Roth fogpartinfo isn’t a valid command

  • Moderator

    @drc0nc Sorry, updated my last post as I remembered that Tom changed this not long ago. Please try fogpartinfo --list-parts /dev/sda and see if you get any errors.

  • @Sebastian-Roth the output was

    /dev/mmcblk0      179:0
    /dev/mmcblk0boot0 179:8
    /dev/mmcblk0boot1 179:16
    /dev/mmcblk0p1    179:1
    /dev/mmcblk0p2    179:2
    /dev/mmcblk0p3    179:3
    /dev/mmcblk0p4    179:4
    /dev/mmcblk0rpmb  179:24