Fog Doesn't copy all Partitions



  • hello again :D
    so finaly i got it to work ! and im able to start a task that should clone the whole disk with multiple partitions
    but … it only takes 1 partition out of the disk, the disk partitioned that 11.7gb are for recovery which only 8.7 in use.
    another 453gb are OS (c:)
    and the OEM 30MB Partition
    so ive set the image to be " Multiple Partition - single disk" and it only copyed 11.7GB (which is clearly the recovery partition)
    then i tryed the “Multiple Partition - all disks” same result …
    does anyone know why could it do that ?

    Running Fog 1.2.0 on Centos 6.5



  • ok so ive changed all the passwords on the server to 1 password and now it is all working
    thank you all very much and have a great day :)



  • @Nox245 Tom is right, this is a FTP credentials issue most likely. NFS is used to upload the image to /images/dev and then FTP is used to move the image (once uploaded) from /images/dev to /images. the username/pass used for this are set in the storage node’s settings area in the web interface. You must also have a matching user account on the actual linux box with FTP permission. The installer does all of these things for you, but changing things can goof them.

    That troubleshooting ftp article posted by @Sebastian-Roth below gives steps on how to correct this.


  • Senior Developer

    @Nox245 said:

    so ive seen the whole process this time and it actualy gets to 100% and it has a complete image of the disk,
    it says its done uploading the image bot i dont really have it in the server here’s a pic: http://postimg.org/image/6xmtu1izr/
    @Wayne-Workman
    yeah it has enough space for the image, i got 67gb free space on the server and fog sees it. the whole image is about 52gb.
    @Uncle-Frank
    ive changed the passwords in /opt/fog/.fogsettings and in Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD
    all the passwords are the same and the error still shows like its trying to use some random password… i rebooted fog before trying the imaging again.

    The only password that fog uses for imaging is the one set to the storage node. Goto storage management, select the relevant master node and look down the bottom of the screen. Ensure the proper username and password match your nodes credentials.



  • so ive seen the whole process this time and it actualy gets to 100% and it has a complete image of the disk,
    it says its done uploading the image bot i dont really have it in the server here’s a pic: http://postimg.org/image/6xmtu1izr/
    @Wayne-Workman
    yeah it has enough space for the image, i got 67gb free space on the server and fog sees it. the whole image is about 52gb.
    @Uncle-Frank
    ive changed the passwords in /opt/fog/.fogsettings and in Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD
    all the passwords are the same and the error still shows like its trying to use some random password… i rebooted fog before trying the imaging again.



  • @Nox245 Is there enough free space on the Fog Sever? df -h

    CentOS defaults the / directory to have 50GB.


  • Developer

    Interesting. This definitely should not happen in the middle of partclone running. Did you actually see partclone closing in the middle of reading or do you guess it did because it looks like it in the web interface?

    Please follow this guide to make sure FTP is working properly: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP (especially the section on passwords)



  • so ive upgraded fog to trunk
    created the image and the host and everything
    started the task, it copied 2 partitions 100% but on the third partition it stoped around 58% and sudenly died
    and shown on the screen that : http://postimg.org/image/4bl20riq7/
    thats how the task progress looks like : http://postimg.org/image/4mjxwjlgf/
    and really … its in a midle of the last partition …


  • Developer



  • @Uncle-Frank

    –list-devices only shows /dev/sda/

    how do i upgrade to trunk ?

    BTW unfortunately i do need the dell recovery in my image


  • Senior Developer

    @Uncle-Frank gotcha I see it now. Didn’t realize it through the text.


  • Developer

    @Tom-Elliott He already posted a picture with --list-parts. Looks good. I am pretty sure that --list-devices will be fine too then.


  • Senior Developer

    @Nox245 can you also get the output of fogpartinfo --list-devices and fogpartinfo --list-parts /dev/sda?


  • Senior Developer

    @Nox245 the problem is your image. First the recovery partition is a dell utility, and while I believe this is fixed in trunk I cannot say for 100% as I don’t typically create my images using the default layout from the manufacturer.

    That aside I believe you specific problem lies with the sector starting at 63. 1.2.0 was a fairly stable release but it missed the sector layout by always trying to start everything at 2048. Maybe you could upgrade to trunk and try again? I think it may work, but it is no guarantee.



  • @Uncle-Frank
    heres what i got from the debug : http://postimg.org/image/4s2mo8o13/


  • Developer

    Well, and we are still not sure if FOG is able to see this using the tools it does when capturing an image!! Again, I kindly ask you to run a debug session to see what fogpartinfo and fdisk (not as important as fogpartinfo) is telling us.
    I have seen unexpected und weird errors coming up that you just won’t see with other tools (especially not windows disk manager!). fogpartinfo is used within FOG upload and you won’t get around looking at what it tells you about your partitions…



  • @Uncle-Frank
    Heres a pic to how ive checked its MBR - http://postimg.org/image/qfflha02z/
    heres fogs compatibility http://postimg.org/image/ofhuu82fz/
    and heres how he sees the partitions http://postimg.org/image/3vovermbd/



  • @Joseph-Hales said:

    If this system is still running the original load from dell it most likely has a gpt partition which fog doesn’t like.

    From my experience, a scratch installation using UEFI and setting up GPT disks, fog trunk will accept and deploy just fine.

    It’ll deploy to a dissimilar disk that had MBR on it previously, it’ll deploy to a partially “zero’d” disk, and to a disk formatted with GPT but laid out differently as well… So it’s not making any use of existing GPT structures, it really does build them correctly according to the image.


  • Developer

    @Nox245 How did you check that it is MBR and could you please the commands in debug mode as suggested further down - just to make sure that FOG is able to see your partitions…



  • For a second i wasnt sure about that so i checked again … its MBR.


 

425
Online

5.4k
Users

12.6k
Topics

118.9k
Posts