Updating Build 4820 on CentOS 7.1



  • Updating a working 4820 install on CentOS 7.1 with build 5012 .

    Configuring services.
    
     * Stopping FOGMulticastManager.service Service................OK
     * Stopping FOGImageReplicator.service Service.................OK
     * Stopping FOGSnapinReplicator.service Service................OK
     * Stopping FOGScheduler.service Service.......................OK
     * Stopping FOGPingHosts.service Service.......................OK
     * Setting up and starting MySQL...............................Failed!
    [root@devfog bin]#
    

    Then immediately trying the install/update again, the install will reach;

    You still need to install/update your database schema.
      This can be done by opening a web browser and going to:
    
          http://172.19.244.13/fog/management
    
      Press [Enter] key when database is updated/installed.
    

    But, web access is a fat 404 .


  • Moderator

    @sudburr It is major, but I don’t think it would affect the DB stuff…

    Maybe you can try this option tomorrow?



  • @Wayne-Workman said: My CentOS 7 build I have on my desk at work uses “Server with GUI”, with all three virtualization options ticked.

    Well that’s a major difference right there. I’m only using minimal install. No GUI.


  • Moderator

    @sudburr My CentOS 7 build I have on my desk at work uses “Server with GUI”, with all three virtualization options ticked. Then, inside of a VM on that, I have another “Server with GUI” built. And on that, Fog installs just fine. and updates just fine. That’s with having a fully updated server before hand of course, running yum update -y

    Everything about the build is default.
    SELinux and Firewalld are disabled of course, as well.



  • Hmm,

    • virgin CentOS 7.1 minimal install
    • install build 4820 : no configuration changes made
    • install build 5036

    The update to 5036 still fails on the first attempt, at the same setting up/start MySQL.

    A second invocation to update to 5036 completes properly.

    The http pathing problem is due to changes I make.



  • Considering some of the changes I make from default, it may have been self-inflicted, but the changes I’m thinking of are necessary to make some things work.

    I’m going to fire up another scratch CentOS 7.1 server and start from there and see where it goes.


  • Senior Developer

    I have solved this thread as the issue received has a fix and a workaround for the fix has been posted here. That said I don’t know that I fully understand what happened. Usually you don’t do a redirect from the base url. This way you can still host other things if needed. So maybe the webroot setting got incorrectly set? Webroot can be species however you want it to be. I will take a look and see if there’s anything I can do to fix the problem but I think I need more details.



  • A few things.

    Removing MariaDB prior to upgrading, removes the MySQL fail from the FOG Installer. The FOG installer fixes things up.
    Running the FOG installer twice gets things just as far.

    At the:

    You still need to install/update your database schema.
      This can be done by opening a web browser and going to:
    
          http://x.x.x.x/fog/management
    
      Press [Enter] key when database is updated/installed.
    

    I can either remote in via another session to apply the following fix, or [Enter] to continue to completion then apply this fix:

    sed -i -e "s|/management|/fog/management|g" /var/www/html/fog/index.php
    

    Visit the home page, http://x.x.x.x/ which redirects me to http://x.x.x.x/fog/management , update the schema, and I’m your uncle.

    So I have a workaround that completes the process, but it doesn’t explain why it fails to begin with.



  • Found it… I think. I’ll get back in a sec.


  • Senior Developer

    @sudburr what’s the error or errors you’re seeing in the Apache error logs? Centos 7 I believe uses systemd and needs systemctl restart mariadb



  • Interestingly, removing mariadb-server prior to attempting the upgrade, the installer breezes through the MySQL setup/start.

    But 404 remains.



  • Reinstalling mariadb is a bad thing, mkay. Toasted the database. Sends me to the schema updater, then error 500.

    I don’t know how much cleaner from scratch I can make this install, but at no time is MySQL available as a service.


  • Moderator

    @sudburr said:

    Issuing prior to update attempt:

    systemctl restart mysql
    Failed to issue method call: Unit mysql\x2a.service failed to load: No such file or directory.
    

    This is CentOS. It uses MariaDB .

    I’ve got a fog box right here running CentOS 7 and systemctl restart mysql works fine.

    If you’re still getting this error, try reinstalling mariadb and mariadb-server

    yum remove mariadb mariadb-server
    yum install mariadb mariadb-server
    


  • Issuing prior to update attempt:

    systemctl restart mysql
    Failed to issue method call: Unit mysql\x2a.service failed to load: No such file or directory.
    

    This is CentOS. It uses MariaDB .


  • Developer

    Did you try restarting mysql by hand? What do you see? service mysql restart



  • Roughly 100 GiB free.

    Build 5032 fails identically.

    I’m not finding any smoking gun yet other than maybe this snippet from /var/log/httpd/error_log .

    [Wed Oct 21 14:48:54.808829 2015] [mpm_prefork:notice] [pid 908] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed Oct 21 14:49:37.254328 2015] [suexec:notice] [pid 911] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Wed Oct 21 14:49:37.364932 2015] [ssl:warn] [pid 911] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Wed Oct 21 14:49:37.444596 2015] [auth_digest:notice] [pid 911] AH01757: generating secret for digest authentication ...
    [Wed Oct 21 14:49:37.446351 2015] [lbmethod_heartbeat:notice] [pid 911] AH02282: No slotmem from mod_heartmonitor
    [Wed Oct 21 14:49:37.449064 2015] [ssl:warn] [pid 911] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Wed Oct 21 14:49:37.501595 2015] [mpm_prefork:notice] [pid 911] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.6.14 configured -- resuming normal operations
    [Wed Oct 21 14:49:37.501657 2015] [core:notice] [pid 911] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    BFD: /var/www/html/fog/service/ipxe/bzImage: Warning: Ignoring section flag IMAGE_SCN_MEM_NOT_PAGED in section .bss
    BFD: /var/www/html/fog/service/ipxe/bzImage32: Warning: Ignoring section flag IMAGE_SCN_MEM_NOT_PAGED in section .bss
    [Wed Oct 21 14:59:20.250823 2015] [mpm_prefork:notice] [pid 911] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed Oct 21 15:00:09.666114 2015] [suexec:notice] [pid 949] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Wed Oct 21 15:00:09.740593 2015] [ssl:warn] [pid 949] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Wed Oct 21 15:00:09.889696 2015] [auth_digest:notice] [pid 949] AH01757: generating secret for digest authentication ...
    [Wed Oct 21 15:00:09.891447 2015] [lbmethod_heartbeat:notice] [pid 949] AH02282: No slotmem from mod_heartmonitor
    [Wed Oct 21 15:00:09.894049 2015] [ssl:warn] [pid 949] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Wed Oct 21 15:00:09.944900 2015] [mpm_prefork:notice] [pid 949] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.6.14 configured -- resuming normal operations
    [Wed Oct 21 15:00:09.944968 2015] [core:notice] [pid 949] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    

    Patching CentOS, rebooting, and manually restarting services have no effect.

    systemctl restart FOGImageReplicator FOGMulticastManager FOGPingHosts FOGScheduler FOGSnapinReplicator mariadb vsftpd httpd
    

  • Senior Developer

    What if you restart MySQL directly? My guess is disk space. Check that you have enough disk space with df command. Clear some space by removing the backup folders default stored to /home. You’ll likely find a ton of .BACKUP folders that are currently eating space.


Log in to reply
 

365
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.