Bootmgr is missing and sysprep fatal error



  • Hello everyone,

    I successfully upload the windows 7 image from the client side (Laptop) to the fog server (Linux Ubuntu 14.04 Choosing Multiple Partition Image Single Disk (Not Resizable)

    Then I swap another new “formatted” hard drive to the client side then try to deploy the windows 7 image which I create earlier on it.

    However, The error massage pops out said “BOOTMGR is missing”.

    I did some research that I might need to run Fogprep and sysprep. (Although this step might only suitable for under fog 0.32)

    I ran the sysprep then there is another error massage pops out “Fatal error occurred while trying to sysprep the machine”

    I tried to modified “HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\SysprepStatus to 7”, it didn’t work.

    And I can’t find any “unattend.xml” file in the sysprep folder.

    Any advice can be helpful.

    If you need more details about my hardware, software, OS, config. Please let me know, I will update as soon as possible.

    Thank you.


  • Developer

    Thanks for letting us know! I’ll mark this thread solved for now. Feel free to ask more questions here (if related) or better start a new one.



  • Hi,

    Sorry about the late reply.

    I resolve the problem by reinstall the fog server as my supervisor impose my computer for emergency usage so he wipe out all the drives.

    I will try to test other method and if I have further questions I will post on the forum.

    Thank you everyone.


  • Moderator

    @stan6595 Can you look to see that after you upload a resizeable image, the OS partition exists inside of /images ? Can you give us a screenshot or copy/paste of the directory after a resizeable image upload for the system in question?



  • There is no error, however it seems that the fog server only deploy the “system reserve partition” (275MB) to the new drive without the entire Windows 7.


  • Moderator

    @stan6595 What errors are given for the other partitions when you try to use resizeable?



  • True. I should double check my later one. It’s only 250 GB and my original one is 400GB.

    Is there anyway to overcome it? I tried the resizeable option, however the fog server only make the image of System Reserve (around 275MB) from my client computer


  • Developer

    There you go… The second partition is too big for the disk. How did you create the partitions on the initial disk (the one you pulled the image from)? Are the two disks you are using the exact same size. Or is the later one smaller by any chance??



  • Thank you @Uncle-Frank and @Hanz .

    Sorry about the misunderstanding @Uncle-Frank , I reboot my laptop again and get in to the debug mode and type in the command

    fogpartinfo --list-parts /dev/sda
    

    All I got is this message

    Error: Can't have a partition outside the disk!
    

  • Developer

    @Hanz I am sure you want to help. But most of the things you wrote do not apply in this case. This is not a resizable image (therefore you see less files in the image directory!), not trunk version and as I already said in my first answer neither fogprep nor sysprep is needed.

    We are trying to see what’'s going wrong in stan6595’s setup (FOG 1.2.0) and I don’t feel like you are pointing him the right direction. Please don’t get me wrong. I am very happy to see you being active in the forums here and appreciate you trying to help!



  • Your image is probably not complete…you should have all these files under that image folder.

    d1.fixed_size_partitions d1.original.fstypes d1p1.img
    d1.mbr d1.original.partitions d1p2.img
    d1.minimum.partitions d1.original.swapuuids

    For Windows 7 I use single disk resizable and it has worked fine so far. That error is from the hard drive not having a proper image installed. I would try recreating the image and make sure you have all the files. I am running trunk and also do not use FOGprep, but you will need to sysprep.

    SYSPREP will format and repartition the drive on install.


  • Developer

    @stan6595 What I meant was running fogpartinfo with parameters to list the partitions on the disk as you can see in my last post. Please try again and run:
    fogpartinfo --list-parts /dev/sda



  • Hi, @Uncle-Frank . Here is what I got from the client computer after I deploy a debug task from my fog server.

    IMG_0865.JPG

    After I run the commnad fogpartinfo
    IMG_0866.JPG


  • Developer

    I am really confused. From the screenshot I see that you never seam to see the (blue) parclone screens when trying to deploy. To me that usually means that something is “wrong” with the partitioning and therefore fogpartinfo cannot identify the partitions properly. But I have tried the following on a test machine and don’t seam to find any error. I booted a client in debug mode and ran the following commands (d1.mbr is the file you provided):

    # mkdir -p /mnt
    # mount -t nfs -o nolock x.x.x.x:/images /mnt
    #
    # dd if=/mnt/d1.mbr of=/dev/sda
    1+0 records in
    1+0 records out
    512 bytes (512 B) copied, 0.0679914 s, 7.5 kB/s
    #
    # fdisk -l /dev/sda
    Disk /dev/sda: 512 GiB, 549755813888 bytes, 1073741824 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xe0433380
    
    Device    Boot     Start       End    Blocks  Id System
    /dev/sda1 *         2048   2101247   1049600   7 HPFS/NTFS/exFAT
    /dev/sda2        2101248 489123839 243511296   7 HPFS/NTFS/exFAT
    
    # fogpartinfo --list-parts /dev/sda
    /dev/sda1 /dev/sda2
    

    Could you please boot the laptop with the new disk after (unsuccessful) deploy into debug task from the web interface and just run the fogpartinfo command?



  • Thank you everyone,

    Sorry about the confusion. I upload the client’s image first on to the fog server and pull out the original hard drive from the laptop then puts a formatted new empty disk into it.
    @Uncle-Frank Thank you for your explanation.

    I have those files in the /images/HPEliteBookGFLAP84

    Screenshot from 2015-10-16 09_53_51.png

    and here is my d1.mbr file

    d1.mbr


  • Moderator

    Hi.

    To fix the sysprep fatal error issue, simply stop the Windows Media Player Network Sharing service.


  • Developer

    @Wayne-Workman If I get his original post right he is using the same laptop and puts a new empty disk into it after pulling an image and before trying to deploy. So BIOS/EFI settings should not be an issue I guess.

    @stan6595 sysprep/fogprep is not compulsory. It’s usually used to create a “generelized” image that can be deployed to different hardware. No need if you want to image and deploy to the same laptop!

    What files have been captured when pulling an image?? ls -al /images/HPEliteBookGFLAP84 (on the FOG server)

    Could you please upload /images/HPEliteBookGFLAP84/d1.mbr to the forum?


  • Moderator

    @stan6595 I would check the firmware settings on the laptop you uploaded from. Pay special attention to Legacy/UEFI options and HDD Operation modes (RAID, SATA, AHCI, LEGACY, IDE, etc.) Make sure those match on the laptop you’re trying to deploy to.

    Also, do you know if your source computer’s HDD is a MBR type disk or a GPT type disk?

    And - is the HDD in the source computer totally blank? If it’s totally blank then, you will have some problems. FOG 1.2.0 is intentionally coded to not image a totally blank disk. If you throw any sort of partition on the disk at all or format it with a windows partition just as a external drive or 2nd drive or something similar, then FOG should be able to image it then.



  • Sorry, I should state clear
    Here is my background info

    Client computer:
    HP EliteBook Laptop with Window 7 64bit
    Fog Server computer:
    Desktop with Ubuntu 14.04
    Fog Server version: 1.2.0

    The “BOOTMGR is missing” message display after I finish download the windows 7 image and reboot my client computer.
    Those are the steps that I went through

    1. create task at Fog GUI to deploy the window 7 image to the client computer. (Around 15 GB on the server)

    2. restart client computer to get into network boot

    3. Client computer get into normal process

    IMG_0860.JPG

    IMG_0861.JPG

    IMG_0862.JPG

    1. Then the client shut down itself. It didn’t continute to process any further

    2. I reboot the client computer, then the error message pops out

    bootMGR.JPG


  • Moderator

    Where does “BOOTMGR is missing” show up? During imaging? During trying to boot up after imaging? Can you give us a photo of that error?

    The model of the laptop would help, and knowing your FOG version would also help.


Log in to reply
 

412
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.