SOLVED TFTP Problem, Ubuntu 14.04 Fog 1.2.0 server on isolated network

  • Hi, Everyone

    I try to construct an isolated network using ubuntu 14.04.3 desktop version with FOG 1.2.0

    When I attempted to connect to the fogserver from my client computer, it show me those text


    After this screen show up, it display “No network found” and enter into the Windows desktop screen.

    Hardware List:
    Ubuntu 14.04.3 desktop version installed on one desktop
    Windows 7 Client HP EliteBook
    Connect two of them using a Trendnet Gigabit Switch TEG-S80g on an isolated network

    I will also provide my installation steps below

    1. Install Ubuntu 14.04.3

    2. Finish the upgrade

    3. Install FOG 1.2.0 (Using “FOG on an Isolated Network”)

    4. IP address :

    5. Using the fog server for dhcp service

    6. Update the database on the Fog Web GUI

    7. In the Fog Web GUI,

    *Go to FOG Configuration/FOG Settings/ TFTP Server

    *Go to Storage management
    Edit DefaultMember
    Set Management Username: fog
    Management Password: fog

    Then edit /var/www/fog/lib/fog/Config.class.php (see below) to edit the credential same as the credential in Web Gui.

    Screenshot from 2015-10-08 15_48_37.png

    **Here goes the troubleshooting: **

    1. I disabled the firewall.
    2. Check the TFTP Service:

    execute -> sudo /etc/init.d/xinetd status

    Screenshot from 2015-10-08 16_01_58.png

    I do not know how to read that information, but it stated the tftp service is running

    execute -> sudo /etc/init.d/xinetd restart

    3. TFTP Settings file:

    Screenshot from 2015-10-08 16_02_20.png

    4. DHCP Setting file: (/etc/dhcp/dhcpd.conf):

    Screenshot from 2015-10-08 16_13_44.png

    5. Network Connection:
    Connection Name: Wired connection 1 (Manual)
    Address :

    6. I also set the Permissions for server to grab the file

    ls -laR /tftpboot
    chmod -R 777 /tftpboot

    After those steps and follow the troubleshooting guide “Unable to connect to TFTP” from FOG Wiki.
    The problem still there, I have no idea how to resolve it.

    Please give me some advices or let me know what distribution of Linux might work the best for FOG server.
    If anyone successfully install the fog server on isolated network environment, please provide me the correct steps for installation.

    I’m appreciate. Thank you

  • @stan6595 Thank you for following up!

    If you have any other problems, never hesitate to start a new thread! (search for a solution first though)


  • Hello, Everyone.

    Here comes the update

    I tried to restart the tftp whcih @Tom Elliott mentioned below.
    I did edit my dhcp config just the exactly the same as @Wayne-Workman 's reply below.
    And I also add one more line refer from @Uncle-Frank 's reply below.

    I tried those methods separately, but didn’t work out well.

    However, when I combine those methods together. Fog server finally run and I can upload and download images to the machine now.

    Thank you everyone who contributes in this post.

    Note: there is a login fail problem with this particular setting. To resolve this issue, change your password through the database to modify your password.

  • Random other suggestion; check /tftpboot folder, see if undionly.0 exists. If it doesn’t, try this as root:

    cd /tftpboot
    sudo su
    ln -r -s undionly.kpxe undionly.0
  • Moderator

    In the packet dump I can see ‘Fragmented IP Protocol’ which means that the TFTP packets seam to be too big in your network. Usually ethernet has an MTU of 1500 and the blocksize of 1456 used here shouldn’t cause a problem. But somehow it does!

    Give this a try: Edit /etc/default/tftp-hpa and add the blocksize option

    TFTP_OPTIONS="-s --blocksize=512"

    512 is very small but should hopefully work for you. If it does you can crank it up step by step. By the way, what kind of network is this?

  • Can you try this for you ISC-DHCP configuration and see what happens?

    option space PXE;
    option PXE.mtftp-ip    code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16; # RFC4578
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    subnet netmask {
            option subnet-mask    ;
            range dynamic-bootp;
            default-lease-time 21600;
            max-lease-time 43200;
            option domain-name-servers;
    	#option routers      x.x.x.x;
        class "UEFI-32-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
        filename "i386-efi/ipxe.efi";
        class "UEFI-32-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
         filename "i386-efi/ipxe.efi";
        class "UEFI-64-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
         filename "ipxe.efi";
        class "UEFI-64-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
        filename "ipxe.efi";
        class "UEFI-64-3" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
         filename "ipxe.efi";
        class "Legacy" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
        filename "undionly.kkpxe";

  • It seems that the problem is the way you’re trying to start tftp. Ubuntu usually uses tftpd-hpa, not xinetd.


    sudo service tftpd-hpa stop; sleep 2; sudo service tftpd-hpa start

  • Thank you guys


    Here is the file from the WireShark from the very beginning of the connect to “Network Not Found” display on the screen



    I tried your methods, I mark out the line of option tftp-server-name. As a result, “TFTP timeout-PXE-E32” display on the screen and “Network Not Found” display on the screen

  • @ITSolutions Ah I didn’t see that. Nice catch.

  • Testers

    @Wayne-Workman I think you maybe right now that I look at his dhcpd.conf file a little closer I noticed option tftp-server-name line in his config. I have run into issues in the past with this. @stan6595 Can you try removing, or remarking this line out and restart your DHCP and see if that works for you? service dhcpd restart

    Not a guarantee, but like I said I have seen where it can be an issue. The next-server should be fine for passing the option to the client.

  • I think it’s DHCP related.

    Make sure it’s running. give it a restart too.

    service dhcpd status
    service dhcpd restart

    If it’s running with no errors, do a Wireshark capture to see if the DHCP server is giving out the options properly. Feel free to post the capture file (the .pcap file) here for others to look at.

  • Testers

    Have you tried a different client, just rule out that variable?