Fog Server on vSphere



  • Dear all,

    I’ve installed fedora server 22 on a VM on vSphere 5.5 followed the instructions at https://wiki.fogproject.org/wiki/index.php/Fedora_21_Server to install fog server but I can’t get it to work.

    Everything installed fine and fog server seems to be running fine but I can’t get a machine on the network to boot.

    I have a draytek router handing out the fog server ip on 66 and undionly.kpxe on 67.

    The machines seem to be getting the options but then just say:

    PXE-E32: TFTP open timeout

    I’ve been through all the steps at https://wiki.fogproject.org/wiki/index.php/Tftp_timeout… and still can’t get it working.

    I can manually get a file, settings look fine, I’ve disabled firewalls (on fedora and vsphere).
    I’ve tried capturing packets and looked at them with wireshark but don’t seem to be able to see anything coming from the ip of the computer attempting the network boot.

    Does anyone have any ideas?

    Is it best not to use vSphere at all? Is there a better version of Linux to use than fedora server 22?

    Totally stuck so any help would be greatly appreciated.

    Thanks in advance!



  • Thanks for all your help guys. Finally got it working. It was the draytek in the end. They seem to be a bit odd with DHCP option 66. Setting the option from the web interface wasn’t working so in the end had to do the following from telnet:

    srv dhcp option -e 1 -1 [lan number] -s [Fog Server IP]

    not sure what the -s flag is but it worked after that.

    Couldn’t find anything about this on the net so hopefully this will help someone else in the future!

    Thanks again!


  • Moderator

    You have turned off SELinux?

    I am suspecting this has something to do with the draytek router. You can confirm that it’s giving the correct options by doing a TCPDump on your server. there are steps listed here under the “troubleshooting” section: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    PXE-E32: TFTP open timeout almost always means a fundamental network issue.

    Also, what mode is the virtual NIC operating in? Is the adapter bridged?


  • Moderator

    @Mattak said:

    Thanks for the response. Good to know i’m not flogging a dead horse.

    Maybe I should just try ubuntu?

    Did you have to do anything special to your vSphere setup? Firewall etc?

    Fedora is ok, if you have the time you can try with ubuntu 14.04 (prefer LTS).
    I’ve not specific configuration in my ESXi.



  • Thanks for the response. Good to know i’m not flogging a dead horse.

    Maybe I should just try ubuntu?

    Did you have to do anything special to your vSphere setup? Firewall etc?


  • Moderator

    @Mattak said:

    Is it best not to use vSphere at all? Is there a better version of Linux to use than fedora server 22?

    ESXi is not a problem, I use it with the version 5.5 without problem.


Log in to reply
 

471
Online

38916
Users

10688
Topics

101382
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.