sending discover loop



  • Hello,

    I’m using fog svn 4050 and i’ve no problem with other machine

    I’ve got a problem with an old machine that i try to inventory or capture…
    It’s a NEC ML470 with only this network card : 82566DM-2

    Each time i try to boot on PXE i’ve got, in first, this error message : “bios bug #0[00000031]” found
    and the after that i’ve got this loop message "sending discover"
    I cant understand what happen

    On the same machine (windows xp) i cant install the new client
    Installation works fine but at the end without error message nothing is installed in program file

    Someone to help me ?

    Thanks


  • Developer

    Best would be to hook the client to a hub and capture traffic from there.

    Second best if you can capture TFTP-DHCP and FOG-server at the same time. I should be able to “synchronize” those two dump files by looking at the broadcast packets.

    And as a quick try you might just capture on the TFTP-DHCP server. Hopefully I am able to make the missing packets up myself.

    Useful tcpdump options:

    • -i eth0 capture interface, change to suit your needs
    • -w outfile.pcap write packets to PCAP file (you won’t see the packets while capturing!)
    • As last parameter you can add capture filters but this is quite tricky when it comes to PXE boot and DHCP (several different protocols and ports). You can simply use udp as a filter or not port 22 to keep your SSH session out of the way. Sometimes host x.x.x.x is also great but not in this case here.


  • @Uncle-Frank said:

    The ipxe.krn binary is actually in the format of a linux kernel. I am still wondering why this is working for you but the others don’t. If you are keen you could capture the boot traffic using tcpdump/wireshark and see what’s going on while you see "sending discovery loop"
    On wich server i run tcpdump ? My dhcp-tftp server or the fog one ?
    What should be the good command line to see everything with tcpdump ?

    Thanks for your help


  • Developer

    @plegrand Tom always has a bunch of different iPXE binaries compiled from the newest source. You find them here: http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/

    Here you can read about the different binaries - at least some of them: http://etherboot.org/wiki/gpxe_imagetypes

    The ipxe.krn binary is actually in the format of a linux kernel. I am still wondering why this is working for you but the others don’t. If you are keen you could capture the boot traffic using tcpdump/wireshark and see what’s going on while you see “sending discovery loop”



  • @plegrand Does the next version will include the ipxe.krn file from ipxe.org?
    Thanks



  • @ch3i Hello
    to explain my problem :
    cf schema here : http://plegrand1.free.fr/fog.png

    I’ve got 2 servers
    My own dhcp-tftp server named " PXE "
    the dhcp server is configured like that
    next-server 192.168.151.247;
    filename “pxelinux.0”;
    where 192.168.151.247 is PXE server address

    And the fog server named " FOG "

    I want to keep for the moment my own PXE server
    Then FOG is configured to not act as a dhcp server

    All my client boot pxe on my PXE server without problem.

    To use fog and boot pxe, i done the following
    copy the ipxe.krn file from /tftpboot of the fOG server to the /var/lib/tftpboot of the PXE server
    Add configuration on the PXE server (tftp) :
    KERNEL fog/ipxe.krn dhcp && chain http://192.168.39.243/fog/service/ipxe/boot.php?mac=${net0/mac}

    i made a test with a first machine everything works fine :
    the client first arrive of the menu of my PXE server
    I choose the fog option
    then the client arrive on the menu of the FOG server
    i choose any option and it works

    i made a test with a second machine :
    the client first arrive of the menu of my PXE server
    I choose the fog option
    then the client arrive on the menu of the FOG server
    i choose any option
    and then it loop on the message : “sending discover”

    these first tests was made with the latest svn version of FOG, but the ipx.krn file came from the stable version of fog (1.2)
    then i made the test again with the latest ipxe.krn from the svn version
    then nothing works :
    tftp://192.168.39.243/default.ipxe… no such file or directory (http://ipxe.org/2d12603b)

    and finally i made a test with the ipxe.krn file downloaded from ipxe.org and … it works !!!

    To be honest i dont know what is the problem
    may be somebody could explain me ??


  • Moderator

    @plegrand said:

    Hello,

    I’m using fog svn 4050 and i’ve no problem with other machine

    I’ve got a problem with an old machine that i try to inventory or capture…
    It’s a NEC ML470 with only this network card : 82566DM-2

    Each time i try to boot on PXE i’ve got, in first, this error message : “bios bug #0[00000031]” found
    and the after that i’ve got this loop message "sending discover"
    I cant understand what happen

    On the same machine (windows xp) i cant install the new client
    Installation works fine but at the end without error message nothing is installed in program file

    Someone to help me ?

    Thanks

    I’ve that bug with multiple network cards connected to two differents vlan. The “sending discover” is on the eth1, but the computer boot on the eth0 during pxe boot.



  • @cml Have you got an idea about the way to make works my installation ?

    i dont understand everythong but thanks ;-)


  • Moderator

    Let’s focus on the elephant in the room, shall we? You couldn’t install the new FOG Client on this machine??? Why not? If you can’t install a simple piece of software, you have much bigger problems.



  • It works if i dont use my own pxe, only my own dhcp server
    then i think my configuration to use my own pxe server is no good.
    But i cant find a way to configure it



  • @cml Hello,
    in first i explain my configuration.

    We’ve got our own PXE server (dhcp, tftp, pxe on linux server) configured like that

    DHCP :
    next-server 192.168.39.247;
    filename “pxelinux.0”;
    192.168.39.247 is the address of the dhcp server itself

    TFTP :
    i copy ipxe.krn /var/lib/tftpboot/fog directory and
    i add to my pxelinux conf this line :
    LABEL FOG_ETUDIANTS
    MENU LABEL Clonage de postes avec FOG pour les postes ETUDIANTS
    KERNEL fog/ipxe.krn
    APPEND dhcp && chain http://192.168.39.243/fog/service/ipxe/boot.php?mac=${net0/mac}
    192.168.39.243 is the address of the fog server.
    Then we dont use the dhcp of the fog server.
    After that everything i test on a client windows works fine.

    Then i try on other client windows :
    NEC ML470 with this network card : 82566DM-2 : FAILED ( “sending discover” loop)
    DELL OPTIPLEX 760 with this network card : 82567LM-3 : FAILED ( “sending discover” loop)

    During the pxe boot, the client get an ip address from our dhcp server, it seems that it loose this address after.
    I try resetting the BIOS default without success
    I upgraded bios without success
    What do you mean by " What switching do you use? "

    Thanks for your help


  • Moderator

    Have you tried resetting the BIOS to defaults? Are there any BIOS updates for that machine?

    It sounds like the machine is not getting an offer from your DHCP server, but without network logs I’m just guessing.

    What hosts your DHCP? What switching do you use? Are you able to capture packets via wireshark or tcpdump?


Log in to reply
 

440
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.