Debian Jessie 8



  • Hello,
    i’m trying to install fog on a fresh installed debian jessie (3 ethernet cards) and i’ve got some problems :

    When i install stable (1.2) version, the installation stop with this error message :

    • Starting FOG Multicast Management Server…Failed!
      Script terminé, le fichier est /var/log/foginstall.log

    When i install the trunk version (4021)
    The installer change default address ip and ethernet default interface (1.2 see eth0, trunk see eth1)
    The mysql-server installer doesnt ask to define password
    and the url of fog is http://192.168.151.243/html/fog/, not http://192.168.151.243/fog/
    To solve the problem of mysql-server 2 solutions :
    Install mysql-server before fog or use dpkg-reconfigure mysql-server-5.5
    But the problem of the url still here

    I tryied to install stable version then upgrade to trunk version (4021)
    I’ve got to change default ip and default interface
    and i’ve got to write in .fogsettings
    snmysqluser="user"
    snmysqlpass=‘password’;
    snmysqlhost=“localhost”;

    During upgrade i precise that image directory was /home/images
    in .fogsettings the path is ok
    in /etc/export the path is ok
    But the directory is not created during install

    What is the version to use with debian jessie ?

    Thanks for your help
    Pascal



  • @Tom-Elliott In first sorry if I seemed to insist heavily.
    As i said before your works is great and the help on the forum also.
    I will install fog as you explained me with “./installfog.sh -D /var/www -W fog/ -y” parameters.

    Sorry again and thanks again for your precious help ;-)


  • Senior Developer

    Because FOG 1.2. is a different animal than Trunk?

    I’ve worked VERY hard on the installer and entirety that makes up fog in trunk. While there are times of problems and issues, other minor things are presented that really don’t require much of a change.

    The current installer is MUCH more dynamic than it ever has been. First off, it doesn’t just link to your original document root any more. You can actually access your fog server through https now as well. It’s most likely this that’s posing the problem you’re seeing. This being a file I now generate that creates a virtual host definition on how to access your fog server. Document root is the “root location of the website you’re trying to access” This is different from webroot (the area you’re actually trying to view. Document root is what determines your location when you to a base url. Example: http://google.com
    this is a Root location of the domain you’re in. Where the files that are served up come from can be anywhere on your filesystem. You can define it to whatever, wherever you want it. So in the case of fog. If you wanted to access the fog management console without having the trailing /fog element (or whatever you call it) you would set the document root to be within the fog webs folder. If you want the trailing /fog element, you go one folder before it.

    This has changed though. Some versions of Ubuntu and Debian, for the longest time, set the documentroot to /var/www. Ubuntu 14 changed this and set the document root to /var/www/html. In 1.2 the “trick” because things were made assumed, was to create a symbolic link from /var/www/fog to /var/www/html/fog.

    I don’t know what other type of answer you’re looking for.



  • @Tom-Elliott … but why the 1.2 version install fog at the right place (/var/www) while svn version install it in /var/www/html ?
    ;-)


  • Senior Developer

    The problem isn’t a direct mistake in the installer. While I do know what you’re saying, I can’t agree fully. Debian and Ubuntu, for the longest time, had /var/www as the document root by default for a long time. They fairly recently changed their document root to /var/www/html. I believe the problem is the install still assumes /var/www is the default location. I’ll take a look tonight and see if I can figure out a way to approach it a little bit better.



  • @need2 now i agree with you : if you accept that mysql root has no password
    and if you know that if installer told you to go to http://192.168.39.243/fog it means you have to go to http://192.168.39.243/html/fog.
    I know it’s a ridiculous bug of the default installer (without parameters) but it disturbed me ;-)

    any way fog seems to be a great program, the forum is very reactif and it permit me to go on
    Then thanks again for your help i appreciate
    sorry for my poor english ;-)
    @Tom Elliot : i will try with --docroot to tell you if it works.
    But can you confirm me that the installer without parameters make a mistake between http://192.168.39.243/fog and http://192.168.39.243/html/fog to be sur we are agree ?

    Thanks again for your help everybody !!


  • Moderator

    I have installed FOG on a fresh Debian 8 system just fine using the SVN. If you are having this many issues already with your setup I might recommend wiping the system and installing fresh again, then grabbing FOG from the SVN the first time.


  • Senior Developer

    @plegrand That method will work. However, as Wayne is suggesting, if you specify the Document Root with the -D or --docroot arguments it should work. Have you tried this and it is not working?



  • @plegrand I don’t understand why you’re insisting that the directory be /var/www



  • @Wayne-Workman i made a symbolic link
    cd /var/www/
    ln -s /var/www/html/fog/ fog



  • @plegrand said:

    @Wayne-Workman but you agree it’s a litle bug ? or it’s a problem on my machine ?

    Yes it’s likely a non-impacting bug.

    And you can install with /var/www/fog with the commands below that I’ve provided.

    It’s also very easy to change the storage location via the Storage Management area in the Web Interface.



  • @Wayne-Workman but you agree it’s a litle bug ? or it’s a problem on my machine ?



  • @Wayne-Workman move storage is not an installer problem. With my tests with 1.2 the storage is defaultly on /images and there is no space enough here
    i’m going to reinstall trunk version
    Could you tell me what is the way to make that the installer install fog in /var/www/fog ?

    thanks for your help



  • @plegrand said:

    @Wayne-Workman is there a wa y to make that the installer install fog in /var/www/fog by default ?

    Not by default, but you can specify this with the installer’s arguments like this:

    ./installfog.sh -D /var/www -W fog/ -y



  • @Wayne-Workman is there a wa y to make that the installer install fog in /var/www/fog by default ?



  • @plegrand said:

    @Wayne-Workman
    it’s for this reason i’ll prefere to use stable version but i’ve got t launch twice 1.2 installer to make it works, and i cant change storage location

    You don’t need to change the storage location to upgrade to trunk. Can you explain the problem with more details?



  • @Wayne-Workman
    it’s for this reason i’ll prefere to use stable version but i’ve got t launch twice 1.2 installer to make it works, and i cant change storage location



  • @plegrand said:

    @Wayne-Workman when i launch the installer without parameters, at the end of installation it told me that fog is on " http://192.168.151.243/fog/" but it’s false because when i go to " http://192.168.151.243/fog/" it give me error 404 not found.

    and i can see that it install fog into " http://192.168.151.243/html/fog/"

    @Developers sounds like a minor bug.

    But, it in fact works?



  • @Wayne-Workman when i launch the installer without parameters, at the end of installation it told me that fog is on " http://192.168.151.243/fog/" but it’s false because when i go to " http://192.168.151.243/fog/" it give me error 404 not found.

    and i can see that it install fog into " http://192.168.151.243/html/fog/"



  • @plegrand You can change the command if you like to point to the directories that you want. :-)

    FOG Trunk is not FOG 1.2.0. Things change. You can set your user/passwords in the /opt/fog/.fogsettings file post-install, and then just re-run the installer afterwards and it’ll use the settings you wrote there.


 

345
Online

41.8k
Users

12.3k
Topics

116.0k
Posts