Apache Fails (trunk4004)



  • Installed the latest trunk (4004) and now my Apache fails. I can not re-install 1.2.0 now. Same error. I have tried removing, installing, nothing works. Please advise. Thanks



  • @Tom-Elliott Sorry for the delay in posting an update on this. On a whim, I pressed the “upgrade” option on the system update page to take it up to 14.04. Didn’t really think it would work, but if I’m going to start over, why not try. You were right. The newer version fixed the problems I was having. Downloaded the latest trunk version, and we’re off and running. Thanks again



  • I say Fedora all the way! Charge forth, thy mighty tech soldiers !!!
    https://wiki.fogproject.org/wiki/index.php/Fedora_21_Server


  • Senior Developer

    @mrbrown If you want to create a FOG Server from scratch, by all means do so as long as you’re comfortable. While I can’t assure you that all the packages you need will be accessible in older versions of linux, as I’m not in control of the repositories used to manage them, I can tell you that FOG has worked on these versions before.

    If you’re willing to update, choose what you’re comfortable with. I, personally, am not a fan of Ubuntu as the way they approach things is totally on what they believe linux should do/be what have, which, IMHO, is not how Linux was every thought to be. In either case, I have tested FOG on many linux platforms. Ubuntu (15, 14, 13, 12, 11, 10, 9), Fedora (22, 21, 20, 19, 18, 17, 16, 15, 14, 13, 12 <- I believe my first go around with FOG at all), Debian 8 and 7, CentOS (7, 6, 5), and now Arch, whatever the latest snapshot is.

    I’m a personal fan of Redhat based Linux (Fedora, CentOS, Redhat, and Mageia) but that’s because I started with Redhat Linux 7 (yes before it was Enterprise Linux). I became accustomed to the approach they use to handle packages and I like, even if now it’s being moved to dnf.

    If you want Debian variant, I’d recommend Debian 8.

    One of the niceties that Linux brings to people is the opportunity of choice and control. If you’re new, Debian/Ubuntu is probably better suited to help you start out, while I think Fedora/Redhat would be better suited to force you to learn things.



  • @Tom-Elliott I can save my images and make a new server. What should I use as a base? FOG will be the only thing on it.


  • Senior Developer

    My suspicion is your server Ubuntu version has fallen into the “oldreleases” category, making updates and other things much more problematic.

    You can look on this site:
    http://old-releases.ubuntu.com/releases/

    This same link would need to be updated for the archive.us.ubuntu.com and security.ubuntu.com areas of your /etc/apt/sources.list file.

    This is do at your own risk but should allow the proper files to be updated as they’re expected to for FOG to operate.



  • @Tom-Elliott trunk 4018, same result foginstall.log



  • @Tom-Elliott Tom, I would be lying if I said I knew where to look for a php.ini



  • I run 14.04 and seems to work great. Few hiccups here and there but overall is good. I would see what @Moderators think. Just to have a double check.



  • @Tom-Elliott The only change made, from a working SVN#3003?? was system updates and installing 4004. It had been working great, had an issue with an image uploading so I thought I would try the latest trunk. If I need to wipe it and switch to 14 (always thought that was a no no), or wipe it and start back with 12 again. I just need to get this up and running. Don’t get me wrong, I would like to keep what I have but if I can’t



  • I was having a similar issue with trying to update to 1.20 from .032 on a Elementary OS server. The dependencies were just so old and beyond repair it would have taken forever to debug and try to find al the little pieces that were not right. I just went ahead and reloaded my server with Ubuntu 14.04 and reloaded the server. Since then its been fine. I tried all that apache removal stuff and reinstall and it was always some little issue until i reloaded. Have you tried loading a FOG VM on your existing server to just narrow it down to the OS load on your machine?

    Don’t know if any of this sparks any ideas, but maybe it will help. :-)


  • Developer



  • Hi,
    For what it’s worth, this happened to me on Ubuntu 12.04 and the newer SVN’s. (from about 37xx) It started off with the “json” package failing. I followed a few threads to try and “fix” it but it ended up breaking the package manager. I’m guessing here, but something may be wrong with the extra package repositories added by the SVN and it breaks the package manager. I didn’t take a snapshot of the errors but it had to do with PHP5 and dependencies and was in an endless loop. After a couple of days of frustration and no online solutions, I bit the bullet and did a fresh install of Ubuntu 14.04.3LTS. Reinstalled FOG 1.2.0, then the latest SVN installed seamlessly. I had 3 nodes all on Ubuntu 12.04 and the SVN broke them all. With Ubuntu 14.04 the SVN installs fine. I’m still experiencing problems re-imaging but at least FOG is up and running. Hope this info helps.


  • Senior Developer

    @Wayne-Workman I’ve only seen the “threaded” error on our vps and that was relatively simple to fix. That said it was due to the php.ini file we need that allows php to run in threaded instances vs a single thread that php normally operates on. My question for the OP, what modifications have you attempted to make to you Apache configuration and do you have a php.ini.new file hiding in you php file tree?







  • Are you behind a proxy?





  • @mrbrown Very interesting. Can you remove both of these and then reinstall them manually?

    apt-get remove libapache2-mod-php5 apache2
    apt-get erase libapache2-mod-php5 apache2
    apt-get install libapache2-mod-php5 apache2
    

    I’m not really great with Ubuntu, but you get the idea right? Remove them and reinstall and try again.



  • @Wayne-Workman Made the change so it would run out and got thisfoginstall.log

    • Checking package: libapache2-mod-php5…Failed!
    • Restarting Apache2 for fog vhost…Failed!

 

360
Online

41.8k
Users

12.3k
Topics

116.0k
Posts