HP 500B MT will not PXE BOOT - File not found



  • I have successfully deployed a multi-hardware image to various HP computers (DX 2200, DX2400, PRO 2420, PRO 3010, PRO 3300 PRO 3400)

    However, HP 500B MT will not pxe boot, keeps giving the following :

    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error - File not found
    PXE-M0F: Exiting PXE ROM.

    I have had the motherboard replaced, and setup Windows XP from a CD and checked networking, and this is fine.

    Any ideas why this is not working? Need this model to work as we want to use FOG to deploy Windows 7 later in the year to around 200 computers.


  • Developer

    Just for anyone who runs into this in the future you can use a clone zilla live usb stick to pxe boot the system to fog.

    Takes a flash drive with 140mb of space and works really slick.

    I had this issue with our 500B MT’s.



  • Damindra,

    I created an Etherboot boot CD and it picked up the FOG server. So, I installed ProxyDHCP and now the HP 500B MT picks up the FOG server on PXE boot. Thanks, chad-bisd!



  • I have not had a chance to test the settings, and am a little reluctant as it works on all the other hardware we have here. You are more than welcome to try the settings advised by Aaron Johnson.

    Regards

    Damindra



  • Hi Damindra,

    Did you solve this problem? I am facing the same exact problem with HP 500B MT. Thanks very much!

    Ian Rossi



  • I will try the settings first before starting to look at ProxyDHCP

    many thanks for all your help on this

    kind regards

    Damindra


  • Moderator

    If you are interested in the ProxyDHCP setup, for Ubuntu at least, it’s on the wiki at: [url]http://www.fogproject.org/wiki/index.php?title=Setting_up_ProxyDHCP[/url]


  • Moderator

    If you are getting this error during PXEboot before it even loads the bzImage, AND it only happens for some models of computers, you may have a problem with the PXE firmware for the device. I have 270 Acer Iconia Tab w500p, and about 40 Compal JHL91 laptops that will not PXE boot, giving the “file not found” error. All other devices on the network can find and download the pxe boot file just fine.

    After scouring wireshark logs I saw that the ones that worked were getting the dhcp info from the dhcp server (next server) and requesting the pxe boot file and getting the chunks of the file in order. The ones that didn’t work were failing on getting the 2nd chunk of the pxe boot file. No idea why, they got the 1st chunk but died on chunk 2.

    I ended up installing ProxyDHCP to get it to work. It takes over the pxeclient dhcp requests and serves the pxeboot file without issue for all my devices: desktops, tablets, laptops, and servers from all makes and models.



  • try changing TFTP_USERNAME to “fog” and change TFTP_OPTIONS to “–secure”. Here is what my /etc/default/tftpd-hpa looks like:
    [CODE]

    /etc/default/tftpd-hpa

    TFTP_USERNAME=“tftp"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”–secure"
    [/CODE]
    …although I doubt this will fix your issue.

    Also make sure that you see these files under /tftpboot and that they have similar permissions to what I have:
    [CODE]
    root@localhost:~# ls /tftpboot -lh
    total 212K
    -rw-r–r-- 1 fog root 828 Apr 23 23:09 boot.txt
    drwxr-xr-x 5 fog root 4.0K Apr 23 12:27 fog
    -rw-r–r-- 1 fog root 25K Apr 23 23:09 memdisk
    -rw-r–r-- 1 fog root 17K Apr 23 23:09 pxelinux.0
    drwxr-xr-x 2 fog root 4.0K Apr 25 00:13 pxelinux.cfg
    drwxr-xr-x 2 fog root 4.0K Apr 23 12:27 tftpboot
    -rw-r–r-- 1 fog root 145K Apr 23 23:09 vesamenu.c32
    [/CODE]



  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • I have checked the /etc/default/tftpd-hpa file and it has the following entries:

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"
    so the TFT_DIRECTORY setting seems correct?
    Found that there is NO /srv/tftp but /srv/ftp?
    further help if very welcome!



  • Thank you for the reply and I will take a look and see. Strange how it only affects HP 500B Workstations, and all other models, older and newer than this particular model work!

    Will let you know if this resolved my issue.



  • I’m not sure if this is your problem or not but on recent versions of Debian Squeeze you must change the TFTP_DIRECTORY path located in /etc/default/tftpd-hpa from “/srv/tftp” to “/tftpboot”, or you can just symlink /tftpboot to /srv/tftp.

    I have updated the FOG Debian installation instructions on the wiki:
    [url]http://fogproject.org/wiki/index.php?title=Installation_on_Debian_Lenny[/url]


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.