Slow Upload issue



  • Well this is a comedy of errors. I loaded up .29 years ago on Ubuntu (ESXi box) and eventually went to .32. Been running great for years. We’ve had to play with the bzimage at times to get it to clone but it’s been awesome. We got some Dell 7020’s that wouldn’t work with .32 so we tried to build a new server. I tried three time with ubuntu 12.04 and 1.02. Must have missed something because it didn’t work either time. With updates. Without updates… I found a walkthrough that loaded 1.0.1 on 14.04 so I tried that. It worked! Didn’t know at the time that I was actually loading the SVN Trunk so looks like I’ve got 1.03 v4457. Changed my DHCP and inventory worked fine. Started uploading an image and oh well. I’ve got a problem. Starts out fine…over a Gig transfer rate. At 8 -10%, the transfer stops and stays on the same block. I timed the upload. The transfer rate starts coming down slowly and the first time it stayed on the same block for 9:10. Then it starts back fast and the rate starts climbing. 38 seconds later it hangs on a block again for 3:58. Starts fast again for 19 seconds, then hangs on a block for 3:59. Some of the hangs were down to 18 seconds but most were over 3 minutes. I’m going to use it like this till I get those 7020’s cloned.

    Any idea’s??

    If not, what would you recommend for going forward? Drop back and punt or do you think this is salvageable?


  • Moderator

    I love how this guy comes here - posts, gets impatient, posts again - then never comes back… and after he leaves, he gets 5 genuine pieces of advice from 5 different people - but he’ll never know that, will he?

    All of us here have Jobs man! We are volunteers for the FOG Project!



  • @Tom-Elliott Great Thought!!


  • Senior Developer

    I’m going to lean on the side, more, that this particular problem is specific to the network. Can you change the cable, and try to limit the number of hops to the server?



  • Have you looked at your compression. Fog 1.2 sets it default to level 9. I had the same issue after upgrading. Look under Fog configuration---->Fog Boot settings—>FOG_PIGZ_COMP. I bet it’s set to 9. Set it to 4 or 5. I run mine at 4 and all works great. Good upload and Download times. You can also set that config on the actually image management of the image itself. Hope this helps.


  • Moderator

    Also, what sort of box is the server AND client running inside of? I know the server is virtual, but it still can only run as fast as the hardware it is inside of.


  • Developer

    could some kind of network traffic throttling be taking place?


  • Moderator

    If you look in this list: https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    Your particular host model was verified as working a little over a year ago.

    That said, what sort of HDD is in it? Are the partitions MBR or GPT? Any encryption software on it? In the Firmware settings, what is the HDD Operation mode set to? And for kicks, what OS?



  • Should have also said “New server on same ESXi 4 box”. Different IP’s. Original Fog not uploading or downloading at the same time since I changed the DHCP. Ethernet using VMXNet 3 adapter on VM. Platter HD’s.


Log in to reply
 

484
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.