[SVN 4437 - Client 0.9.4] Unable to rename/join domain machine - Certificate problem


  • Moderator

    Hi,

    I have a problem with the new client, not sure that it’s a FOG bug…

    Below my log of fog client (OS : Windows 7) :

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     21/08/2015 09:33 Client-Info Version: 0.9.4
     21/08/2015 09:33 Middleware::Communication URL: http://x.x.x.x/fog/management/other/ssl/srvpublic.crt
     21/08/2015 09:34 Middleware::Authentication ERROR: Could not get security token
     21/08/2015 09:34 Middleware::Authentication ERROR: Impossible de trouver le fichier 'C:\Windows\system32\token.dat'.
     21/08/2015 09:34 Data::RSA CA cert found
     21/08/2015 09:34 Middleware::Authentication Cert OK
     21/08/2015 09:34 Middleware::Communication POST URL: http://x.x.x.x/fog/management/index.php?sub=authorize
     21/08/2015 09:34 Middleware::Communication Unknown Response: Failed to decrypt data
     21/08/2015 09:34 Bus Registering ParseBus in channel Power
    
    [......]
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     21/08/2015 09:34 Client-Info Version: 0.9.4
     21/08/2015 09:34 HostnameChanger Running...
     21/08/2015 09:34 Middleware::Communication URL: http://x.x.x.x/fog/service/servicemodule-active.php?moduleid=hostnamechanger&mac=A0:D3:C1:4D:C5:2C||00:00:00:00:00:00:00:E0&newService=1
     21/08/2015 09:34 Middleware::Communication Response: Success
     21/08/2015 09:34 Middleware::Communication URL: http://x.x.x.x/fog/service/hostname.php?moduleid=hostnamechanger&mac=A0:D3:C1:4D:C5:2C||00:00:00:00:00:00:00:E0&newService=1
     21/08/2015 09:34 Middleware::Communication Response: Invalid host certificate
     21/08/2015 09:34 Middleware::Communication URL: http://x.x.x.x/fog/management/other/ssl/srvpublic.crt
     21/08/2015 09:34 Middleware::Authentication ERROR: Could not get security token
     21/08/2015 09:34 Middleware::Authentication ERROR: Impossible de trouver le fichier 'C:\Windows\system32\token.dat'.
     21/08/2015 09:34 Data::RSA CA cert found
     21/08/2015 09:34 Middleware::Authentication Cert OK
     21/08/2015 09:34 Middleware::Communication POST URL: http://x.x.x.x/fog/management/index.php?sub=authorize
     21/08/2015 09:34 Middleware::Communication Unknown Response: Failed to decrypt data
    ------------------------------------------------------------------------------
    

    I’ve found some topic, but none helped me.


  • Moderator

    @ch3i said:

    @Wayne-Workman said:

    @ch3i Can you use a virtual machine this time? Snapshots really honestly are lifesavers!

    My server is always virtual. I’m a warrior > no snapshot !

    lol, no you’re crazy lol.


  • Moderator

    @Wayne-Workman said:

    @ch3i Can you use a virtual machine this time? Snapshots really honestly are lifesavers!

    My server is always virtual. I’m a warrior > no snapshot !


  • Moderator

    @ch3i Can you use a virtual machine this time? Snapshots really honestly are lifesavers!


  • Moderator

    For the legacy client it was a AD password mismatch… so stupid.

    I’ll install it instead the new client for the moment.


  • Moderator

    @Wayne-Workman said:

    @ch3i So it’s stuck in a reboot loop? What point does it restart at?

    After reboot loop I remove the ethernet and stop the service. I plug the ethernet and start the service (and reboot the machine to). Now there is no loop but the same error message.
    I will install a new server FOG…


  • Moderator

    @ch3i So it’s stuck in a reboot loop? What point does it restart at?


  • Moderator

    @Tom-Elliott What I’ve tried this mornig :

    • Remove fog client (legacy) on the host, remove the folder “fog” in program files
    • Remove the host on the UI and check in database
    • Register the host via the ipxe entry
    • Install the client (legacy) on the host
    • Now the host restart n restart n restart …

  • Senior Developer

    To fix, can you make sure there’s no data in there? Just open up the conflicting host and delete all data in there, including spaces, and save? Does this correct the problem?


  • Moderator

    @Tom-Elliott said:

    It appears, to me, that the error you’re seeing thrown is from alo-bg.php, but this should not be hindering anything else.

    The hostname changer, appears, to be because there’s a value in the product key field for the host, and the client that’s installed is using the defaults? Does this sound correct?

    On the web UI I’ve not product key but on the database I’ve ZHNkZnNkZg== … oO


  • Moderator

    @Tom-Elliott said:

    It appears, to me, that the error you’re seeing thrown is from alo-bg.php, but this should not be hindering anything else.

    The hostname changer, appears, to be because there’s a value in the product key field for the host, and the client that’s installed is using the defaults? Does this sound correct?

    No product key :s


  • Senior Developer

    It appears, to me, that the error you’re seeing thrown is from alo-bg.php, but this should not be hindering anything else.

    The hostname changer, appears, to be because there’s a value in the product key field for the host, and the client that’s installed is using the defaults? Does this sound correct?


  • Moderator

    @Tom-Elliott said:

    This problem seems specific to his environment. I do want to fix it, but I don’t know where the issue is occurring, or why for that matter.

    Not sure if it’s linked but the old client don’t work too… I have that error on apache :

    [Fri Aug 28 10:55:43 2015] [error] [client 172.20.4.15] PHP Fatal error:  Uncaught exception 'Exception' with message '#!im' in /var/www/fog/lib/fog/FOGBase.class.php:508\nStack trace:\n#0 /var/www/fog/lib/fog/FOGBase.class.php(521): FOGBase->getHostItem()\n#1 /var/www/fog/service/alo-bg.php(3): FOGBase->sendData('YzpccHJvZ3JhbSB...')\n#2 {main}\n  thrown in /var/www/fog/lib/fog/FOGBase.class.php on line 508
    
    

    And on the client :

     28/08/2015 11:20 FOG Service Engine Version: 3
     28/08/2015 11:20 Starting all sub processes
     28/08/2015 11:20 14 modules loaded
     28/08/2015 11:20  * Starting FOG.AutoLogOut
     28/08/2015 11:20  * Starting FOG.SnapinClient
     28/08/2015 11:20  * Starting FOG.DirCleaner
     28/08/2015 11:20  * Starting FOG.DisplayManager
     28/08/2015 11:20  * Starting FOG.GreenFog
     28/08/2015 11:20 FOG::AutoLogOut Starting process...
     28/08/2015 11:20 FOG::ClientUpdater Starting client update process...
     28/08/2015 11:20 FOG::ClientUpdater Sleeping for 158 seconds.
     28/08/2015 11:20  * Starting FOG.GUIWatcher
     28/08/2015 11:20 FOG::DisplayManager Starting display manager process...
     28/08/2015 11:20 FOG::GUIWatcher Starting GUI Watcher...
     28/08/2015 11:20  * Starting FOG.HostNameChanger
     28/08/2015 11:20  * Starting FOG.HostRegister
     28/08/2015 11:20  * Starting FOG.MODDebug
     28/08/2015 11:20 FOG::HostRegister Starting host registration process...
     28/08/2015 11:20  * Starting FOG.PrinterManager
     28/08/2015 11:20 FOG::MODDebug Start Called
     28/08/2015 11:20 FOG::GreenFog Sleeping for 37 seconds.
     28/08/2015 11:20 FOG::MODDebug Sleeping for 100 Seconds
     28/08/2015 11:20  * Starting FOG.SnapinClient
     28/08/2015 11:20  * Starting FOG.TaskReboot
     28/08/2015 11:20  * Starting FOG.UserCleanup
     28/08/2015 11:20 FOG::PrinterManager Starting interprocess communication process...
     28/08/2015 11:20 FOG::TaskReboot Taskreboot in lazy mode.
     28/08/2015 11:20 FOG::PrinterManager  interprocess comm startup: OK
     28/08/2015 11:20 FOG::TaskReboot Starting Task Reboot...
     28/08/2015 11:20 FOG::HostnameChanger Starting hostname change process...
     28/08/2015 11:20  * Starting FOG.UserTracker
     28/08/2015 11:20 FOG::HostnameChanger Yielding to other subservices for 6 seconds.
     28/08/2015 11:20 FOG::UserCleanup Sleeping for 19 seconds.
     28/08/2015 11:20 FOG::UserTracker Starting user tracking process...
     28/08/2015 11:20 FOG::SnapinClient Starting snapin client process...
     28/08/2015 11:20 FOG::PrinterManager Attempting to connect to fog server...
     28/08/2015 11:20 FOG::HostRegister Exiting because only 1 mac address was found.
     28/08/2015 11:20 FOG::DisplayManager Attempting to connect to fog server...
     28/08/2015 11:20 FOG::SnapinClient Sleeping for 424 seconds.
     28/08/2015 11:20 FOG::UserTracker Attempting to connect to fog server...
     28/08/2015 11:20 FOG::TaskReboot Attempting to connect to fog server...
     28/08/2015 11:20 FOG::UserTracker Module is disabled globally on the FOG Server, exiting.
     28/08/2015 11:20 FOG::AutoLogOut Module is active...
     28/08/2015 11:20 FOG::AutoLogOut Timeout value is Zero, disabling module.
     28/08/2015 11:20 FOG::AutoLogOut Le serveur distant a retourné une erreur : (500) Erreur interne du serveur.
     28/08/2015 11:20 FOG::AutoLogOut    à System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       à System.Net.WebClient.DownloadString(Uri address)
       à FOG.AutoLogOut.doWork()
     28/08/2015 11:20 FOG::DisplayManager Module is disabled globally on the FOG Server.
     28/08/2015 11:20 FOG::PrinterManager Module is disabled globally on the FOG Server, exiting.
     28/08/2015 11:20 FOG::TaskReboot Module is active...
     28/08/2015 11:20 FOG::TaskReboot Attempting to connect to fog server...
     28/08/2015 11:20 FOG::TaskReboot No job exists for 4C:72:B9:F9:52:E5
     28/08/2015 11:20 FOG::TaskReboot No task found for client.
     28/08/2015 11:20 FOG::HostnameChanger Attempting to connect to fog server...
     28/08/2015 11:20 FOG::HostnameChanger Module is active...
     28/08/2015 11:20 FOG::HostnameChanger AD mode requested, confirming settings.
     28/08/2015 11:20 FOG::HostnameChanger Impossible de trouver des chiffres reconnaissables. #can't find recognizable numbers
     28/08/2015 11:20 FOG::HostnameChanger    à System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
       à System.Convert.ToByte(String value, Int32 fromBase)
       à FOG.FOGCrypt.hexToByte(String hex)
       à FOG.FOGCrypt.decryptHex(String hex)
       à FOG.HostNameChanger.changeHostName()
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::UserCleanup Starting user cleanup process...
     28/08/2015 11:20 FOG::UserCleanup Attempting to connect to fog server...
     28/08/2015 11:20 FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GreenFog Starting green fog...
     28/08/2015 11:20 FOG::GreenFog Attempting to connect to fog server...
     28/08/2015 11:20 FOG::GreenFog Module is active...
     28/08/2015 11:20 FOG::GreenFog 1 actions found, validating...
     28/08/2015 11:20 FOG::GreenFog No tasks found after validation!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::DirCleaner Starting directory cleaning process...
     28/08/2015 11:20 FOG::DirCleaner Attempting to connect to fog server...
     28/08/2015 11:20 FOG::DirCleaner Module is disabled globally on the FOG Server.
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:20 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:20 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
     28/08/2015 11:21 FOG::GUIWatcher Message found, attempting to notify GUI!
     28/08/2015 11:21 FOG::GUIWatcher Dispatch Failed!
    
    

  • Senior Developer

    This problem seems specific to his environment. I do want to fix it, but I don’t know where the issue is occurring, or why for that matter.


  • Moderator

    @Wayne-Workman said:

    @ch3i Can you reset the encryption for the problem computer?

    Tom is working on the problem…


  • Moderator

    @ch3i Can you reset the encryption for the problem computer?


  • Moderator

    Hi,

    I’ve tried to install latest SVN, latest GIT, generate new certificate, rerun the installer of the client, … The problem is not solved.


  • Moderator

    @Wayne-Workman said:

    Have you tried resetting the encryption for this host? Host Management -> [click host] -> General -> Reset encryption

    I’ve not the reset encryption on the host.

    @Jbob said:

    @ch3i said:

    21/08/2015 09:34 Middleware::Communication Unknown Response: Failed to decrypt data

    That tells me the server keys are incorrect (specifically the public / private key pair). Whatever you do, do not regenerate the CA key, as this will require a re installation of all clients.

    @Tom-Elliott should be able to tell you how to regen the authentication key pair.

    I’ll test monday.


  • Moderator

    @Jbob said:

    @ch3i said:

    21/08/2015 09:34 Middleware::Communication Unknown Response: Failed to decrypt data

    That tells me the server keys are incorrect (specifically the public / private key pair). Whatever you do, do not regenerate the CA key, as this will require a re installation of all clients.

    @Tom-Elliott should be able to tell you how to regen the authentication key pair.

    Forgive me but, we really need some solid documentation on what NOT to do with the new client…

    I didn’t know that you could do something that would require a re-installation everywhere… that’s pretty terrifying.


  • Senior Developer

    @ch3i said:

    21/08/2015 09:34 Middleware::Communication Unknown Response: Failed to decrypt data

    That tells me the server keys are incorrect (specifically the public / private key pair). Whatever you do, do not regenerate the CA key, as this will require a re installation of all clients.

    @Tom-Elliott should be able to tell you how to regen the authentication key pair.


Log in to reply
 

412
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.