SOLVED SVN 4337 - Update Active Directory settings in Groups view

  • Guys,
    I noticed something after updating to SVN 4337 yesterday.

    When I changed the AD details for a group of computers, it did not propagate to the individuals in the group.
    I was having trouble with joining computers to the domain (self inflicted problem), so I created a dedicated user for the task. I changed the user name and password, in the default AD settings and also in the group, but noticed that my newly imaged machines were not joining the domain automatically.

    Is this a bug, or did I miss a step?

    I’m in the process of updating a few of them manually to see if they will join the domain.


  • @Matt-Rozema said:

    Also, I was changing AD settings **after ** the computers were imaged. Should the Fog service recognize that change and attempt to join them?

    Yes, long as all the service settings are checked and the “Join Domain” checkbox is checked.

    (EDIT) Unless they are already bound to another domain… 😕 I don’t know how FOG would behave then, but I wouldn’t expect it to behave as intended… simply because that’s not something that would normally get tested… sorry…

    Perhaps the @Developers and especially @Jbob could elaborate on this topic.

  • I’m updated to 4367 now.

    I thought that something was wrong because after imaging my computers, a specific group of them did not join the domain. I checked the log file on several of them and found an active directory error 8557. Google tells me this means the account reached its max number of computer joins to the domain. This prompted me to create a dedicated account that would not have this limitation.
    So then I created the dedicated computer-joining account. I went into every one of the group AD settings (I have seven groups at present), and updated the user name and both password fields in all of them. I restarted the Fog service on all of these computers and received the same AD error 8557 on all, but one (which joined the domain) in the problem group of computers. I went back to the group AD settings to make sure I didn’t miss anything. They looked right, so I checked the AD settings for the individual computers. All but one still had the old user name and password that wouldn’t join any more computers to the domain.

    I should’ve wrote this before sleeping on it, but I think I’ve got all the details in there. They might even be mostly in order. HA!

    Also, I was changing AD settings **after ** the computers were imaged. Should the Fog service recognize that change and attempt to join them?


  • As you decided, I would have recommended trying out your new credentials manually. If those work, then we will need a copy of the C:\fog.log from one of the hosts that failed. Also I’d advise updating like Tom said.

  • Can you please update to the latest? I don’t know how you’re determining that they’re not setting properly.