Orphaned Image Definitions when changing storage groups



  • Not sure if this is a bug or not, but I thought I’d say something about it.

    If you create a new storage group, and change existing storage nodes to be within the new group,

    Image definitions get orphaned. This happened when there were two storage nodes in the group, with one set as master (don’t know if it makes a difference or not).

    Deleting the image definition (but not the data) and then re-creating it and selecting the correct storage group fixes this.



  • @ch3i Oh… the storage group I moved the nodes to was empty. I had just made it. I didn’t quite catch where you were going with that.



  • @ch3i No idea… Replication was not even working in this particular instance. I think I disabled the FOGImageReplicator

    The data wasn’t gone. It was still there. Just the imaging process didn’t know where to look.


  • Moderator

    @Wayne-Workman said:

    @ch3i I moved them both to the new group… don’t remember which one I moved first.

    I ask you that but if I understand the fog replication, if you move a secondary node to another group as secondary node, all of images of previous group in this node will be remove and replace by the image of the new group, no ?



  • @ch3i I moved them both to the new group… don’t remember which one I moved first.


  • Moderator

    The node you change to another group is a secondary node or the master ?


 

448
Online

41.8k
Users

12.3k
Topics

115.9k
Posts