Fog on existing network, clients wont boot.



  • Hello all! I’m currently running FOG on top of Ubuntu Server 14.04 on an existing network. The network has an Untangle 11.1 server. I have setup fog with the correct setting according to the wiki (setup correctly pulled the IP, didn’t point towards dhcp server, dns, and said no to FOG running its own DHCP server). I then booted the client and it wouldn’t connect, I had the error:
    PXE:T01 File not found.
    PXE: e3B: TFTP file not found.
    PXE:M0F: Existing PXE ROM.

    So I began to search the internet for how to fix it. I added dhcp-boot=pxelinux.0, image-01, 192.168.1.140 to my untangle server under advanced settings but the problem persists. I have been trying for about a week now to get this to work and just can’t seem to make any progress. Any help will be greatly appreciated! :)



  • Figured out how to boot the computers in legacy so we went that route instead of figuring out how to do it with UEFI. Thanks to all who helped, especially @Tom-Elliott, who is a very cool dude. Happy to finally get to work!


  • Senior Developer

    I’m solving this thread.

    @jguest found the option to allow the physical systems to boot using undionly.kpxe. He’s using a pair between proxyDHCP so we linked the undionly.kpxe.0 file as necessary.

    I still want to figure out snp.efi but at least he is able to go on with fogging.


  • Senior Developer

    To everybody responding to this thread. @jguest systems are loading in UEFI/EFI and appears, from what he can tell, to only allow EFI. This means, no amount of .{,k,kk,}pxe will work at all.

    We made small progress with using the snp.efi file.



  • @jguest I had mentioned this in another thread, but you might try passing undionly.kkpxe as the boot file rather than undionly.kpxe. I have a lab of Lenovo Thinkstation E31s that had difficulty getting IPs and using the kkpxe was the only way I’ve been able to correct it.


  • Moderator

    Found this thread on the iPXE forums.

    No idea if this will help but all files were built with debugging enabled and latest commit as of today. It will also drop you into the shell on dhcp failure.

    tftpboot.tar.gz


  • Moderator

    I’d still say use TCPDump (in the troubleshooting section) and see what is going on between the client and server.



  • @Wayne thanks for the link. I tested from a Windows machine and was able to successfully download undionly.kpxe from the fog server. So this means tftp is working correct? Anyone have any idea why it still doesn’t want to boot and what’s up with the weird mac address?


  • Moderator

    You can take a look at this article: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    I’d highly recommend looking at the “Troubleshooting” bit and using Wireshark to see if your clients are even getting the correct info passed to them via DHCP. Of course, go through the other things in that article too.



  • @Junkhacker It’s a Lenovo C260. The mac address isn’t 01:01:01:01:01:01. Other computers fail to boot as well.


  • Developer

    @jguest what kind of hardware is in that computer? does it actually have a private mac address of 01:01:01:01:01:01 assigned to it?



  • So @Tom Elliott ended up connecting to my server for awhile and he made a lot of progress. Awesome guy btw. I’m not sure all he did, but the clients are now booting to pxe, but they hang before booting.

    Waiting for link-up on net0… ok
    Configuring (net0 01:01:01:01:01:01)… Error 0x040ee186
    Failed to get IP, Booting back to bios

    Any thoughts?

    A video on it just in case: https://www.youtube.com/watch?v=oKFCUGnjUSE


  • Moderator

    @jguest What’s the content or your tftboot folder and the rights on files under ?



  • More info: At first it wasn’t giving the option to press F8 for boot menu, after adding the "dhcp-boot=pxelinux.0,X.X.X.X " to Untangle it does now show up, grabs an IP, but then fails to load with the error messages in the original post.



  • @Tom Elliott I disabled the firewall on Untangle and the problem still persists. I’ve researched up and down and from what I see on the untangle forums other people who have gotten fog running have just had to add dhcp-boot=pxelinux.0,X.X.X.X to their dnsmasq (Config > Network > Advanced > DNS & DHCP) and that fixed it. I’m not sure where to add next-server as on untangle a lot of the config files get overwritten due to the gui. It looks like it is possible but in my case I’m not sure. I’m perhaps in over my head here…

    @ch3i Hi! It is 1.2.0


  • Senior Developer

    Is firewalld/ufw disabled? What is in your untangle servers next-server/option 66? What is in your untangle servers file name/option 67?


  • Moderator

    @jguest Hi, which version of fog is installed ?


Log in to reply
 

462
Online

38955
Users

10706
Topics

101580
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.