New Fog Client 0.8.4 - Hostname Changer not working


  • Testers

    I’m having an issue with the new client (0.8.4) changing hostnames. FOG SVN 3554 is installed.

    In the client log, I see this each time it runs:

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     6/12/2015 2:07 PM Client-Info Version: 0.8.4
     6/12/2015 2:07 PM HostnameChanger Running...
     6/12/2015 2:07 PM Middleware::Communication URL: http://172.16.200.10/fog/service/servicemodule-active.php?moduleid=hostnamechanger&mac=A0:A8:CD:B5:91:C7|14:58:D0:18:FA:B1||00:00:00:00:00:00:00:E0&newService=1
     6/12/2015 2:07 PM Middleware::Communication Response: Module is disabled on the host
    ------------------------------------------------------------------------------
    

    The module IS enabled for the host, and it is not globally disabled. Any ideas?

    Thanks!


  • Testers

    Appears to be resolved with SVN 3563.


  • Testers

    @Tom-Elliott “#!ok”


  • Senior Developer

    @MRCUR What’s the actual response if you go to the url in a browser?


  • Testers

    @Tom-Elliott said:

    If the HostnameChanger is globally disabled, and HostnameChanger isn’t working, could it be because it’s globally disabled?

    Sorry Tom, that was a typo. I just confirmed again that it is not disabled globally. I’ve tried disabling/enabling it at the host and server level as well with no luck.


  • Senior Developer

    If the HostnameChanger is globally disabled, and HostnameChanger isn’t working, could it be because it’s globally disabled?


 

356
Online

41.8k
Users

12.3k
Topics

116.0k
Posts