image upload error



  • I am trying to upload a new ubuntu 14.04 image to my fog server that I recently upgraded to 1.2.0. When it goes to network boot, it gets to /fog/kernel/bzImage… No such file or directory…could not boot. What do I need to modify to get this working right?


  • Moderator

    Better yet forget all of that mysql nonsense. You can add all of your hosts to a group and change Group Kernel to nothing, or whatever you may want there.


  • Moderator

    You could do it through mysql.

    This should only nullify the cells that contain fog/kernel/bzImage, but you can remove everything after the WHERE and have it set all hosts.

    UPDATE hosts SET hostKernel = NULL WHERE hostKernel="fog/kernel/bzImage";



  • @Wayne-Workman I just tried this and all I get in the csv is the MAC, Hostname, date the image was created and the image id. The hostKernel and hostKernelArgs fields don’t seem to export



  • You could export your hosts via the Host Management screen, and using excel, you could just delete the data for the ‘hostKernel’ and ‘hostKernelArgs’ columns… then re-import your hosts…

    Be sure to make a backup of your entire DB FIRST using FOG Configuration -> Configuration Save -> Export

    You could also just use the CLI to throw out the data in those two colums for that particular table… whichever one you’re more comfortable with.



  • @Tom-Elliott I hope I didn’t come off as rude earlier, certainly wasn’t trying to be. Here are the settings under my tftp server settings.

    FOG_TFTP_PXE_KERNEL_DIR /var/www/html/fog/service/ipxe/
    FOG_TFTP_PXE_KERNEL bzImage
    FOG_KERNEL_RAMDISK_SIZE 127000
    FOG_PXE_BOOT_IMAGE init.xz
    FOG_PXE_IMAGE_DNSADDRESS 127.0.0.1
    FOG_TFTP_PXE_KERNEL_32 bzImage32
    FOG_PXE_BOOT_IMAGE_32 init_32.xz


  • Senior Developer

    @the_duke what is the setting for kernels and units under fog configuration/fog settings/tftp server



  • @Tom-Elliott No Tom, that is not it. I did follow the instructions and changed my dhcp server to the correct setting. Some of my hosts that i created a couple of years ago still had the old kitchen sink kernel and when I went to push out an image to one of them it wouldn’t go until I deleted the host and re-registered it. That’s when I got to thinking about the old format for for where the directory stored the kernel. I originally had the kitchen sink kernel and a lot of my computers wouldn’t run on that kernel so I had to updated it periodically. For my server, a lot of the older hosts have the kernel tied to the old kernel in the host menu.


  • Senior Developer

    Follow the instructions? The dhcp server is still set to and out pxelinux.0, which is not present in 1.2.0 natively.



  • I’m not sure… I use one kernel for all my hosts… when I update my kernel via FOG COnfig -> Fog Settings -> kernel update, it applies to them all.



  • is there a way that I can change that for all of my old hosts at once or do I have to change that for each host? 1600+ hosts and I’d rather not have to do it manually if I don’t have to.



  • @Wayne-Workman Ok, I think that I might know what it was. In my host settings from my old images, the kernel was at fog/kernel/bzImage; I think that now it is just bzImage.



  • @the_duke yeah re-run the FOG installer.



  • @Wayne-Workman When you say to re-run the installer, are you talking about the fog installer or something else?



  • @the_duke said:

    It sounds like your kernel is just missing.

    Try re-running your installer. It’ll re-use your previous settings, and won’t delete any data.

    If that doesn’t work, try deleting that host from Host Management and re-register it.


 

425
Online

41.5k
Users

12.0k
Topics

113.5k
Posts