Fedora 22 Server - issues with installer


  • Moderator

    Earlier today, I was helping install FOG Trunk via Team Viewer for @ftgjason on Fedora 22 Server.

    The installer failed over and over on the mysql bits, and on installing the various services… like all of the services that try in the early part of installation…

    I manually installed everything listed in the script using dnf
    And, I had to change /lib/redhat/functions.sh

    I changed the lines:
    [CODE]service mysqld restart
    service mysqld enable[/CODE]

    to:

    [CODE]service mariadb restart
    service mariadb enable[/CODE]

    And, instead of installing the DB using
    [CODE]dnf install -y mysql mysql-server[/CODE]

    I had to use:
    [CODE]dnf install -y mariadb mariadb-server[/CODE]

    I was talking to @Tom-Elliott about it earlier, he said

    617 if [ “$RHVER” == “7” -o “$linuxReleaseName” == “Fedora” ]; then
    618 systemctl=“yes”;
    619 systemctl enable mariadb.service >/dev/null 2>&1;
    620 systemctl restart mariadb.service >/dev/null 2>&1;
    621 else

    that’s the installer

    the else is

    service mysqld restart

    So, for some reason, Fedora 22 Server failed that check above… don’t know why…

    Just bringing these things to attention…

    I’m going to go out on a limb and assume that because this check was failed for the MariaDB parts, this is why pretty much every single other package failed also.



  • Another thing to keep in mind is that the installer will require remi repo.
    http://www.2daygeek.com/enable-remi-repository-centos-fedora-rhel/#


  • Developer

    3554 appears to have this fixed thanks to Tom.



  • It looks like it’s from this part of the .install.sh script where it tries to detect the distribution:

    if [ -f "/etc/os-release" ]; then
    	linuxReleaseName=`sed -n 's/^NAME="\(.*\)"/\1/p' /etc/os-release`;
    else
    	linuxReleaseName=`cat /etc/*release* 2>/devnull | head -n1 | awk '{print $1}'`;
    fi
    

    On Fedora 22 the installation has issues because there are no quotes around NAME’s value, so linuxReleaseName returns empty instead of with Fedora.

    Debian 8 also has installation issues related to this. Debian has the quotes, but the value is “Debian GNU/Linux” and the other scripts are looking for just “Debian”.


  • Moderator

    I just verified that r3530 and r3549 successfully do an early hostname change on Windows XP.


  • Moderator

    Maybe in the installer, there should be an option JUST for fedora?

    I know this has come up before in another thread… it might be for the best to just separate Fedora from the other RedHat stuff and let the user say what the OS is.


  • Moderator

    Also,

    @ftgjason said that hostname changing during imaging didn’t work for him. It was for a Win7 image. No idea why that didn’t work… maybe I installed the wrong package for it or something… idk. Maybe something is weird with his image… again idk…

    And, we did reboot the server and everything seemed fine, but then he said that the DB stopped working and he was getting errors. So perhaps one of the enable commands didn’t work… probably due to the version check for the OS failing… again I have zero ideas…

    Although I would suspect that if the version check worked, all would be just fine if he svn up’d and re-ran the installer.


Log in to reply
 

739
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.