LDAP plugin in 1.3 causes login issue



  • Hello, everyone.

    This is my first post to this forum. I just now upgraded from 1.2 to 1.3 and after installing the LDAP plugin I am getting a blank page upon logging in. no error just blank (in Chrome and IE). I fear I must have configured it wrong. :-( I have tried numerous things and can get back to my previous build of 1.2 but still i get a blank page after logging in. I also moved my original settings file so it would create a new one upon a fresh install and upgraded to 1.3 again and everything looks good but still get blank page after logging in. Is there a way to manually /unactivate/uninstall/comment out the LDAP plugin from loading without doing it through the GUI (which is borked)? That seems to be the only change that was made to make my FOG system unusable now. Not much of a picture I can upload but here is what the URL looks like on this blank page.

    upload-52c0176a-dab8-48eb-82cd-cb9bedb73dc9

    Thanks in advance,
    DM


  • Developer

    quickest fix rather than re-installing everything is: on the server rename /var/www/fog/lib/plugins/LDAP to something else like: LDAP1

    this will essentially stop the LDAP Plugin “loading”

    now you have access back - login to the GUI, deactivate/remove the LDAP plugin (under installed plugins) then rename /var/www/fog/lib/plugins/LDAP1 back to LDAP

    if you want to try again and re-check your setting you can now enable LDAP plugin again and if it fails follow the process above again to regain access…logs will be your friend here to figure out what’s wrong :-)



  • Although this isn’t a fix I’m going to reinstall and not try to mess around with 1.3 until it’s stable.

    Thank you, all


  • Senior Developer

    @Jbob Or look in the cloud of the logo on the GUI.


  • Moderator

    Yes.

    If you have SSH access, you can just export your entire DB to /tftpboot and then use tftp to grab the file. (that is, if MySQL isn’t broken). You could also install Samba (or use a linux machine to mount to your /images directory) and then grab your images.



  • No, it doesn’t take long at all. Can I at least keep the images/settings I’ve made? In reality if I can salvage the images themselves that is really the only thing that would be hard to lose.

    Thanks


  • Moderator

    @curvature said:

    run the 1.2 installer on top of it?

    … downgrading is not supported…

    I’d recommend wiping / reinstalling the OS. It doesn’t take long to do.



  • Thank you for the reply. I installed the 1.3 to GET the LDAP implementation but I need something stable and it’s not a requirement for my project. btw, I tried what you suggested and same result. If I’m downgrading from 1.3 is there a certain method I should be using or simply run the 1.2 installer on top of it?


  • Moderator

    @curvature said:

    OG system unusable now. Not much of a picture I can upload but here is what the URL looks like on this blank page.

    You could try restarting Apache, and perhaps reinstalling it.
    You could try reinstalling PHP.
    You could also re-run your fog installer (no harm).

    We need to know exactly what revision you’re using. 1.3.0 is not released yet. FOG Trunk is in developmental phase till release, and it’s in a constant state of flux.


  • Senior Developer

    What version of FOG? (1.3 is not released yet) You should be able to find the revision number in the installer / install logs.


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.