• can I add an iso? I googled and found some guides but they are for older version of fog, I’ve no /tftpboot/pxelinux.cfg/default file

  • @mmiat There is no “complete” guide because every occurrence is going to vary in some way.

    Sometimes ISO’s can be directly loaded as you attempted first.

    Sometimes they cannot. Which can and which can’t is not spelled out nicely.

    Most bootable ISO’s will not be an installer itself.

    Most installer CDs/DVDs will not be able to be directly bootable.

    You have to mount iso’s and use the relative kernel and initrd files from the CD to boot.

    Again, I have no clue which will work and which will not work. Nor am I about to test every possible ISO on the market to write a guide for every ISO.

    In the case of booting and installing from network using the net install ISO you downloaded, you will need to mount the ISO as if it’s another disk volume. Once it’s mounted, you can direct everything to look there and which files to look for. This should work fine for debian, ubuntu, fedora, or whatever linux distro you’re attempting. For Windows, I don’t know. They often require 4GB of RAM to load into in the first place and I’ve never really attempted such a feat myself. GParted, if it’s got instructions. should work in a similar manner to Debian.

    The link I gave earlier should at least provide some insight as to what needs to be loaded from the relevant disk, which is why I provided. There is no guide because it is a completely case by case situation.

  • I’m not frustrated with you or this thread, but with the fact I can’t find a clear and complete guide where I can understand how to use FOG. it’s clear that I’m newbie of this product, but I’d like to study a guide and after, with some background, ask in the forum. I think it’s not practical to ask you every single thing I need to do…

    I want to boot and install from network debian 7, debian 8, gparted, windows 7: is there some complete guide where I can understand how I can do or have I to merge from many forum’s threads? thanks

  • @mmiat What are expecting from us?

    I provide what I could to assist.

    I’m sorry it isn’t operational for you at the moment, but just giving up on it isn’t going to fix the issue either.

    You provided your configuration, but you haven’t provided what it is you’ve actually tried. IE modified configuration, file system layout, etc…

    How can we help you, if we have NOTHING to work from?

  • all this stuff is starting to boring me
    kernel panic error, no media error, and no guide/howto
    I’m very frustrated

  • Bump - still working on this at the house.

    Worked on an automated SAMBA installation script that integrates with FOG Trunk… Just so I could easily place my ISOs on the FOG server.

  • I’m trying but an error appers but it’s to quick and I can’t read it, I can only see “file not found”
    how/where I can see logs?

  • For an example of how to load see this link:


  • @mmiat I’m glad you were able to get it to boot, even if it is just a failure to load further than the scan of the CD/DVD drive.

    The particular problem, now, that you’re facing is due to how many installation ISO’s operate. These kinds of CDs are not designed to be booted and run from the network. They’re designed to run off a CD which is why it fails when it can’t find the cd.

    To get things to boot/install, you need to mount the ISO and load the kernel and initrd files outside of the scope of the ISO itself.

    Linux is pretty sweet in that you can mount ISO files directly without having to burn the files to a disk.

    Something such as:
    mount -o loop /path/to/iso/isofile.iso /location/to/mount/iso/to

    Then you would create the menu entry to load its relevant kernel, usually vmlinuz, and initrd, usually initrd.gz

  • DONE!

    but it’s not so clear how to do…

    1. access fog web interface, go to “FOG Configuration” > “PXE Boot Menu” > “Advanced Configuration Options” and add the code I posted
    2. create iso folder in /var/www/fog/ and copy iso there


    after install starts it says “no cdrom found” and installation process hangs

  • last version, I’ve modified it many times, always with no results 🙂

    item debian7.8_64 Debian 7.8 64 Bits
    item debian8.1_64 Debian 8.1 64 Bits
    item Mint_Cinnamon
    choose --default debian7.8_64 target && goto ${target}
    initrd http://${fog-ip}/${fog-webroot}/iso/debian/debian-7.4.0-amd64-netinst.iso
    chain memdisk iso raw ||
    goto MENU
    initrd http://${fog-ip}/${fog-webroot}/iso/debian/debian-8.1.0-amd64-netinst.iso
    chain memdisk iso raw ||
    goto MENU
    initrd http://${fog-ip}/${fog-webroot}/iso/mint_cinnamon/lmde-2-201503-cinnamon-64bit.iso
    chain memdisk iso raw ||
    goto MENU

  • @mmiat can you post your config for the menu?

  • this morning I resumed original default.ipxe and it works, but how can I add iso using web GUI?

    instead, if I try to create a custom default.ipxe as you said I have "could not start download: operation not supported (http://ipxe.org/3c062003)
    FOG 1.2
    Debian 7.8
    permissions are ok, files are accessible using web interface

  • @mmiat What FOG version are you running? What Linux Distro? Where are you getting the error above? i.e. are you getting to the normal FOG Boot Menu then choosing Advanced Menu fails?

  • Testers

    check your permissions on the dir that contains your isos if it correctly set ups you should be able to hit it with a web browser like this. http://fog ip/fog/iso

  • @mmiat What did you try?

  • I tried but:

    Configuring (net0 00:24:etc)… ok
    /default.ipxe… ok

    and after nothing happens

  • FOG Trunk has features that allow easily adding items to the menu via the Web UI…

    Read through this article (especially at the bottom): https://wiki.fogproject.org/wiki/index.php/SVN

  • Developer

    In version 1.2 release it was noted that adding Menu items was difficult and needed to be cleaned up. This is the way to add a menu item using 1.2.

    @Joseph-Hales said:

    Try this thread https://forums.fogproject.org/topic/4212/add-a-livecd-entry-in-network-boot-menu


    If you update to SVN(trunk) you will find that adding menu items has become a little less complicated. To my knowledge a wiki has not yet been created to accommodate 1.3’s update but it is currently being worked on.