SVN 3513 - Unable to Locate Image Storage



  • I have another problem and have been searching the forums (and google) for a solution and I have yet to find one.

    So I am able to now successfully register a host. This host in particular is an older machine (using Windows XP), and the image being used was one that was migrated over to the new SVN version way back from FOG 0.32. So I’ve set the image to “Single Disk - Resizable” and “PartImage”.

    I have went through much of the troubleshooting steps to resolve this issue including the ‘touch’ commands for the storage locations…editing the etc\exports file…changing the file/folder permissions of the storage locations…and I have yet to solve this problem. Any help is always appreciated.

    IMG_20150605_1002492241.jpg


  • Moderator

    @crosser said:

    Actually, now that I’ve looked at my own picture again, I see something wrong.

    So my image name is “5700dec2012”, but the location in the picture above is wrong…

    The correct location should be /images/fiber-storage/… not simply /images/…

    How do I fix this?

    Doublecheck that your /etc/exports reflect the correct path to the images, also. Can you post a copy here?


  • Moderator

    Oh and also -

    I don’t know if you’ve done this or not but bad permissions on those images would totally break FOG.

    They should be set as 777 recursively.

    [CODE]sudo chmod -R 777 /images/fiber-storage[/CODE]

    Are you using a NAS, by chance? what is “fiber-storage” ???


  • Moderator

    the image being stuck in /images/dev is a common problem people have.

    It is usually due to incorrect credentials.

    Check this out:
    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP



  • One more quick update before the weekend…

    So after the image upload took place on SVN 3513, I tried to deploy it back down, but it was unsuccessful because when I tried to assign the deployment task, I received the following error:

    Failed to create deployment tasking for the following hosts

    You must first upload an image to create a download task

    I went and checked out the /images/dev folder and I found the image upload was stuck in there with its mac address. Any insight?



  • We did have a couple of images that we uploaded on FOG 1.2, so I went ahead and tried to deploy one of them on this new SVN 3513 and I received the same “Unable to Locate Image Store” error…

    On another note, it seems that I “am” able to upload an image. Once I upload a new image, I will deploy it back down for testing purposes.

    BUT I really can’t afford the time to have to re-upload all of those images individually… :(

    PS: I will plan to try to reinstall FOG using the latest SVN version on Monday once more. If it comes down to it, I may just remove FOG and retry all of this from scratch if nobody can figure this out. If I do decide to uninstall FOG, should I use these instructions found here? https://wiki.fogproject.org/wiki/index.php/Uninstall_FOG


  • Moderator

    I think the most simple (but maybe most time consuming) way to solve this…

    Is to get a spare old computer, install linux with FOG .32, deploy your images one by one to the appropriate hardware, and then upload those images to the new FOG server.

    I’ll look at this more when I get home… Because re-uploading all those would be incredibly time consuming.



  • @Wayne - No, unfortunately, this is not resolved yet. The picture of all of my images mostly consist of images created back with FOG 0.32. I have tried two different images/machines and I get the same “Unable to Locate Image Store” or “Unable to Locate MBR”.

    I have yet to test anything out with uploading a brand new image. But never-the-less, I would like to tried to resolve this issue with the older “PartImage” images.


  • Moderator

    Your path to 5700dec2012 looks correct.

    Can you verify that other images work? Can you upload a fresh image, then download it?

    EDIT

    I read further and see that you’ve solved your problem by changing the image type?



  • Here’s another picture of the images directory on my Ubuntu FOG Server. The one image I want to currently use is selected within the screenshot. Since these are older XP images, they were uploaded using “Single Disk - Resizable” instead of using “Multiple Partition Image - Single Disk”.

    PS: We no longer use “Single Disk - Resizable” going forward…but some of our older images/models still use it.

    Capture3.JPG



  • I tried changing the file path of the XP image, but I don’t think I’m doing something right. I have reverted the settings back and have taken additional screenshots for troubleshooting purposes.

    Capture1.JPG

    Capture2.JPG


  • Senior Developer

    The location you’re seeing there is the literal location it is mounted on the init.

    It mount’s the image directory of the path you have set on /images in the init.

    So that’s not the problem you’re seeing.



  • Actually, now that I’ve looked at my own picture again, I see something wrong.

    So my image name is “5700dec2012”, but the location in the picture above is wrong…

    The correct location should be /images/fiber-storage/… not simply /images/…

    How do I fix this?


  • Senior Developer

    What is the filename of the image in question. As it’s an xp the actual image file should be in the name of the image path itself. For example if the path/name was imagexp. The file name it should be seeking should be either /images/imagexp or /images/imagexp/imagexp


Log in to reply
 

1449
Online

38956
Users

10706
Topics

101581
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.